Windows 8 and 8.1 Forums

Possible networking driver corruption?

  1. #1

    Possible networking driver corruption?

    I have no sognificant issues on my laptop that started out as Windows 8.0 and hasn't much in the way of additional software or devices. My desktop is another matter. It started out with Windows 7 installed by Dell and the Windows 8 upgrade went smoothly. After the 8.1 upgrade a lot of stuff stopped working. All of the store apps didn't work and I can't install anything. I get an error code 0x80072ee4. I think it's related to the other major problem. After a ehile (1-6 hours) it loses connectivity to the router but the hardware layer still works as it can see if the cable is plugged. I plugged a USB network adapter in and it works and does not lose the network but after a long download (40-50MB) it hangs. If I use a download helper program, I can stop and restart or if I use my Usenet client which does this automatically, I can do gigantic downloads. Since the amount of time I can maintain a wired connection seems to be related to network load (overnight, it usually stays connected) I think these have a common cause.

    The only other bothersome thing is the Intel RST says the service is not running but the Microsoft services control panel says it's running and stopping and restarting doesn't fix it. Also, Iastore is using a lot of cpu (15%) compared to before.

    I ran all the Microsoft troubleshooters and reset the network via command line and did a System File Checker with no errors found. Also I checked my AMD (formerly ATI) drivers and AMD's utility says they are the latest (Microsoft says they "might" be out of date.

    Any suggestions?

      My System SpecsSystem Spec

  2. #2

    Not too sure on this one but from what I have read it may have to do with moving the temp files location to the wrong directory. The link explains what I'm talking about.

    apps won't install giving me a error code 0x80072ee4 - Microsoft Community
      My System SpecsSystem Spec

  3. #3

    My Temp Internet Files are still in the default location
      My System SpecsSystem Spec

  4. #4

    Quote Originally Posted by TheBigCheese View Post
    My Temp Internet Files are still in the default location
    With the store Apps not working the usual problem is either system file corruption or component store corruption.

    Try running the system file scan's outlined in the following link and let me know how it goes.

    Accessing internet
      My System SpecsSystem Spec

  5. #5

    Here is the answer. Microsoft distributes a defective NIC driver:

    Windows 8.1 loses wired internet connection
      My System SpecsSystem Spec

  6. #6

    Yes I'm actually the person who told the teddy bear person to look for other drivers because the default ones don't seem to be working as they should, that was a couple weeks ago however and in a different thread. It's not driver corruption though it was simply the wrong driver. Your explanation of the problem didn't really point to a driver problem with 6 hours between working.

    It's very strange that Windows 8.1 is installing some old Vista driver rather than a Windows 7 driver or an actual Windows 8.1 driver, especially for such a common NIC like Broadcom.

    I didn't look for drivers in your case as your system specs mention Dell XPS which doesn't really narrow it down and the Broadcom issue hadn't come to light.

    It seems that Windows was installing an older Vista driver which wasn't working but the Windows 7 driver is the one that worked. He was convinced it was a Windows 8.1 problem rather than a driver problem.

    The other fix I pointed you too is a more common problem with system file and component store corruption.
      My System SpecsSystem Spec

Possible networking driver corruption?
Related Threads
Never-ending system corruption in Performance & Maintenance
Hi, I am having more and more issues with Windows 8.1. This now reaches the point my computer is almost unusable because the behavior is just too erratic. There are many different issues so I am quite overwhelmed and just don't know what to do. ALL Metro applications stop right after I...
Greetings, I have a small problem with my system, that I am hoping someone here knows how to fix without a clean install. I recently had some trouble with my computer, which I won't get into all the details here, as many are irrelevant. During this I ran the System File Checker followed by the...
I am getting repeated Component store corruptions after any security updates. No metro apps will open yet an icon appears on the Taskbar. I have been able to repair it with DISM every time but that is beside the point. I want to know why!
Critical Structure Corruption BSOD in BSOD Crashes and Debugging
Hello. Attached is a copy of logs/dumps. I believe this is the 3rd time I've had this BSOD. It is completely random as far as I can tell. I wasn't pushing the computer very hard, just a few tabs open in my browser and listening to online radio. Any insight would be greatly appreciated.
Hi i'm reading TeraByte Unlimited ? View topic - W8 Corruption. there is the fix is 1) Open Control Panel. 2) Choose Hardware and Sound -> Power Options
File Corruption Problem... in Performance & Maintenance
Using the sfc command, I found some corrupted windows files but it was unable to repair them... Is there any way I can repair the files without having to reset or refresh my computer and lose everything I installed? I found something called DISM, but when I used it, it said unable to find source...
Hang ---> corruption in BSOD Crashes and Debugging
While playing audio, using either WMP or MPC, the system may hang, with a reboot the only option. This can occur after just minutes, or hours. It's then evident that the NTFS is corrupt on both the SATA drive (Win 8) and an SSD drive (W7) - all partitions. CHKDSK /f fires up. Otherwise the...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook