Windows 8 and 8.1 Forums


Windows 8.1 loses wired internet connection

  1. #11


    Quote Originally Posted by 2xg View Post
    I have upgraded my O/S from Windows 8 to Windows 8.1 Enterprise edition and luckily both my wired and wireless connections from my Samsung laptop are pretty stable. I am using WPA2 with AES encryption and no issues whatsoever. Sorry to hear that most of you are having similar issue. It's just unfortunate that Microsoft would give a free O/S upgrade but ended up causing some issues. Let me do some more research, hopefully that there will be Windows Updates and patches that would fix these issues.

    BRB.....
    Yes, it seems that there may be a module of code (perhaps a couple of hundred lines) that "talks" to the network adapter driver. Perhaps there was no need to revise it but someone did a "clean up" to help keep the OS size and load time down. In that case it might be easy to simply revert back to the Win 8 code. If there is actually an improved feature in the code then it will take a little more work to fix the problem. However some users are having a problem with some Sony laptops that don't connect to the network at all. That could be used to fairly quickly find out where the problem is. Hello!! Microsoft are you listening?

      My System SpecsSystem Spec

  2. #12


    Posts : 96
    Win 8.1 Enterprise


    bassplayer97 - Do you have a spare ethernet cable to try, a Cat5e or Cat6? Also, move the ethernet cable in a different ethernet port of your router.
      My System SpecsSystem Spec

  3. #13


    Quote Originally Posted by 2xg View Post
    bassplayer97 - Do you have a spare ethernet cable to try, a Cat5e or Cat6? Also, move the ethernet cable in a different ethernet port of your router.
    Oh, You mean one of those cables that will start working when you reboot the computer? Perhaps one of those cables that worked for the last 10 years with Win XP, Win 7 and Win 8 (and still do!) but don't work with Win 8.1?

    Sorry, checking cables is always a good thing to do. However, with all the reports of the same problem it seems to be a more difficult situation :-)
      My System SpecsSystem Spec

  4. #14


    Posts : 7
    Windows 8.1


    I've solved this on my machine now, might be worth a try for some of you...

    Head to device manager, find your network adapter, right click and select Uninstall. It will give you a check box to also remove the drivers, make sure it's checked. Once this has completed, restart Windows. Your network card will be picked up on reboot and Windows will install drivers automatically. This took me back to an older version of the driver than I had, but it's now working correctly.
      My System SpecsSystem Spec

  5. #15


    Quote Originally Posted by ActionFlash View Post
    I've solved this on my machine now, might be worth a try for some of you...

    Head to device manager, find your network adapter, right click and select Uninstall. It will give you a check box to also remove the drivers, make sure it's checked. Once this has completed, restart Windows. Your network card will be picked up on reboot and Windows will install drivers automatically. This took me back to an older version of the driver than I had, but it's now working correctly.
    Rebooting always "fixes" it for me until the next time it stops :-(
      My System SpecsSystem Spec

  6. #16


    Posts : 7
    Windows 8.1


    Have you tried what I suggested though? As mine always worked when I first booted. Might be worth a try...
      My System SpecsSystem Spec

  7. #17


    Quote Originally Posted by ActionFlash View Post
    Have you tried what I suggested though? As mine always worked when I first booted. Might be worth a try...
    Yes, I tried that early on. It simply gave me the driver I already had that the system said was the "latest". Perhaps the latest but certainly not the correct one. A driver for my Dell that appears to work can be found here
    Broadcom NetLink Ethernet Adapter issues with Windows 8.1 - Desktop General Hardware Forum - Desktop - Dell Community
      My System SpecsSystem Spec

  8. #18


    Posts : 3
    Windows 8.1


    I have a Dell Studio XPS (broadcom wired NIC) as well and the upgrade from 8 to 8.1 nuked my internet connectivity. Antivirus updating, HMA VPN, Chrome, Forefox & Opera do not load pages with the exception of Google sites. IE 11 loads most sites but not all. Outlook 2010 email also seems to work. I have posted to various forums without any luck.
    The closest resolution I did stumble upon (as posted above) was in a Dell driver forum where they suggested rolling back a 2009 driver and running it in Windows 7 mode. It looks like it worked for some but did not work for me.
      My System SpecsSystem Spec

  9. #19


    Quote Originally Posted by spaxz View Post
    I have a Dell Studio XPS (broadcom wired NIC) as well and the upgrade from 8 to 8.1 nuked my internet connectivity. Antivirus updating, HMA VPN, Chrome, Forefox & Opera do not load pages with the exception of Google sites. IE 11 loads most sites but not all. Outlook 2010 email also seems to work. I have posted to various forums without any luck.
    The closest resolution I did stumble upon (as posted above) was in a Dell driver forum where they suggested rolling back a 2009 driver and running it in Windows 7 mode. It looks like it worked for some but did not work for me.
    This is the driver I have installed in my XPS8100. http://dell.to/16nfwMF
    So far it is working however my problem was complete disconnect from the network not intermittent access of the web.
      My System SpecsSystem Spec

  10. #20


    Posts : 1
    windows 8.1


    For 3 days I have done everything that I found in internet, I have updated the Wi-Fi and Ethernet drives, disable adds-on, update internet options, use other Browser, etc. Nothing has worked for me in two different Toshiba Quosmio computers. So I decided to reinstall Windows 8 and another nightmare started. There are a Refresh and a Reset feature in Windows, in one computer the Refresh worked, it kept the files but I had to reinstall all the programs. In the other computer it failed due to another big windows 8 issue ("Some files are missing") that you can read about in the internet. I have not solved it that yet.
      My System SpecsSystem Spec

Page 2 of 6 FirstFirst 1234 ... LastLast
Windows 8.1 loses wired internet connection
Related Threads
Hi, I'm alright with technology but I've come across a problem I cannot solve. About two weeks ago I turned my laptop on and everything went blank, it couldn't read my drives, no data, nothing. After rebooting it a few times (with a lot of swearing and threatening to chuck it out of the...
I just installed a new wireless ac adapter and I do get a 1.3Gbps connection to my router. However when I test this connection by transferring some large files I get about 350Mbps for sending and 600 Mbps for receiving. When I transfer the same files with a 1Gbps wired connection I get about...
I've been having trouble with my internet connection for the past few days. It seems to be a battle between my router and modem, but my question is about the sidebar on windows 8. When I click on the internet connection icon (?) in the lower right hand corner, the sidebar appears, showing the...
This is the other random problem i am having all the normal things did not work sfc scan,malwarebytes etc etc no viruses etc clean pc....reinstall unistall drivers blah blah blah....Apparently its not grabbing a proxy from the network it seems ipconfig / all shows this
hello when i connect my hp probook 4520s to my sony vpcyb4ajg with Ethernet cable on my Hp wireless disconnects and can not be connected until i disconnect lan cable. but on my sony i have both wired and wireless connections simultaneously hp:win8 x64 realteck Ethernet and atheros wireless sony:...
My wife's Windows 8 Laptop loses internet connectivity frequently in our home. It still says connected and gives absolutely no indication that she has restricted or no access. She simply cannot access any kind of internet service. I made sure that all of her drivers have been updated. I...
Wired Ethernet connection Problem in Network & Sharing
Hi, I've installed Win8 to my laptop and tried to connect to our dormitory network. First, it has been working pretty well.. ..but since this morning*) I cant connect. The troubleshooter ends without success displaying: "Wired ehernet connection doesnt have valid IP configuration." I'm...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook