What's new

Solved Windows 8.1 loses wired internet connection

JHouse

New Member
I had this issue also'after update of windows 8.1. My wifi was working but couldn't use an internet connection via a cable ethernet. I resolved using the following:
1. Right hand side edge swipe
2. In the 'search'area write 'device manager'
3. select 'Network Adapters'
4. Select your ethernet connection device (mine was Realtek GBE Family Connector)
5. Select 'Uninstall' the device
6. Select 'OK'to confirm uninstall.
7. Restart my desktop. This installs the device driver again automatically. My wired connection shows up and is working.
8. Also... Right side edge swipe
9. Select the 'settings' icon
10. Select the network icon on bottom right hand side
11. Select my wifi connection
12. Un-select the option 'connect automatically'

Lastly the HP helpdesk (awesome group by the way), had me uninstall my wifi adapter and restart. This is to ensure I had the latest driver for my wifi.

After this all working well!

I have the same Realtek PCle Fe Family Controller. Tried all this, and it didn't work. As a matter of fact, it made the frequency of losing the connection increase. So I right clicked to update the driver and now it is back to "normal". On and off, on and off, on and off.............
 

My Computer

System One

  • OS
    Windows 8.1

bassplayer97

New Member
@JHouse,

Rolling back to an older driver seems to be the solution to this problem. Best bet would be to search with Realtek and find a driver that is one version ahead or behind of the one you have installed now.
 

My Computer

System One

  • OS
    Windows 8.1

JHouse

New Member
Found this on another site:

My adapter was set to auto negotiate the speed by default (it is burried away in Ethernet Properties / Configure / Advanced tab and Speed & Duplex property). Since changing this to "100 Mbps Full Duplex" a month or two ago I haven't seen a dropout again.

Would it be possible to get a little more detail as to how to do this?
 

My Computer

System One

  • OS
    Windows 8.1

Dude

Active Member
Power User
right click the network icon in the taskbar and click on open network and sharing center
click on change adapter settings
right click your ethernet icon and click properties
Click configure, then click advanced tab, then click speed and duplex and change the value

duplex.PNG
 

My Computer

System One

  • OS
    W10 Pro X64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Dude
    CPU
    Intel(R) Core(TM) i5-3570K CPU OC@ 4.5 GHZ Turbo
    Motherboard
    MSI Z77MA-G45 (MS-7759)
    Memory
    8.00 GB DDR3 1600Mhz
    Graphics Card(s)
    PNY GTX 760
    Sound Card
    Realtek High Definition
    Monitor(s) Displays
    Dell S23O9W, HP L1710
    Screen Resolution
    DELL-1920 x 1080 HP-1280 x1024
    Hard Drives
    Crucial m4 256 SSD WD 7200RPM 500GB
    PSU
    Seasonic X650 Gold
    Case
    Zalman Z12
    Cooling
    Antec Kuhler 920
    Keyboard
    Logitech
    Mouse
    MSI DS100 Interceptor
    Internet Speed
    50 down 5 up
    Browser
    Chrome, IE 11
    Antivirus
    Windows Defender
    Other Info
    Logitech X-620 Speakers

JHouse

New Member
Mother of GOD! I thinks it's fixed. If you were a beautiful single woman who wouldn't talk to my wife I would hunt you down and kiss you on the lips. Thanks Guys. This is HUGE.
 

My Computer

System One

  • OS
    Windows 8.1

JHouse

New Member
Well, it's back. No explanation. The settings remained the same. So how do I switch back to Windows 7 that I "upgraded" to 8.1? I don't want to pay for it again. :mad:
 

My Computer

System One

  • OS
    Windows 8.1

Dude

Active Member
Power User
Before you switch back, try a system restore to a date where it worked.
 

My Computer

System One

  • OS
    W10 Pro X64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Dude
    CPU
    Intel(R) Core(TM) i5-3570K CPU OC@ 4.5 GHZ Turbo
    Motherboard
    MSI Z77MA-G45 (MS-7759)
    Memory
    8.00 GB DDR3 1600Mhz
    Graphics Card(s)
    PNY GTX 760
    Sound Card
    Realtek High Definition
    Monitor(s) Displays
    Dell S23O9W, HP L1710
    Screen Resolution
    DELL-1920 x 1080 HP-1280 x1024
    Hard Drives
    Crucial m4 256 SSD WD 7200RPM 500GB
    PSU
    Seasonic X650 Gold
    Case
    Zalman Z12
    Cooling
    Antec Kuhler 920
    Keyboard
    Logitech
    Mouse
    MSI DS100 Interceptor
    Internet Speed
    50 down 5 up
    Browser
    Chrome, IE 11
    Antivirus
    Windows Defender
    Other Info
    Logitech X-620 Speakers

PCG

Member
Member
Solved!

SOLVED! I have a Broadcom Netlink (TM) Gigabit Ethernet card in a Dell Studio XPS 8100 and ran in to this problem after upgrading from 8 to 8.1 yesterday evening; I was getting ready to do a Macrium system restore, but ended up doing the following:

1. I tried CalBear's solution above: I visited Dell's website and downloaded the the older driver (12.4.0.3, dated 10/16/2009). I installed it, and the connection worked just fine.

2. However, after a little more research at Dell (using the link CalBear pointed out above: Broadcom NetLink Ethernet Adapter issues with Windows 8.1 - Desktop General Hardware Forum - Desktop - Dell Community), I discovered that Broadcom updated their driver in July 2013. The new driver version is: 15.6.0.10, dated 7/26/2013; I downloaded and installed their new driver and I'm 'up-and-running!'

For you Broadcom folks, here's the link:
http://www.broadcom.com/support/ethernet.nic/netlink_K57.php

Good luck!
 

My Computer

System One

  • OS
    Windows 10 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Dell Studio XPS 8100 in Corsair 200R Case
    CPU
    Intel Core i7-860 processor, (8MB Cache, 2.80GHz)
    Motherboard
    Dell (Chicony - DH57M01)
    Memory
    Corsair 16GB DDR3 SDRAM at 1333MHz-4x4GB
    Graphics Card(s)
    nVidia GeForce GTX 760, 2GB DDR5
    Sound Card
    OEM Integrated
    Monitor(s) Displays
    Dell ST2410, 24" Flat Panel Monitor
    Hard Drives
    256GB Samsung SSD 840 Pro-MZ-7PD256BW,
    Western Digital 1TB Caviar Blue-WD10EALX,
    2 Western Digital 2TB Black WD2003FZEX,
    1 Western Digital 6TB Green
    PSU
    Corsair CX600M (600 Watt)
    Case
    Corsair 200R mid-tower
    Cooling
    OEM
    Internet Speed
    Broadcom Netlink (TM) Gigabit Ethernet Card.
    Other Info
    This Dell XPS 8100 was transplanted in to a Corsair 200R mid-tower case in June 2015; The only Dell remnants are the motherboard and cpu, which will be upgraded some time in the future...

Gweezel

Member
Member
Before doing anything drastic--Device Manager / Network adapters / {your network card} / Power Management. Uncheck "Allow the computer to turn off this device to save power."
 

My Computer

System One

  • OS
    Windows 8 64-bit Media Center
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Dell 435MT (Modified)
    CPU
    i7
    Motherboard
    Dell
    Memory
    12 GB
    Graphics Card(s)
    Nvidia GTX 660 Ti 2 GB
    Monitor(s) Displays
    Dual 26" LG LED
    Screen Resolution
    1920x1080
    Hard Drives
    21.2 TB (8 TB on board, rest on network raid)
    PSU
    1000 W ThermalTake
    Keyboard
    Logitech G19, G13
    Mouse
    Logitech G600 MMO
    Internet Speed
    150Gb / 20Gb
    Browser
    Firefox

skitbow

New Member
right click the network icon in the taskbar and click on open network and sharing center
click on change adapter settings
right click your ethernet icon and click properties
Click configure, then click advanced tab, then click speed and duplex and change the value

View attachment 50812

Thank you. This resolved my issue. I was dropping internet as well. I would ping the default gateway and would get a huge fail rate. Before I tried this fix, I would have to unplug the ethernet cord and plug it back in so that it would reset. Now with this setting, it works amazingly well. Not disconnects.
 

My Computer

System One

  • OS
    Windows 7

bassfacer22

Banned
Member
Man what a mess..

Do you have a firewall on? Have you messed with any firewall rules??

I would just backup all your files you want to keep and clean fresh install windows 8.1 if you have your key..
 

My Computer

System One

  • OS
    Windows 8.1 (HOME not Pro) 64bit
    Computer type
    Laptop
    System Manufacturer/Model
    (So not very nice) Lenovo Y410P
    CPU
    i7 quad 2.4Gig
    Memory
    16G ram
    Graphics Card(s)
    nvidia 2gig 755m
    Hard Drives
    Samsung 840 Evo

    supercache2 m2. mini card.
    Antivirus
    Win Defender

RMax304823

New Member
Thanks Dude.

right click the network icon in the taskbar and click on open network and sharing center
click on change adapter settings
right click your ethernet icon and click properties
Click configure, then click advanced tab, then click speed and duplex and change the value

It seems to be so simple, yet it's worked for the past 2 hours. No disconnects -- yet. It was driving me mad.

View attachment 50812
:eek:
 

My Computer

System One

  • OS
    windows 8.1
    Computer type
    PC/Desktop
    System Manufacturer/Model
    hp 110
    Browser
    Firefox

Bluesky

New Member
I recently changed to Avast internet Security and started to experience frequent DNS connection drop out problems so I thought I would try the solution offered by ActionFlash (#26).
Using https://www.whatsmydns.net/dns/ I looked up my ISP (Optusnet) DNS server address and reconfigured my connection as advised.

I have no more problems, thank you.
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
Top