Windows 8 and 8.1 Forums

Windows 8.1 refuses to sleep

  1. #51

    Posts : 60
    Windows 8.1 Pro with Media Center

    Okay, you are definitely having better success than I am. I tried your suggestions and unfortunately as long as I have a Homegroup set up, the computers will not sleep. I even tried disabling the network adapter as you suggested. When I do not have a Homegroup created, the computer will sleep. However, once I create a Homegroup, the computer won't sleep, even if the network adapter is disabled.

    I also tried unsharing the files and folders on the user accounts, but that did not have an effect. I wonder what I'm doing differently than you. Are all three of your computers sleeping on the timer when you have Homegroup set up on all of them? Are you sharing files between all three?

      My System SpecsSystem Spec

  2. #52

    Posts : 60
    Windows 8.1 Pro with Media Center

    I don't believe it, I got it to work! Hot damn!!

    It took me some time last night, but I was finally able to get this fixed, and I owe it to you, johnpombrio, for getting me there! So I was having some initial trouble last night getting everything to work, but then I went back and re-read your posts. Here is what I did to finally get everything to work:

    • Before joining or creating a Homegroup, you must remove ALL shares from ALL networked computers. I realized that more than just the standard Music, Pictures, Videos, Documents libraries, I had also previously set up sharing for entire drive letters (example: I had shared the entire D and E Drive). I remembered that before I got wrapped up in the Homegroup mess, I was sharing files and folders using the old-fashioned way of sharing (as described under Option Two in this guide.) So, I had to unshare EVERYTHING.
    • In order to unshare EVERYTHING, I needed to know what I was sharing. I found this tutorial to be very helpful in identifying what was shared on each of my computers. From here, I removed sharing on EVERY FOLDER in the list (by right-clicking and selecting properties, then under the sharing tab, click on the advanced sharing button, and uncheck the box for "Share this folder". This allowed me to remove ALL of my shared folders. Yes, I even removed the share for Music, Pictures, Videos, Documents, D Drive, E Drive, Users, etc. Essentially, I had zero folders in this list.
    • Once I was confident that I had nothing shared on any computer on the network, then I created a Homegroup on Computer 1 and Joined the Homegroup on Computer 2. I started off simple and only shared one library on one computer, the Music library (which for me is all contained under one folder anyways). I set the sleep timer to 1 minute, and low and behold the damn thing went to sleep!!
    • From here I became bolder by incrementally sharing multiple libraries across both computers. In order to share additional libraries, I had to go into the Homegroup settings (follow this tutorial) and change them from Not shared to Shared. Again, keeping the sleep timer at 1 minute, both of them went to sleep. Okay, I'll be honest here, one machine has a Samsung 840 Pro SSD and 32 GB Corsair Dominator GT 2133 RAM, so it will idle to sleep pretty much on the 1 minute timer. The other machine has an older magnetic hard disk drive and 6 GB of slow-ish RAM, so it can take some time for it to finally put everything in memory and then sleep, but it does it.
    • My final test was sharing all libraries (Music, Pictures, Videos, Documents) on both computers AND re-establishing the full sharing on my D Drive and E Drive. I then set the screen saver for 5 minutes and the sleep timer to 20 minutes for both computers and walked away. I came back in the room in about 25 minutes and both computers were asleep. It was late, so I let them sleep overnight and came back to them this morning and they are both asleep, just like I want them to be.

    I think we finally got this figured out. The key was to remove all the previous shares before creating or joining a Homegroup.

    Thank you, thank you, thank you for helping me get to the bottom of this. If Connecticut wasn't so far from Texas, I'd offer to take you out to lunch today to celebrate! I am hoping that our success will allow others to find some relief as well. This was by far, one of the most troublesome issues I have yet to encounter, but I'm glad we got it figured out. Again, thanks so much for all of your help!
      My System SpecsSystem Spec

  3. #53

    Manchester CT
    Posts : 693
    Windows 8.1 Pro 64 bit GA

    Rockhound, congratulations! I pointed the way but you put in all the hard work to get it to run. Instead of lunch, you can upvote my reputation by clicking on the little thumbs up on one of my posts. In the meantime, go to the tutorial section here on the site and marvel at the wisdom that this site offers.

    With two of us now having the same results, it is definitely a bug in Win 8.1. As far as I know, I am the ONLY POSTER about this particular fix on the internet. Brink, if you are following this post ( and God knows you seem to be omnipresent on this site- luckily for us), would you like me to do a tutorial on how to fix this broken HOMEGROUP/sharing/sleep issue?

    The files/folders that were previously being shared on the old HOMEGROUP issue was exactly what hung up my my new HOMEGROUP/sharing/sleep also. I wish disabling the network adapter temporarily fixed it for you but it might be which computers have the broken file/folder shares that lets this work. If it was the machine you tried disabling the network, it must not temporarily fix the problem.

    Like Rockhound, I had to disable a LOT of files and folders to get HOMEGROUP to work. I did a kind of batch unsharing by selecting all the files/folders in a folder and then unsharing them all at once with a right click/unshare.

    And, yes Rockhound, this was a bitch of a problem!

    EDIT: NO FIX. It started having trouble again for the two of us within a couple of days.

    EDIT 2013-12-28 This did not fix the problem. For me, a MS update on Dec 11th fixed it.

    Last edited by johnpombrio; 28 Dec 2013 at 14:40.
      My System SpecsSystem Spec

  4. #54

    Posts : 102
    Windows 8.1 Pro x64

    I can confirm I have the same problem that you had guys: Activating the homegroup would prevent my PC from going to sleep. After I found out about this, I reverted all the other changes suggested in other troubleshooting guides to resolve the issue. Luckily, the idle-to-sleep functionality still worked, hence I was able to ascertain that the homegroup is the culprit and only the homegroup.

    I am now trying to unshare everything via Computer Management - this seems to be the most convenient way to do it in just a few clicks. However, it seems a bit weird during the process to undo some system shares like $ADMIN and C: (yes, C: is also a system-initiated share), but I'm proceeding with it anyways since Rockhound put the emphasis on unsharing literally EVERYTHING.

    I agree that this is definitely a Windows 8.1 bug.

    Here's another oddity I noticed while testing the sleep issues, and I would be curious whether your machine also exhibits this:

    My PC always need a couple of minutes more than the set sleep time. For example, I set the timer for sleep and switch off of the screen to both 1 minute. However, while I have not used a stopwatch yet, it more feels like 3 to 4 minutes before the machine goes to sleep. The reaction of the screen is accurate though, that is it darkens after exactly one minute. I cannot remember to have noticed such inaccuracy with Windows 8 before.

    Is the timer just a bug we can nothing do about or is it still a matter of settings?
      My System SpecsSystem Spec

  5. #55

    Manchester CT
    Posts : 693
    Windows 8.1 Pro 64 bit GA

    Steve, I just posted a definitive list of what to do with the HOMEGROUP on your original post (along with 25 8 by 10 color glossy photos with diagrams and arrows on the back of each one). Go look at that for additional help.

    The biggest change between Windows 8 and Windows 8.1 seems to be that you need ALL COMPUTERS up and running before making ANY changes to the HOMEGROUP! I ignored this completely when I joined the old HOMEGROUP on setting up Win8.1 Pro. I bet this is the cause of all these issues, joining a HOMEGROUP without all the other computers up and running at that time. Notice the verbiage in highlight:

    Click image for larger version

    So, boot all the machines, join the HOMEGROUP and keep your fingers crossed that it sleeps.

    Yeah, as I said in a bunch of posts, you need to wait a few minutes before sleep kicks in. The ONLY time you will ever notice it is when you are impatiently waiting for the damn thing to sleep!

    EDIT: NO FIX. I eventually completely disabled Homegroup but that only fix the sleep problem for a couple of days.

    EDIT 2013-12-28 This did not fix the problem. For me, a MS update on Dec 11th fixed it.
    Last edited by johnpombrio; 28 Dec 2013 at 14:41.
      My System SpecsSystem Spec

  6. #56

    Posts : 60
    Windows 8.1 Pro with Media Center


    Sorry to hear that you are having the same problems that we had. I think we can now confirm this to be a Windows 8.1 bug. Follow john's steps and that should fix it for you.

    I tried to add our laptop to the Homegroup today and had major problems. I fouled up sleep and Homegroup accessibility on the two previously set up computers. Frustrated, I came back to this thread and saw john's new post about having all computers turned on when doing this. So, reluctantly, I decided to start all over again.

    After unsharing all the folders on all computers and re-establishing the Homegroup on my main computer and joining the Homegroup on the other computers (including the laptop), I was able to get the Homegroup working properly again. I set the sleep timer to 1 minute on all three computers and waited. It took 13 minutes for one computer to sleep and 15 minutes for another computer to sleep. Unfortunately, the laptop is not sleeping. I'm not sure what I got wrong there, but I may have missed something. Interestingly, after waking up the other two computers, they went back to sleep on their timer (one computer does it in 1 minute, the other does it in 3 minutes.) Perhaps I had a process running in the background?

    Have you had any success following john's steps? I can't help but think that Microsoft will have to release a hotfix for this, as it is clearly a bug in Windows 8.1. Until then, I am hoping this workaround holds.

    johnpombrio, I definitely think a guide would be very helpful for this issue and I fully support your endeavor. Have you heard from Brink yet? If you would like any assistance, please let me know, as I would be happy to help out.

    By the way, do you have any suggestions on what I can do/check out on the laptop to find out why it is not sleeping?

    Also, I tried out the Wake-on-LAN feature on the two desktops and it works great! Finally, Windows, the way it was meant to operate.

    EDIT: I restarted the laptop and now it appears that sleep is working on it. So, if the Gods are with us, I should have both sleep and Homegroup working on all three computers. Fingers crossed, I'll keep an eye on everything this weekend and hopefully all is good.
    Last edited by Rockhound; 19 Oct 2013 at 20:36.
      My System SpecsSystem Spec

  7. #57

    Posts : 2
    Windows 8.1

    After having this problem for the past few days I tried everything and couldn't figure out what the issue was. After finding this thread on Google, I wanna buy everyone a drink.

    Only issue for now is sleep takes a bit to start, maybe 2-3 minutes after the amounted time from clicking sleep. This going on for everyone else?
      My System SpecsSystem Spec

  8. #58

    Posts : 60
    Windows 8.1 Pro with Media Center

    Owl, my sympathies that you too experienced this problem. I'm glad that you got it fixed!!! By the way, my favorite drink is rum and coke!

    I can confirm that the sleep timer does not always work exactly on the dot like a screensaver does. I've had it take up to 10 to 15 minutes, but it has also worked within 2 to 3 minutes too. I can only guess that there is something processing in the background that takes the extra time. But I also seem to recall that without a Homegroup, sleep worked nearly on the dot (maybe 10-20 seconds extra, but generally on-time).

    At this point, I'm willing to call it good simply because it sleeps!! If the computer takes it a few minutes extra, so be it. This bitch is solved!

    Last edited by Rockhound; 20 Oct 2013 at 00:26.
      My System SpecsSystem Spec

  9. #59

    Posts : 60
    Windows 8.1 Pro with Media Center

    @steve - just to be clear, I did not disable the system initiated shares such as ADMIN$ or C$ (sorry for the confusion on this). I just went to my computer name under network in windows explorer (I did not use computer management) and removed the shares in that folder. Also, I went to my user directory (C:\Users\), right-clicked each user directory, hovered over "Share with" and then clicked on "Stop sharing". This seemed to help with unsharing other folders that did not get unshared during the first step.
      My System SpecsSystem Spec

  10. #60

    Posts : 60
    Windows 8.1 Pro with Media Center

    For those looking for johnpombrio's additional tips with screenshots:

    Windows 8.1 does not go to sleep / standby automatically
      My System SpecsSystem Spec

Page 6 of 206 FirstFirst ... 456781656106 ... LastLast
Windows 8.1 refuses to sleep
Related Threads
For some reason, Windows refuses to let any program (utorrent, iexplore, firefox...) connect to (reporting that it cannot locate the server in Firefox and telling the me machine actively refused the connection in uTorrent) I can access the site through a proxy (eg: by going to...
When trying to boot Windows 8, it gets stuck at a black screen. I tried automatic repair and refreshing my pc. I need a dvd to refresh my pc which I don't have. I tried bcdboot but apparently the problem is not with the boot process. It seems that the only option left is to reinstall Windows 8...
I don't know if this is a software problem or not, so forgive me if this is the wrong forum to post it on. My Asus Q301LA refuses to wake from sleep mode if the charger is plugged in and the battery is fully charged. To elaborate, all that happens is the light on the power button comes on, but my...
After much trouble getting Windows Media Player to "see" several music files, I finally was able to burn a CD for use on a common stereo player. All tracks are short because they are simply sound effects for use on stage. I create a burn list of 1Music, 2Music, etc., through 25Music. I end up...
It will sleep when told, as far as I can tell... and it will hibernate if I manually right click and tell it too, So I've enabled hibernate, went into advanced setting under sleep to tell the computer when to hibernate. I set it to what ever time. It refuses to hibernate at the allotted time...
Amazing... I searched for "sleep" here and found the "Windows 8.1 refuses to sleep" thread, which is still going strong after almost 800 posts, talking about the exact opposite problem to the one I'm having! (Now, needless to say, I haven't read the entirety of that thread - yet; could someone...
I bought a new Dell 5 weeks ago (my old one of 9 years died) sadly it came with Wiin 8 installed? I wish I hadn't? The accounts and Passwords are atrocious. I have been locked out Twice using the same password I have used for 5 years and had used the night before and then had to wait a week for a...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook