Windows 8.1 refuses to sleep

VooDoo

New Member
Messages
21
Hi,

Hope someone can help me.

Windows 8.1(full fresh install) will not go to sleep/shut down etc. This has been happening since I installed 8.1 a few weeks back. It works/worked fine in Windows 7 and windows 8.0 till this install. I have narrowed it down to the Ethernet Chipset ( on board Realtec RTL8110 SC )

Through all the threads on here, W7 and Vista sites and the rest of the tech sites around the web I have tried most things over the past few weeks. All the settings in the divice manager the powercfg commands etc etc. Disabling in device manager does not help either

Then today I have found out, in an almost eureka moment, that when you take the Ethernet Cable out of the computer............it goes to sleep. :shock: Why did I not try this before? ? ? When I remove the cable from the router, it stays awake when plugged in at the computer end.


I am out of ideas and patience!!! Your help or ideas appreciated!

Thanks

Edit to add: Once asleep it stays that way and if I get it to sleep by other means - PWR Button\Sleep Option in W 8.1, it stays sleeping.
 
Last edited:

My Computer

System One

  • OS
    Windows 8.1 - Win10
    Computer type
    PC/Desktop
    CPU
    i7 4770
    Memory
    12MB
    Hard Drives
    Samsung 840 - 500GB

XweAponX

New Member
VIP Member
Pro User
Messages
3,908
Location
Sloe Deth, Californicatia
That may the the issue - I never use HOMEGROUP at all, I use an Administrator account for sharing and connecting.

It gives you that option when you initially connect to your network, you get 3 choices: Home Network, Work Network or Public Network. I always use HOME even when connected via laptop to a free wifi.

When you choose HOME network, it will then continue on to create a Homegroup for you, or let you use Windows Sharing. I always choose Windows Sharing.

I'd have to set up a new computer to my network and go through this again, that way I can save Screen shots.

Ok, it's pretty much the same as it was in Windows 7 - Choose Home:

home-goop.png

Then cancel out of the next screen:

cancelhopmegoop.png

And then you can set up regular Windows Sharing via the Admin account (remember to set a password for the Admin account else it won't work).
 

My Computer

System One

  • OS
    Windows 8 Pro with Media Center/Windows 7
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Asus M2N-MX SE Plus § DualCore AMD Athlon 64 X2, 2300 MHz (11.5 x 200) 4400+ § Corsair Value Select
    CPU
    AMD 4400+/4200+
    Motherboard
    Asus M2N-MX SE Plus/Asus A8M2N-LA (NodusM)
    Memory
    2 GB/3GB
    Graphics Card(s)
    GeForce 8400 GS/GeForce 210
    Sound Card
    nVIDIA GT218 - High Definition Audio Controller
    Monitor(s) Displays
    Hitachi 40" LCD HDTV
    Screen Resolution
    "1842 x 1036"
    Hard Drives
    WDC WD50 00AAKS-007AA SCSI Disk Device
    ST1000DL 002-9TT153 SCSI Disk Device
    WDC WD3200AAJB-00J3A0 ATA Device
    WDC WD32 WD-WCAPZ2942630 USB Device
    WD My Book 1140 USB Device
    PSU
    Works 550w
    Case
    MSI "M-Box"
    Cooling
    Water Cooled
    Keyboard
    Dell Keyboard
    Mouse
    Microsoft Intellimouse
    Internet Speed
    Cable Medium Speed
    Browser
    Chrome/IE 10
    Antivirus
    Eset NOD32 6.x/Win Defend
    Other Info
    Recently lost my Windows 8 on my main PC, had to go back to Windows 7.

johnpombrio

New Member
Power User
Messages
693
Location
Manchester CT
Is there an icon for beating my head against my keyboard? I got Homegroup to work by changing the password. Now I cannot get the computer to sleep by either method, leaving Homegroup or disabling IPv6. Automatic sleeping used to work, some sort of Win8.1 RTM issue. Not worth the bother to try to fix it any more. I will manually sleep it or let it run polluting my precious bodily fluids.
 

My Computer

System One

  • OS
    Windows 8.1 Pro 64 bit GA
    Computer type
    PC/Desktop
    CPU
    i7-4770K Haswell
    Motherboard
    ASUS Z87-PRO
    Memory
    16 GB of Corsair 1866
    Graphics Card(s)
    GTX 780
    Sound Card
    Cooler Master Storm Headphones
    Monitor(s) Displays
    Dell 27 inch U2711 IPS
    Screen Resolution
    2560 by 1440
    Hard Drives
    Samsung 840 Pro 250GB SSD plus 2 3 TB drives
    PSU
    Corsair-750
    Case
    Corsair White Graphite Series 600T
    Cooling
    Corsair H00i Water
    Keyboard
    Corsair K90
    Mouse
    Logitech G9 Laser
    Internet Speed
    6.3 MBps
    Browser
    Firefox
    Antivirus
    MS

XweAponX

New Member
VIP Member
Pro User
Messages
3,908
Location
Sloe Deth, Californicatia
I have to admit, I've never used "Hoomegoop", is it any better than just using Windows Networking?

It just seemed like too much plumbing installed to Windows where regular Windows Networking was always good enough for me in XP. And because I still have at least one Windows XP workstation, I just stuck with the Windows Networking.
 

My Computer

System One

  • OS
    Windows 8 Pro with Media Center/Windows 7
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Asus M2N-MX SE Plus § DualCore AMD Athlon 64 X2, 2300 MHz (11.5 x 200) 4400+ § Corsair Value Select
    CPU
    AMD 4400+/4200+
    Motherboard
    Asus M2N-MX SE Plus/Asus A8M2N-LA (NodusM)
    Memory
    2 GB/3GB
    Graphics Card(s)
    GeForce 8400 GS/GeForce 210
    Sound Card
    nVIDIA GT218 - High Definition Audio Controller
    Monitor(s) Displays
    Hitachi 40" LCD HDTV
    Screen Resolution
    "1842 x 1036"
    Hard Drives
    WDC WD50 00AAKS-007AA SCSI Disk Device
    ST1000DL 002-9TT153 SCSI Disk Device
    WDC WD3200AAJB-00J3A0 ATA Device
    WDC WD32 WD-WCAPZ2942630 USB Device
    WD My Book 1140 USB Device
    PSU
    Works 550w
    Case
    MSI "M-Box"
    Cooling
    Water Cooled
    Keyboard
    Dell Keyboard
    Mouse
    Microsoft Intellimouse
    Internet Speed
    Cable Medium Speed
    Browser
    Chrome/IE 10
    Antivirus
    Eset NOD32 6.x/Win Defend
    Other Info
    Recently lost my Windows 8 on my main PC, had to go back to Windows 7.

johnpombrio

New Member
Power User
Messages
693
Location
Manchester CT
I have to admit, I've never used "Hoomegoop", is it any better than just using Windows Networking?

It just seemed like too much plumbing installed to Windows where regular Windows Networking was always good enough for me in XP. And because I still have at least one Windows XP workstation, I just stuck with the Windows Networking.

Homegroup works very well. It makes sharing folders and printers a snap, Right click on a folder, share with Homegroup. Done. I have not bothered with anything but since Win7. frankly, I do not even know how to share a folder with Workgroup any more (but I am sure there is a tutorial on it!)
 

My Computer

System One

  • OS
    Windows 8.1 Pro 64 bit GA
    Computer type
    PC/Desktop
    CPU
    i7-4770K Haswell
    Motherboard
    ASUS Z87-PRO
    Memory
    16 GB of Corsair 1866
    Graphics Card(s)
    GTX 780
    Sound Card
    Cooler Master Storm Headphones
    Monitor(s) Displays
    Dell 27 inch U2711 IPS
    Screen Resolution
    2560 by 1440
    Hard Drives
    Samsung 840 Pro 250GB SSD plus 2 3 TB drives
    PSU
    Corsair-750
    Case
    Corsair White Graphite Series 600T
    Cooling
    Corsair H00i Water
    Keyboard
    Corsair K90
    Mouse
    Logitech G9 Laser
    Internet Speed
    6.3 MBps
    Browser
    Firefox
    Antivirus
    MS

Rockhound

Member
Member
Messages
60
First off, I want to thank this community for its support in helping members and non-members alike. I'm bad about reading other's threads, but never joining myself. In this case, I joined this forum specifically to weigh in on the issue and help offer some support.

johnpombrio, you and I are having exactly the same problems. Like you, I have been trying for weeks (feels like months) to troubleshoot this problem. I've been able to narrow it down to Homegroup and WOL, although I am suspecting it may be deeper than that. Perhaps it is a NIC driver issue? I too have scoured other forums and websites trying to figure it out, but alas the problem remains.

Here are my current observations:

  • Two desktop machines on a wired connection
  • Both machines with Windows 8.1 Pro with Media Center (64 bit)
  • With Homegroup enabled and WOL disabled, both machines auto sleep and manual sleep just fine.
  • With Homegroup disabled and WOL enabled, both machines auto sleep and manual sleep just fine.
  • With Homegroup disabled and WOL disabled, both machines auto sleep and manual sleep just fine.
  • With Homegroup and WOL enabled, neither machine will auto sleep, but sleep on manual command just fine.
    • Under this scenario, I removed both machines from Homegroup, and leave WOL enabled. Restart the computer and create a Homegroup on Machine 1 and Join the Homegroup on Machine 2. Set sleep timer for 10 minutes on Machine 1 and 20 minutes on Machine 2. Machine 1 falls asleep after ~10 minutes. However, Machine 2 does not fall asleep on its timer (even waited over an hour just to see).
      • Here's where it get's really strange. I wake Machine 1 up. Move the mouse around for a second or two and walk away. Machine 2 falls asleep on its 20 minute timer. However, Machine 1 is now an insomniac and won't fall back asleep.
    • I thought this could be a driver issue. I have a Rampage IV Extreme motherboard on Machine 1 with an onboard Intel 82579V NIC. I updated it's driver, but problem still persists. Machine 2 has an older XFX 780i motherboard. The NVidia driver is as current as it's ever going to get (which is to say it's actually quite outdated.)

I think we're getting close to figuring this out. If it worked in Windows 7 and Windows 8, then surely it can work in Windows 8.1. Have you had any other success on your end?
 

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center
    Computer type
    PC/Desktop
    CPU
    Intel 3930K (Overclocked to 4.5 GHz)
    Motherboard
    ASUS Rampage IV Extreme
    Memory
    32 GB Corsair Dominator GT at 2133 MHz
    Graphics Card(s)
    EVGA GTX TITAN
    Monitor(s) Displays
    ASUS PB278Q 27" overclocked to 85Hz
    Screen Resolution
    2560 x 1440
    Hard Drives
    Samsung 840 Pro, 512 GB;
    Western Digital Black 4TB
    PSU
    Corsair AX 1200i
    Case
    Corsair 900D
    Cooling
    Custom Water Loops
    Keyboard
    Logitech G19S
    Mouse
    Logitech G700S
    Other Info
    Yes, I just LOVE this system!! I've never had anything this nice, ever. It may take me a year to pay it off, but it was soooo worth it.

johnpombrio

New Member
Power User
Messages
693
Location
Manchester CT
First off, I want to thank this community for its support in helping members and non-members alike. I'm bad about reading other's threads, but never joining myself. In this case, I joined this forum specifically to weigh in on the issue and help offer some support.

johnpombrio, you and I are having exactly the same problems. Like you, I have been trying for weeks (feels like months) to troubleshoot this problem. I've been able to narrow it down to Homegroup and WOL, although I am suspecting it may be deeper than that. Perhaps it is a NIC driver issue? I too have scoured other forums and websites trying to figure it out, but alas the problem remains.

I think we're getting close to figuring this out. If it worked in Windows 7 and Windows 8, then surely it can work in Windows 8.1. Have you had any other success on your end?

Rockhound, Welcome to the Win8 forums!

I have NOT been able to fix my sleep issue. I still have two ASUS mobos (Z77 and Z87) that will not auto-sleep in Win8.1 Pro. I have Homegroup enabled and Wake On LAN disabled. At some point, I had them sleeping by disabling either IPv6 and/or Homegroup. Since Homegroup USES IPv6, I had to enable it in order to run Homegroup (which I use a LOT). I do not use Media Player so that is not an issue.

Since both machines would easily auto-sleep before upgrading to Win8.1 Pro, I have to consider the upgrade to be the issue. The major sticking point with my machines is having Homegroup enabled and running. I now have to MANUALLY sleep both machines.

When trying to see if sleep works, put it on sleep after one minute, you spend less time waiting, heh.

I have given up on trying to fix the issue as I seriously messed up my LAN driver to the point where I had to uninstall the driver and let Windows reinstall it for me. I also had to reset my Homegroup password on one machine and load it into the other machine to get THAT back up and running.

Right now I am just waiting for a Win update to fix auto-sleep as I have run out of ideas and have yet to find a solution on the web. Boy, I have worked hours and hours on this issue myself!

EDIT 2013-12-28 This did not fix the problem. For me, a MS update on Dec 11th fixed it.
 
Last edited:

My Computer

System One

  • OS
    Windows 8.1 Pro 64 bit GA
    Computer type
    PC/Desktop
    CPU
    i7-4770K Haswell
    Motherboard
    ASUS Z87-PRO
    Memory
    16 GB of Corsair 1866
    Graphics Card(s)
    GTX 780
    Sound Card
    Cooler Master Storm Headphones
    Monitor(s) Displays
    Dell 27 inch U2711 IPS
    Screen Resolution
    2560 by 1440
    Hard Drives
    Samsung 840 Pro 250GB SSD plus 2 3 TB drives
    PSU
    Corsair-750
    Case
    Corsair White Graphite Series 600T
    Cooling
    Corsair H00i Water
    Keyboard
    Corsair K90
    Mouse
    Logitech G9 Laser
    Internet Speed
    6.3 MBps
    Browser
    Firefox
    Antivirus
    MS

johnpombrio

New Member
Power User
Messages
693
Location
Manchester CT
On Win8.1 Pro, disabling the network port (after booting with port enabled) will allow the computer to sleep. That is at least some progress, heh. Now to try to figure out what process in the network is keeping the computer from sleeping.


Rockhound, if you are following, could you verify this with your machine too? On the Network Internet access Icon in the notification icon, right click-open Network and sharing Center-Connections-ethernet-disable. To enable Change adapter settings- double click on Ethernet which will enable networking again.
 

My Computer

System One

  • OS
    Windows 8.1 Pro 64 bit GA
    Computer type
    PC/Desktop
    CPU
    i7-4770K Haswell
    Motherboard
    ASUS Z87-PRO
    Memory
    16 GB of Corsair 1866
    Graphics Card(s)
    GTX 780
    Sound Card
    Cooler Master Storm Headphones
    Monitor(s) Displays
    Dell 27 inch U2711 IPS
    Screen Resolution
    2560 by 1440
    Hard Drives
    Samsung 840 Pro 250GB SSD plus 2 3 TB drives
    PSU
    Corsair-750
    Case
    Corsair White Graphite Series 600T
    Cooling
    Corsair H00i Water
    Keyboard
    Corsair K90
    Mouse
    Logitech G9 Laser
    Internet Speed
    6.3 MBps
    Browser
    Firefox
    Antivirus
    MS

johnpombrio

New Member
Power User
Messages
693
Location
Manchester CT
Solved! Damn it, I solved it! What a handsome frog. All computers that are using HOMEGROUP have to all be on the same HOMEGROUP and have to be properly configured to share something before any of the computers will auto sleep properly.

Example, I had two computers on Win 8.1 Pro (which automatically starts a HOMEGROUP when installed) that would NOT connect using my old HOMEGROUP password. I created a new HOMEGROUP password and managed to get these two computers to share files. However, there was a THIRD computer on the network (with Win 8) who had the old HOMEGROUP password. I successfully changed it to the new HOMEGROUP by leaving and rejoining using the new password. Yet I could not see any files on this last computer. I had to UNSHARE with the HOMEGROUP all of the files and folders under users. Then I shared the one folder that I wanted to share. That worked and that also FINALLY let my computer sleep!

I think this is the reason why some of the workarounds fixed the issue. The netsrv issue is probably trying to connect to the HOMEGROUP computers that are not connected properly. Leaving HOMEGROUP would fix the problem, as well as turning off IPv6 (which is needed by HOMEGROUP to connect), and finally killing the LAN just turns off all sharing.

I tell you tho, I have my fingers and toes crossed that I have finished with this issue. ++++++++++ ++++++++++

EDIT: NOPE. NO FIX. It started having issues a couple of days later.

EDIT 2013-12-28 This did not fix the problem. For me, a MS update on Dec 11th fixed it.
 
Last edited:

My Computer

System One

  • OS
    Windows 8.1 Pro 64 bit GA
    Computer type
    PC/Desktop
    CPU
    i7-4770K Haswell
    Motherboard
    ASUS Z87-PRO
    Memory
    16 GB of Corsair 1866
    Graphics Card(s)
    GTX 780
    Sound Card
    Cooler Master Storm Headphones
    Monitor(s) Displays
    Dell 27 inch U2711 IPS
    Screen Resolution
    2560 by 1440
    Hard Drives
    Samsung 840 Pro 250GB SSD plus 2 3 TB drives
    PSU
    Corsair-750
    Case
    Corsair White Graphite Series 600T
    Cooling
    Corsair H00i Water
    Keyboard
    Corsair K90
    Mouse
    Logitech G9 Laser
    Internet Speed
    6.3 MBps
    Browser
    Firefox
    Antivirus
    MS

Rockhound

Member
Member
Messages
60
Interesting. Very interesting. Sorry, I haven't replied in awhile, I've been away on work, but I just got back and saw your updates. I tried as you suggested by disabling the network port after it has booted with the port enabled and the computer sleeps like it should.

Currently, I have removed all computers from the Homegroup because it was just causing too much problems with sleep. However, I would really like to have it because it makes sharing files much easier.

So you really think you put a nail in this one, huh? That's a very interesting solution. Just to make sure I got it right, you create a Homegroup on one computer and join the Homegroup on other computers. Then (and I'm hoping this is the key), you unshare all files and folders under users on all computers and then you reshare the file/folders that you want. I'm going to give this a try tonight when I get home. It sounds promising.
 

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center
    Computer type
    PC/Desktop
    CPU
    Intel 3930K (Overclocked to 4.5 GHz)
    Motherboard
    ASUS Rampage IV Extreme
    Memory
    32 GB Corsair Dominator GT at 2133 MHz
    Graphics Card(s)
    EVGA GTX TITAN
    Monitor(s) Displays
    ASUS PB278Q 27" overclocked to 85Hz
    Screen Resolution
    2560 x 1440
    Hard Drives
    Samsung 840 Pro, 512 GB;
    Western Digital Black 4TB
    PSU
    Corsair AX 1200i
    Case
    Corsair 900D
    Cooling
    Custom Water Loops
    Keyboard
    Logitech G19S
    Mouse
    Logitech G700S
    Other Info
    Yes, I just LOVE this system!! I've never had anything this nice, ever. It may take me a year to pay it off, but it was soooo worth it.

johnpombrio

New Member
Power User
Messages
693
Location
Manchester CT
So you really think you put a nail in this one, huh? That's a very interesting solution. Just to make sure I got it right, you create a Homegroup on one computer and join the Homegroup on other computers. Then (and I'm hoping this is the key), you unshare all files and folders under users on all computers and then you reshare the file/folders that you want. I'm going to give this a try tonight when I get home. It sounds promising.

Heh, I am hoping! First try turning off your network adapter (see above post of mine) and change sleep to one minute. Give it a few minutes to sleep. If that works, then HOMEGROUP could definitely be your issue.

Leave what is shared alone. On two of my machines, they shared fine but would not sleep. The third computer I had to unshare all folders and files after users, then share what I wanted to share.

Good Luck!
 

My Computer

System One

  • OS
    Windows 8.1 Pro 64 bit GA
    Computer type
    PC/Desktop
    CPU
    i7-4770K Haswell
    Motherboard
    ASUS Z87-PRO
    Memory
    16 GB of Corsair 1866
    Graphics Card(s)
    GTX 780
    Sound Card
    Cooler Master Storm Headphones
    Monitor(s) Displays
    Dell 27 inch U2711 IPS
    Screen Resolution
    2560 by 1440
    Hard Drives
    Samsung 840 Pro 250GB SSD plus 2 3 TB drives
    PSU
    Corsair-750
    Case
    Corsair White Graphite Series 600T
    Cooling
    Corsair H00i Water
    Keyboard
    Corsair K90
    Mouse
    Logitech G9 Laser
    Internet Speed
    6.3 MBps
    Browser
    Firefox
    Antivirus
    MS

Rockhound

Member
Member
Messages
60
Okay, you are definitely having better success than I am. I tried your suggestions and unfortunately as long as I have a Homegroup set up, the computers will not sleep. I even tried disabling the network adapter as you suggested. When I do not have a Homegroup created, the computer will sleep. However, once I create a Homegroup, the computer won't sleep, even if the network adapter is disabled.

I also tried unsharing the files and folders on the user accounts, but that did not have an effect. I wonder what I'm doing differently than you. Are all three of your computers sleeping on the timer when you have Homegroup set up on all of them? Are you sharing files between all three?
 

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center
    Computer type
    PC/Desktop
    CPU
    Intel 3930K (Overclocked to 4.5 GHz)
    Motherboard
    ASUS Rampage IV Extreme
    Memory
    32 GB Corsair Dominator GT at 2133 MHz
    Graphics Card(s)
    EVGA GTX TITAN
    Monitor(s) Displays
    ASUS PB278Q 27" overclocked to 85Hz
    Screen Resolution
    2560 x 1440
    Hard Drives
    Samsung 840 Pro, 512 GB;
    Western Digital Black 4TB
    PSU
    Corsair AX 1200i
    Case
    Corsair 900D
    Cooling
    Custom Water Loops
    Keyboard
    Logitech G19S
    Mouse
    Logitech G700S
    Other Info
    Yes, I just LOVE this system!! I've never had anything this nice, ever. It may take me a year to pay it off, but it was soooo worth it.

Rockhound

Member
Member
Messages
60
I don't believe it, I got it to work! Hot damn!!

It took me some time last night, but I was finally able to get this fixed, and I owe it to you, johnpombrio, for getting me there! So I was having some initial trouble last night getting everything to work, but then I went back and re-read your posts. Here is what I did to finally get everything to work:

  • Before joining or creating a Homegroup, you must remove ALL shares from ALL networked computers. I realized that more than just the standard Music, Pictures, Videos, Documents libraries, I had also previously set up sharing for entire drive letters (example: I had shared the entire D and E Drive). I remembered that before I got wrapped up in the Homegroup mess, I was sharing files and folders using the old-fashioned way of sharing (as described under Option Two in this guide.) So, I had to unshare EVERYTHING.
  • In order to unshare EVERYTHING, I needed to know what I was sharing. I found this tutorial to be very helpful in identifying what was shared on each of my computers. From here, I removed sharing on EVERY FOLDER in the list (by right-clicking and selecting properties, then under the sharing tab, click on the advanced sharing button, and uncheck the box for "Share this folder". This allowed me to remove ALL of my shared folders. Yes, I even removed the share for Music, Pictures, Videos, Documents, D Drive, E Drive, Users, etc. Essentially, I had zero folders in this list.
  • Once I was confident that I had nothing shared on any computer on the network, then I created a Homegroup on Computer 1 and Joined the Homegroup on Computer 2. I started off simple and only shared one library on one computer, the Music library (which for me is all contained under one folder anyways). I set the sleep timer to 1 minute, and low and behold the damn thing went to sleep!!
  • From here I became bolder by incrementally sharing multiple libraries across both computers. In order to share additional libraries, I had to go into the Homegroup settings (follow this tutorial) and change them from Not shared to Shared. Again, keeping the sleep timer at 1 minute, both of them went to sleep. Okay, I'll be honest here, one machine has a Samsung 840 Pro SSD and 32 GB Corsair Dominator GT 2133 RAM, so it will idle to sleep pretty much on the 1 minute timer. The other machine has an older magnetic hard disk drive and 6 GB of slow-ish RAM, so it can take some time for it to finally put everything in memory and then sleep, but it does it.
  • My final test was sharing all libraries (Music, Pictures, Videos, Documents) on both computers AND re-establishing the full sharing on my D Drive and E Drive. I then set the screen saver for 5 minutes and the sleep timer to 20 minutes for both computers and walked away. I came back in the room in about 25 minutes and both computers were asleep. It was late, so I let them sleep overnight and came back to them this morning and they are both asleep, just like I want them to be.

I think we finally got this figured out. The key was to remove all the previous shares before creating or joining a Homegroup.

Thank you, thank you, thank you for helping me get to the bottom of this. If Connecticut wasn't so far from Texas, I'd offer to take you out to lunch today to celebrate! I am hoping that our success will allow others to find some relief as well. This was by far, one of the most troublesome issues I have yet to encounter, but I'm glad we got it figured out. Again, thanks so much for all of your help!
 

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center
    Computer type
    PC/Desktop
    CPU
    Intel 3930K (Overclocked to 4.5 GHz)
    Motherboard
    ASUS Rampage IV Extreme
    Memory
    32 GB Corsair Dominator GT at 2133 MHz
    Graphics Card(s)
    EVGA GTX TITAN
    Monitor(s) Displays
    ASUS PB278Q 27" overclocked to 85Hz
    Screen Resolution
    2560 x 1440
    Hard Drives
    Samsung 840 Pro, 512 GB;
    Western Digital Black 4TB
    PSU
    Corsair AX 1200i
    Case
    Corsair 900D
    Cooling
    Custom Water Loops
    Keyboard
    Logitech G19S
    Mouse
    Logitech G700S
    Other Info
    Yes, I just LOVE this system!! I've never had anything this nice, ever. It may take me a year to pay it off, but it was soooo worth it.

johnpombrio

New Member
Power User
Messages
693
Location
Manchester CT
Rockhound, congratulations! I pointed the way but you put in all the hard work to get it to run. Instead of lunch, you can upvote my reputation by clicking on the little thumbs up on one of my posts. In the meantime, go to the tutorial section here on the site and marvel at the wisdom that this site offers.

With two of us now having the same results, it is definitely a bug in Win 8.1. As far as I know, I am the ONLY POSTER about this particular fix on the internet. Brink, if you are following this post ( and God knows you seem to be omnipresent on this site- luckily for us), would you like me to do a tutorial on how to fix this broken HOMEGROUP/sharing/sleep issue?

The files/folders that were previously being shared on the old HOMEGROUP issue was exactly what hung up my my new HOMEGROUP/sharing/sleep also. I wish disabling the network adapter temporarily fixed it for you but it might be which computers have the broken file/folder shares that lets this work. If it was the machine you tried disabling the network, it must not temporarily fix the problem.

Like Rockhound, I had to disable a LOT of files and folders to get HOMEGROUP to work. I did a kind of batch unsharing by selecting all the files/folders in a folder and then unsharing them all at once with a right click/unshare.

And, yes Rockhound, this was a handsome frog of a problem!

EDIT: NO FIX. It started having trouble again for the two of us within a couple of days.

EDIT 2013-12-28 This did not fix the problem. For me, a MS update on Dec 11th fixed it.

 
Last edited:

My Computer

System One

  • OS
    Windows 8.1 Pro 64 bit GA
    Computer type
    PC/Desktop
    CPU
    i7-4770K Haswell
    Motherboard
    ASUS Z87-PRO
    Memory
    16 GB of Corsair 1866
    Graphics Card(s)
    GTX 780
    Sound Card
    Cooler Master Storm Headphones
    Monitor(s) Displays
    Dell 27 inch U2711 IPS
    Screen Resolution
    2560 by 1440
    Hard Drives
    Samsung 840 Pro 250GB SSD plus 2 3 TB drives
    PSU
    Corsair-750
    Case
    Corsair White Graphite Series 600T
    Cooling
    Corsair H00i Water
    Keyboard
    Corsair K90
    Mouse
    Logitech G9 Laser
    Internet Speed
    6.3 MBps
    Browser
    Firefox
    Antivirus
    MS

Steve06

New Member
Messages
102
I can confirm I have the same problem that you had guys: Activating the homegroup would prevent my PC from going to sleep. After I found out about this, I reverted all the other changes suggested in other troubleshooting guides to resolve the issue. Luckily, the idle-to-sleep functionality still worked, hence I was able to ascertain that the homegroup is the culprit and only the homegroup.

I am now trying to unshare everything via Computer Management - this seems to be the most convenient way to do it in just a few clicks. However, it seems a bit weird during the process to undo some system shares like $ADMIN and C: (yes, C: is also a system-initiated share), but I'm proceeding with it anyways since Rockhound put the emphasis on unsharing literally EVERYTHING.

I agree that this is definitely a Windows 8.1 bug.

Here's another oddity I noticed while testing the sleep issues, and I would be curious whether your machine also exhibits this:

My PC always need a couple of minutes more than the set sleep time. For example, I set the timer for sleep and switch off of the screen to both 1 minute. However, while I have not used a stopwatch yet, it more feels like 3 to 4 minutes before the machine goes to sleep. The reaction of the screen is accurate though, that is it darkens after exactly one minute. I cannot remember to have noticed such inaccuracy with Windows 8 before.

Is the timer just a bug we can nothing do about or is it still a matter of settings?
 

My Computer

System One

  • OS
    Windows 8.1 Pro x64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom-built silent Mini-ITX workhorse
    CPU
    Intel Core i7-3770, 4x 3.40GHz
    Motherboard
    ASRock Z77E-ITX
    Memory
    2x8GB GeIL Black Dragon PC3-12800U
    Graphics Card(s)
    Intel HD 4000 (integrated)
    Monitor(s) Displays
    Eizo
    Hard Drives
    Intel SSD 530 240GB, Intel SSD 520 120GB, WD 1TB
    Mouse
    Lenovo Trackpoint Mouse
    Browser
    Firefox, Chrome
    Antivirus
    Windows Defender

johnpombrio

New Member
Power User
Messages
693
Location
Manchester CT
Steve, I just posted a definitive list of what to do with the HOMEGROUP on your original post (along with 25 8 by 10 color glossy photos with diagrams and arrows on the back of each one). Go look at that for additional help.

The biggest change between Windows 8 and Windows 8.1 seems to be that you need ALL COMPUTERS up and running before making ANY changes to the HOMEGROUP! I ignored this completely when I joined the old HOMEGROUP on setting up Win8.1 Pro. I bet this is the cause of all these issues, joining a HOMEGROUP without all the other computers up and running at that time. Notice the verbiage in highlight:

HG7.jpg

So, boot all the machines, join the HOMEGROUP and keep your fingers crossed that it sleeps.

Yeah, as I said in a bunch of posts, you need to wait a few minutes before sleep kicks in. The ONLY time you will ever notice it is when you are impatiently waiting for the damn thing to sleep!

EDIT: NO FIX. I eventually completely disabled Homegroup but that only fix the sleep problem for a couple of days.

EDIT 2013-12-28 This did not fix the problem. For me, a MS update on Dec 11th fixed it.
 
Last edited:

My Computer

System One

  • OS
    Windows 8.1 Pro 64 bit GA
    Computer type
    PC/Desktop
    CPU
    i7-4770K Haswell
    Motherboard
    ASUS Z87-PRO
    Memory
    16 GB of Corsair 1866
    Graphics Card(s)
    GTX 780
    Sound Card
    Cooler Master Storm Headphones
    Monitor(s) Displays
    Dell 27 inch U2711 IPS
    Screen Resolution
    2560 by 1440
    Hard Drives
    Samsung 840 Pro 250GB SSD plus 2 3 TB drives
    PSU
    Corsair-750
    Case
    Corsair White Graphite Series 600T
    Cooling
    Corsair H00i Water
    Keyboard
    Corsair K90
    Mouse
    Logitech G9 Laser
    Internet Speed
    6.3 MBps
    Browser
    Firefox
    Antivirus
    MS

Rockhound

Member
Member
Messages
60
Steve,

Sorry to hear that you are having the same problems that we had. I think we can now confirm this to be a Windows 8.1 bug. Follow john's steps and that should fix it for you.

I tried to add our laptop to the Homegroup today and had major problems. I fouled up sleep and Homegroup accessibility on the two previously set up computers. Frustrated, I came back to this thread and saw john's new post about having all computers turned on when doing this. So, reluctantly, I decided to start all over again. :(

After unsharing all the folders on all computers and re-establishing the Homegroup on my main computer and joining the Homegroup on the other computers (including the laptop), I was able to get the Homegroup working properly again. I set the sleep timer to 1 minute on all three computers and waited. It took 13 minutes for one computer to sleep and 15 minutes for another computer to sleep. Unfortunately, the laptop is not sleeping. I'm not sure what I got wrong there, but I may have missed something. Interestingly, after waking up the other two computers, they went back to sleep on their timer (one computer does it in 1 minute, the other does it in 3 minutes.) Perhaps I had a process running in the background?

Have you had any success following john's steps? I can't help but think that Microsoft will have to release a hotfix for this, as it is clearly a bug in Windows 8.1. Until then, I am hoping this workaround holds.

johnpombrio, I definitely think a guide would be very helpful for this issue and I fully support your endeavor. Have you heard from Brink yet? If you would like any assistance, please let me know, as I would be happy to help out.

By the way, do you have any suggestions on what I can do/check out on the laptop to find out why it is not sleeping?

Also, I tried out the Wake-on-LAN feature on the two desktops and it works great! Finally, Windows, the way it was meant to operate.


EDIT: I restarted the laptop and now it appears that sleep is working on it. So, if the Gods are with us, I should have both sleep and Homegroup working on all three computers. Fingers crossed, I'll keep an eye on everything this weekend and hopefully all is good.
 
Last edited:

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center
    Computer type
    PC/Desktop
    CPU
    Intel 3930K (Overclocked to 4.5 GHz)
    Motherboard
    ASUS Rampage IV Extreme
    Memory
    32 GB Corsair Dominator GT at 2133 MHz
    Graphics Card(s)
    EVGA GTX TITAN
    Monitor(s) Displays
    ASUS PB278Q 27" overclocked to 85Hz
    Screen Resolution
    2560 x 1440
    Hard Drives
    Samsung 840 Pro, 512 GB;
    Western Digital Black 4TB
    PSU
    Corsair AX 1200i
    Case
    Corsair 900D
    Cooling
    Custom Water Loops
    Keyboard
    Logitech G19S
    Mouse
    Logitech G700S
    Other Info
    Yes, I just LOVE this system!! I've never had anything this nice, ever. It may take me a year to pay it off, but it was soooo worth it.

Owl

New Member
Messages
2
After having this problem for the past few days I tried everything and couldn't figure out what the issue was. After finding this thread on Google, I wanna buy everyone a drink.

Only issue for now is sleep takes a bit to start, maybe 2-3 minutes after the amounted time from clicking sleep. This going on for everyone else?
 

My Computer

System One

  • OS
    Windows 8.1

Rockhound

Member
Member
Messages
60
Owl, my sympathies that you too experienced this problem. I'm glad that you got it fixed!!! By the way, my favorite drink is rum and coke!

I can confirm that the sleep timer does not always work exactly on the dot like a screensaver does. I've had it take up to 10 to 15 minutes, but it has also worked within 2 to 3 minutes too. I can only guess that there is something processing in the background that takes the extra time. But I also seem to recall that without a Homegroup, sleep worked nearly on the dot (maybe 10-20 seconds extra, but generally on-time).

At this point, I'm willing to call it good simply because it sleeps!! If the computer takes it a few minutes extra, so be it. This handsome frog is solved!

:dinesh:
 
Last edited:

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center
    Computer type
    PC/Desktop
    CPU
    Intel 3930K (Overclocked to 4.5 GHz)
    Motherboard
    ASUS Rampage IV Extreme
    Memory
    32 GB Corsair Dominator GT at 2133 MHz
    Graphics Card(s)
    EVGA GTX TITAN
    Monitor(s) Displays
    ASUS PB278Q 27" overclocked to 85Hz
    Screen Resolution
    2560 x 1440
    Hard Drives
    Samsung 840 Pro, 512 GB;
    Western Digital Black 4TB
    PSU
    Corsair AX 1200i
    Case
    Corsair 900D
    Cooling
    Custom Water Loops
    Keyboard
    Logitech G19S
    Mouse
    Logitech G700S
    Other Info
    Yes, I just LOVE this system!! I've never had anything this nice, ever. It may take me a year to pay it off, but it was soooo worth it.

Rockhound

Member
Member
Messages
60
@steve - just to be clear, I did not disable the system initiated shares such as ADMIN$ or C$ (sorry for the confusion on this). I just went to my computer name under network in windows explorer (I did not use computer management) and removed the shares in that folder. Also, I went to my user directory (C:\Users\), right-clicked each user directory, hovered over "Share with" and then clicked on "Stop sharing". This seemed to help with unsharing other folders that did not get unshared during the first step.
 

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center
    Computer type
    PC/Desktop
    CPU
    Intel 3930K (Overclocked to 4.5 GHz)
    Motherboard
    ASUS Rampage IV Extreme
    Memory
    32 GB Corsair Dominator GT at 2133 MHz
    Graphics Card(s)
    EVGA GTX TITAN
    Monitor(s) Displays
    ASUS PB278Q 27" overclocked to 85Hz
    Screen Resolution
    2560 x 1440
    Hard Drives
    Samsung 840 Pro, 512 GB;
    Western Digital Black 4TB
    PSU
    Corsair AX 1200i
    Case
    Corsair 900D
    Cooling
    Custom Water Loops
    Keyboard
    Logitech G19S
    Mouse
    Logitech G700S
    Other Info
    Yes, I just LOVE this system!! I've never had anything this nice, ever. It may take me a year to pay it off, but it was soooo worth it.

Rockhound

Member
Member
Messages
60

My Computer

System One

  • OS
    Windows 8.1 Pro with Media Center
    Computer type
    PC/Desktop
    CPU
    Intel 3930K (Overclocked to 4.5 GHz)
    Motherboard
    ASUS Rampage IV Extreme
    Memory
    32 GB Corsair Dominator GT at 2133 MHz
    Graphics Card(s)
    EVGA GTX TITAN
    Monitor(s) Displays
    ASUS PB278Q 27" overclocked to 85Hz
    Screen Resolution
    2560 x 1440
    Hard Drives
    Samsung 840 Pro, 512 GB;
    Western Digital Black 4TB
    PSU
    Corsair AX 1200i
    Case
    Corsair 900D
    Cooling
    Custom Water Loops
    Keyboard
    Logitech G19S
    Mouse
    Logitech G700S
    Other Info
    Yes, I just LOVE this system!! I've never had anything this nice, ever. It may take me a year to pay it off, but it was soooo worth it.
Top