Windows 8 and 8.1 Forums

Multiple W8 Update failures - TroubleShooter no help

  1. #1

    Posts : 26
    2 x W7-64, W81-64, W10-64, 2 x NAS (Samba), and a partridge in a pear tree

    Multiple W8 Update failures - TroubleShooter no help

    When trying to use Windows Update on a Windows 8 Pro - 64 machine, I am encountering a number of errors: 6 Updates just will not install:
    KB2835364 - Error 80070003 - and, on one attempt Error 80070007
    KB2856373 - Error 80070026 - and, on one attempt Error 80070007
    KB2822241 - Error 80070002
    KB2845533 - Error 80070026
    KB2781197 - Error 80070026
    KB2876415 - Error 80070002

    I ran the Update Trouble Shooter, which supposedly fixed certain issues but when I re-started and re-ran the update, I had the same results (or lack of them)

    Does anyone have any ideas how to resolve this problem?

    Thank You!
    Attached Thumbnails Attached Thumbnails Update Log.jpg   Trouble Shooter.jpg  

      My System SpecsSystem Spec

  2. #2

    Posts : 2,191
    Windows 8.1

    Hello TheAncient,

    Follow this tutorial and see if that will resolve your issue.

    DISM - Fixing Component Store Corruption in Windows 8

    Good luck
      My System SpecsSystem Spec

  3. #3

    Posts : 26
    2 x W7-64, W81-64, W10-64, 2 x NAS (Samba), and a partridge in a pear tree

    DISM found no corruption

    Thanks for your quick reply!
    I had already run
    Dism /Online /Cleanup-Image /CheckHealth
    Dism /Online /Cleanup-Image /ScanHealth
    Dism /Online /Cleanup-Image /RestoreHealth

    In an elevated command prompt but DISM found "No component Store Corruption"
    Any other ideas?
      My System SpecsSystem Spec

  4. #4

    Posts : 2,191
    Windows 8.1

    Did you run sfc /scannow first and were there any errors from that? If so, then you would run:

    Dism /Online /Cleanup-Image /RestoreHealth

    You could skip the first 3...
      My System SpecsSystem Spec

  5. #5

    Posts : 26
    2 x W7-64, W81-64, W10-64, 2 x NAS (Samba), and a partridge in a pear tree

    SFC /scannow solved the problem

    System File Checker did the trick:
    Ran sfc /scannow which repaired "something"
    Ran Windows Update again and all is well.

    (When I re-started, I got a prompt asking which Windows Installation I wanted to use: "Windows 8" or "Windows".
    Err - I only have the one Windows 8 installation - where did it find another one?
    But that's another topic for another day)

    Thanks a lot for your help!
    Suggest you change your nick to "2Bucks"
      My System SpecsSystem Spec

  6. #6

    Posts : 2,191
    Windows 8.1

    That's wonderful news! Glad you got it fixed! Thanks for the acknowledgement too!
      My System SpecsSystem Spec

  7. #7

    Posts : 26
    2 x W7-64, W81-64, W10-64, 2 x NAS (Samba), and a partridge in a pear tree

    Turns out I spoke too soon: Only three of the six updates installed correctly.
    I re-ran the sfc and DISM with the restorehealth parameter - all appeared to be clean
    Rebooted, Ran Windows Update, KB2781197, KB2845533, KB2856373 are still offered.
    Tried to install the first one (KB2781197) by itself: It failed with Error 80070026
      My System SpecsSystem Spec

  8. #8

    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64

    You can try to create a bat file from this link and run it as admin then run update again:
    windows update 80070026 error - Microsoft Community

      My System SpecsSystem Spec

  9. #9

    Posts : 26
    2 x W7-64, W81-64, W10-64, 2 x NAS (Samba), and a partridge in a pear tree

    Symbolic Link could be the culprit

    I found a post at KB2856373 update failing with error 80070026 - Microsoft Community
    This posts deals with the exact same problem I have: KB2856373 fails with Error 80070026 (I haven't checked the remaining 2 updates ).
    In the last post of that thread, the original poster notes that he may have found the cause:
    "My primary hard drive is a 120 GB SSD, as a result, I also have a 1.5 TB traditional hard drive installed. In order to prevent write cycles and to free up space on my SSD, I used symbolic links to redirect C:\Users to D:\Users. Usually this causes no problems as everything is redirected without issue. However, in the case of this update, it needs C:\Users to be at C:\Users instead of symbolically linked to D:\Users."
    My circumstances are identical and thus could be caused by the same anomaly. The question now is, how do I work around this? I certainly do not want to move all the user files back to C: and remove the link.

    Any thoughts?

    @topgundcp: I have not yet tried your batch file - I have to leave some work for tomorrow so I can justify my existence. Right now it's Miller Time!
      My System SpecsSystem Spec

  10. #10

    Posts : 2,191
    Windows 8.1

    If topguncp's fix works then great; however, if for some reason it does not, have you tried this Fixit Solution from Microsoft? It is different from the internal troubleshooter from what I understand:

    Fix the problem with Microsoft Windows Update that is not working
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Multiple W8 Update failures - TroubleShooter no help
Related Threads
A number of my (mainly MS) apps were damaged by an agent dealing with anti-virus software. Some key Tiles refuse to respond. After reading much of the detailed help on this Forum I downloaded the Troubleshooter and got the Store back (so some progress}. But the damaged apps, such as Outlook,...
Asus laptop windows 8 update failures. in Windows Updates & Activation
Hi there. I just recently bought asus notebook x550C i3 processor,had been working fine for a week. Then lost connection to Internet went to update and restart as updates were needing to be done. After appearing to complete the updates, it then said failure configuring updates, reverting...
After going through the endless loop* of Win 8.1 updates one more time (2-3 more times?), I again used the 3-finger salute to finally bring my system to a halt. I rebooted and got the lockscreen and logon screens as usual. I then went to Settings \ Control Panel \ Troubleshooting \ Fix problems...
Fix Microsoft Account Issues in Windows 8 with "Microsoft Accounts" Troubleshooter This tutorial will show you how to download and run the Microsoft Accounts troubleshooter to help troubleshoot and fix common issues with Microsoft accounts automatically in Windows 8. Microsoft Accounts...
Various BSOD failures in BSOD Crashes and Debugging
I have a Windows 8 PC with a ASRock E350M1 motherboard that has no real Windows 8 drivers and I think that may be causing my problems, but it may also be hardware related. After enough crashes it stops booting and I need to reinstall Win 8. Attached debugging info. First post here. Thanks for...
Updates Failures in Windows Updates & Activation
I have had Win 8 installed for approx. 3 weeks now and love it. Takes a bit of tweaking at first but worth it. I have currently 6 updates waiting installation and none will install. :mad: 1. Security update for framework 3.5 on Windows 8x86 (KB2739462) 2. Sec update KB2727528...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook