• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Unplugging an External Drive Powers on the Computer


Ark

Member
Member
Posts
26
#1
Hi, I notice that when my computer is in sleep mode, I can unplug the external hard drive and the computer will power on again. I never had this issue with Windows 7. Right now I have Windows 8 Pro 64-bit.

Is there any way for me to disable this feature so that I can unplug the external hard drive without turning the computer back on again?

Thanks
 

My Computer

System One

  • OS
    Windows 7

ninelives

Seize the Day
Member
Philippines

Posts
10
#3
Is your PC running on AHCI mode?
 

My Computer

System One

  • OS
    Windows 8 Pro x64
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Custom Build
    CPU
    AMD Phenom X4 B55
    Motherboard
    M5A78L-M LX3
    Memory
    G.Skill 1333Mhz
    Graphics Card(s)
    Sapphire HD6570
    Hard Drives
    OCZ Agility 3 60GB, Western Digital Caviar blue 500GB
    Browser
    Chrome
    Antivirus
    Windows Defender

topgundcp

Well-Known Member
VIP Member
Guru
San Jose - California

Posts
2,847
#4
Couple of places you might want to look at.

  1. Open Device Manager and look at the option in the screenshot

    4-8-2013 4-43-31 AM.png
  2. Control Panel->Power Options->Change plan Settings and look at the screenshot

    4-8-2013 4-51-59 AM.png
 

My Computer

System One

  • OS
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home Brewed
    CPU
    I7 4970K OC'ed @4.7 GHz
    Motherboard
    MSI-Z97
    Memory
    16 GB G-Skill Trident X @2400MHZ
    Graphics Card(s)
    NVIDIA GeForce GTS 450
    Sound Card
    X-Fi Titanium Fatal1ty Professional Series
    Monitor(s) Displays
    Dual HP-W2408
    Screen Resolution
    1920X1200
    Hard Drives
    256 GB M2 sm951, (2) 500GB 850EVO, 5TB, 2 TB Seagate
    PSU
    Antec 850W
    Case
    Antec 1200
    Cooling
    Danger Den H20
    Keyboard
    Logitech
    Mouse
    Logitech Performance Mouse MX
    Internet Speed
    35/12mbps
    Browser
    Firefox

Ark

Member
Member
Posts
26
#5
Thank you for the help! Here's what I've done so far:

1. I went through the device manager and ensured all eight of my USB ports, or root hubs, were unchecked for the option shown in the image. Not only were they unchecked by default, but the option was grayed out ( so I could not check it even if I wanted to)

2. I went into the power options and disabled the setting for allowing the wake timers as shown in the image. I then put the computer to sleep, unplugged the external USB hard drive, and unfortunately the computer turned on again.

Is there anything else That might be causing the issue?

Is your PC running on AHCI mode?

I am not sure, how can I check this?

Thanks again
 

My Computer

System One

  • OS
    Windows 7

topgundcp

Well-Known Member
VIP Member
Guru
San Jose - California

Posts
2,847
#6
How about go back to Device Manager and check Human Interface Devices->USB Input Device for power Management. Do you use USB Mouse and Keyboard ?, if so, check them too.
 

My Computer

System One

  • OS
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home Brewed
    CPU
    I7 4970K OC'ed @4.7 GHz
    Motherboard
    MSI-Z97
    Memory
    16 GB G-Skill Trident X @2400MHZ
    Graphics Card(s)
    NVIDIA GeForce GTS 450
    Sound Card
    X-Fi Titanium Fatal1ty Professional Series
    Monitor(s) Displays
    Dual HP-W2408
    Screen Resolution
    1920X1200
    Hard Drives
    256 GB M2 sm951, (2) 500GB 850EVO, 5TB, 2 TB Seagate
    PSU
    Antec 850W
    Case
    Antec 1200
    Cooling
    Danger Den H20
    Keyboard
    Logitech
    Mouse
    Logitech Performance Mouse MX
    Internet Speed
    35/12mbps
    Browser
    Firefox

Ark

Member
Member
Posts
26
#7
Hi, now my USB mouse or keyboard won't wake up the computer but unplugging the USB drive will! Is there anything else to check?
 

My Computer

System One

  • OS
    Windows 7

topgundcp

Well-Known Member
VIP Member
Guru
San Jose - California

Posts
2,847
#8
Last check is boot to your BIOS to see if anything set up in there. In addition, make sure you have the latest BIOS installed.
 

My Computer

System One

  • OS
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home Brewed
    CPU
    I7 4970K OC'ed @4.7 GHz
    Motherboard
    MSI-Z97
    Memory
    16 GB G-Skill Trident X @2400MHZ
    Graphics Card(s)
    NVIDIA GeForce GTS 450
    Sound Card
    X-Fi Titanium Fatal1ty Professional Series
    Monitor(s) Displays
    Dual HP-W2408
    Screen Resolution
    1920X1200
    Hard Drives
    256 GB M2 sm951, (2) 500GB 850EVO, 5TB, 2 TB Seagate
    PSU
    Antec 850W
    Case
    Antec 1200
    Cooling
    Danger Den H20
    Keyboard
    Logitech
    Mouse
    Logitech Performance Mouse MX
    Internet Speed
    35/12mbps
    Browser
    Firefox

XweAponX

New Member
VIP Member
Pro User
#9
Also check your BIOS and Windows 8 Power settings, for any Wake options, some motherboards have a bunch of Wake options, like Wake on Modem and Wake on Lan and USB. Disable any of those if you have them. Some brand name PC's have these settings removed. and shut off any USB Wake options. Go Into Power Options, choose Advanced Power Options, and shut off any Wake Timers.
 

My Computer

System One

  • OS
    Windows 8 Pro with Media Center/Windows 7
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Asus M2N-MX SE Plus § DualCore AMD Athlon 64 X2, 2300 MHz (11.5 x 200) 4400+ § Corsair Value Select
    CPU
    AMD 4400+/4200+
    Motherboard
    Asus M2N-MX SE Plus/Asus A8M2N-LA (NodusM)
    Memory
    2 GB/3GB
    Graphics Card(s)
    GeForce 8400 GS/GeForce 210
    Sound Card
    nVIDIA GT218 - High Definition Audio Controller
    Monitor(s) Displays
    Hitachi 40" LCD HDTV
    Screen Resolution
    "1842 x 1036"
    Hard Drives
    WDC WD50 00AAKS-007AA SCSI Disk Device
    ST1000DL 002-9TT153 SCSI Disk Device
    WDC WD3200AAJB-00J3A0 ATA Device
    WDC WD32 WD-WCAPZ2942630 USB Device
    WD My Book 1140 USB Device
    PSU
    Works 550w
    Case
    MSI "M-Box"
    Cooling
    Water Cooled
    Keyboard
    Dell Keyboard
    Mouse
    Microsoft Intellimouse
    Internet Speed
    Cable Medium Speed
    Browser
    Chrome/IE 10
    Antivirus
    Eset NOD32 6.x/Win Defend
    Other Info
    Recently lost my Windows 8 on my main PC, had to go back to Windows 7.

ninelives

Seize the Day
Member
Philippines

Posts
10
#10
I am not sure, how can I check this?

Thanks again
Open regedit:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci

In the right pane you can see 'start'
Value data 0 - AHCI Enabled
if
Value data 3 - AHCI Disabled
 

My Computer

System One

  • OS
    Windows 8 Pro x64
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Custom Build
    CPU
    AMD Phenom X4 B55
    Motherboard
    M5A78L-M LX3
    Memory
    G.Skill 1333Mhz
    Graphics Card(s)
    Sapphire HD6570
    Hard Drives
    OCZ Agility 3 60GB, Western Digital Caviar blue 500GB
    Browser
    Chrome
    Antivirus
    Windows Defender

whs

New Member
VIP Member
Guru
Germany/Florida

Posts
4,514
#11
Your computers behavior is normal. Whenever it gets an external interrupt, it will wake up. That could be by unplugging a device, starting a printer, from the internet, etc.

You have to go into device properties in the device manager and shut off each device that has a power management button.
 

My Computer

System One

  • OS
    Vista and Win7
    System Manufacturer/Model Number
    2xHP, 2xGateway, 1xDell, 1xSony
    Hard Drives
    5 SSDs and 12 HDs