What's new

System Reserved on Wrong Drive

john970

New Member
When I installed Windows 8, it recognized a hard drive as Disk 0 and my SSD as Disk 1. I didn't know that it was important to put the system files on Disk 0, with the System Reserved partition, and installed Windows on the SSD. After installation, I saw that the hard drive had a System Reserved partition and a larger partition, which I combined. So it now has one partition marked System Reserved. I installed my programs on the SSD and only data files on the System Reserved hard drive, and everything is working. However, when I swapped in another hard drive in place of the hard drive with the System Reserved partition, the computer wouldn't boot. Thus I'm going to have to do something about it.

In the Disk Management screen under Computer Management, the drives show up as follows:

HDD: Disk 0: System Reserved (D:) Healthy (System, Active, Primary Partition)

SSD: Disk 1: (C:) Healthy (Boot, Page File, Crash Dump, Primary Partition)

How can I get rid of the System Reserved designation on the Disk 0 hard drive and place it on the Disk 1 SSD without having to reinstall Windows and my programs on the SSD? I don't mind having to recopy data files to the hard drive if gets wiped clean.
 

My Computer

System One

  • OS
    Windows 8

Anusha

New Member
Member
I don't think it is something you can do without starting from the scratch.

Perhaps if you unplug your HDD, boot from Windows disc or USB and hit repair, it will fix it. If all's fine, plug in the HDD and remove the 100MB partition and combine it with the next partition. ( but I don't think you can do it from Disk Management without losing your data. You will have to find a 3rd party tool like Acronis Disk Director.)
 

My Computer

System One

  • OS
    Windows 8.1 Pro x64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    DIY
    CPU
    Intel Core i7 4790K @4.5GHz
    Motherboard
    Asus ROG Maximus VII Gene
    Memory
    16GB A-DATA DDR3-2400
    Graphics Card(s)
    Gigabyte GTX 970 Gaming G1
    Monitor(s) Displays
    QNIX QX2710
    Screen Resolution
    2560x1440
    Hard Drives
    Samsung 840 series 250GB
    Toshiba DT01ACA300 3TB (Data)
    Western Digital Caviar Green WD30EZRX-00DC0B0 3TB (Backup)
    PSU
    Silversonte G series 750W
    Case
    Silverstone Sugo SG09
    Cooling
    Noctua NH-U12S
    Keyboard
    Generic
    Mouse
    Logitech G602
    Internet Speed
    200Mbps/200Mbps Fibre
    Browser
    Google Chrome
    Antivirus
    Windows Defender

theog

VIP Member
VIP Member
Gold Member
Physically disconnect the HD Drive.
Make the Windows 8 SSD, disk0 & first HD boot in BIOS.Also connected to the first Sata port on the MOBO.

Than boot the DVD & run Repairs.
http://www.eightforums.com/tutorials/2269-system-recovery-options-boot-windows-8-a.html


How to do a Auto Repair:
http://www.eightforums.com/tutorials/2843-automatic-repair-run-windows-8-a.html

How do a Refresh:
http://www.eightforums.com/tutorials/2293-refresh-windows-8-a.html


How to do a Reset:
http://www.eightforums.com/tutorials/2302-reset-windows-8-a.html



When Windows is booting OK, replace HD Drive back in & make sure you mark the HD Drive INACTIVE:
Partition - Mark as Inactive - Windows 7 Forums
 

My Computer

System One

  • OS
    ME, XP,Vista,Win7,Win8,Win8.1
    Computer type
    PC/Desktop
    Other Info
    Notebooks x 3

    Desktops x 5

    Towers x 4

john970

New Member
Thanks for the advice. I connected the SSD to the first SATA port. However, I was unable to make it Disk0 in the BIOS because I have an Asus Z77 motherboard that automates hard disk detection and does not show the storage drives in BIOS screens. I disconnected the hard drive, booted from the DVD, and ran Automatic Repair, which worked partially. After reconnecting the hard drive and rebooting, I tried to make the hard drive inactive in Disk Management, but the option isn't available. "Mark Partition as Active" is the only choice, and it is grayed out on both drives. Here are what Disk Management displays:

HDD: Disk 0 - System Reserved (E:) Healthy (Active, Primary Partition)

SSD: Disk 1 - (C:) Healthy (System, Boot, Page File, Active, Crash Dump, Primary Partition)

I tried to change the HDD drive letter back to D:, but that option isn't available.

The HDD no longer includes System, but it's still Disk 0, System Reserved, and Active, and the drive letter has changed from D: to E: and can't be reset.
 

My Computer

System One

  • OS
    Windows 8

Anusha

New Member
Member
Does Windows boot up without the hard drive plugged in?

If the hard drive doesn't have any data, a simple repartitioning would fix everything right?
 

My Computer

System One

  • OS
    Windows 8.1 Pro x64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    DIY
    CPU
    Intel Core i7 4790K @4.5GHz
    Motherboard
    Asus ROG Maximus VII Gene
    Memory
    16GB A-DATA DDR3-2400
    Graphics Card(s)
    Gigabyte GTX 970 Gaming G1
    Monitor(s) Displays
    QNIX QX2710
    Screen Resolution
    2560x1440
    Hard Drives
    Samsung 840 series 250GB
    Toshiba DT01ACA300 3TB (Data)
    Western Digital Caviar Green WD30EZRX-00DC0B0 3TB (Backup)
    PSU
    Silversonte G series 750W
    Case
    Silverstone Sugo SG09
    Cooling
    Noctua NH-U12S
    Keyboard
    Generic
    Mouse
    Logitech G602
    Internet Speed
    200Mbps/200Mbps Fibre
    Browser
    Google Chrome
    Antivirus
    Windows Defender

Saltgrass

New Member
Pro User
Dsikpart can make a partition inactive, which needs to be done with on the Active HDD partition.

You already have the partition set to active on the SSD. Unplug the HDD and run the Automatic repair.

And you can set the drive priority in the bios on a Z77 (used advanced settings). Showing a drive as Drive 0 does not mean it is first priority.
 

My Computer

System One

  • OS
    Windows 8.1 x64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home Grown
    CPU
    i7 3770K
    Motherboard
    ASUS P8Z77 -v Pro, Z87-Expert
    Memory
    16 G
    Graphics Card(s)
    EVGA GTX 680 Classified (2)
    Hard Drives
    Kingston SSD 240 GB

john970

New Member
I ran diskpart and set the hard drive to inactive. From the diskpart list, I noticed that drive letter D: had been assigned to a DVD drive, so I reset the drive letters in Disk Management. I also deleted the volume name "System Reserved" from the hard drive from Properties in Disk Management. It's still Disk 0, but as previously, the computer boots normally to the SSD, which still is Disk 1 and HarddiskVolume2. I looked again at the BIOS setup on the Z77, BIOS 1708, and the only options under SATA configuration are to Enable or Disable Hot Plug on each drive. Unless there is some reason that the SSD should be Disk 0, the problem appears to be solved.
 

My Computer

System One

  • OS
    Windows 8

theog

VIP Member
VIP Member
Gold Member
As long as it booting, it will be OK. Well done :dinesh:
 

My Computer

System One

  • OS
    ME, XP,Vista,Win7,Win8,Win8.1
    Computer type
    PC/Desktop
    Other Info
    Notebooks x 3

    Desktops x 5

    Towers x 4

Saltgrass

New Member
Pro User
To set the drive priority on a P8Z77, you need to be in the Boot section. There will be a "Hard Drive BBS Priorities" section to set the primary drive. You may have to scroll down to see it, but this works for an MBR install as you have. An install will put the active partition and boot files on that drive.

If you ever use the UEFI options on that board, it is handled a little differently.
 

Attachments

  • Bios.gif
    Bios.gif
    30.9 KB · Views: 5,226

My Computer

System One

  • OS
    Windows 8.1 x64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home Grown
    CPU
    i7 3770K
    Motherboard
    ASUS P8Z77 -v Pro, Z87-Expert
    Memory
    16 G
    Graphics Card(s)
    EVGA GTX 680 Classified (2)
    Hard Drives
    Kingston SSD 240 GB

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top