• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Running out of memory when running overnight.


#1
First let me say, I rarely leave my 8.1 system running all night as I generally switch off before bed.

On the FEW occasions I leave the system running all night I always get the "Your computer is low on memory" warning.

For instance, yesterday my software RAID mirror was "Re-synchronizing" and I wanted it to complete syncing so I left it running. NOTHING was running except Disk Manager. I closed down everything else. No browser, no Skype, no directory utility, no paint, no uTorrent....

Sure enough when I woke up this morning there it was....

A few days ago I wanted a couple of torrents to keep downloading so I kept the desktop running. Again NOTHING else was running and in the morning there it was....

I have 16Gb of memory and my pagefile.sys is 42Gb. My OS disc is a 250Gb SSD. I have set my system to hibernate after 5 hours idle. I have set the screen/display to sleep after 30 minutes.

The system isn't asleep when I wake as moving the mouse immediately brings the display back on line. Checking Task Manager shows NO memory hogs.

What I suspect is (please feel free to confirm or deny this suspicion), after 5 hours the hibernation process denies access to memory requests or something?

The strange thing is millions of people on 8.1 must leave their systems running all night but I have seen no mention of this behaviour.

Comments anyone? :confused:
 

Attachments

My Computer

System One

  • OS
    7 Pro & 8.1 Pro & 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Self Built & self built
    CPU
    i7 870 & i7 4771 & i7 HP Laptop
    Motherboard
    GA-P55A-UD7 & Asus Z87 Deluxe/Dual
    Memory
    8Gb & 16Gb
    Graphics Card(s)
    HD5770 & None
    Sound Card
    inbuilt & inbuilt
    Monitor(s) Displays
    32' LED TV
    Screen Resolution
    1920 X 1080
    Hard Drives
    About 40Tb
    PSU
    Antec TP-750C & Ditto
    Case
    Antec DF-85 & Antec Nineteen Hundred
    Cooling
    7 fans & 6 fans
    Keyboard
    Logitech MX5500 Combo
    Mouse
    Logitech MX5500 Combo
    Internet Speed
    Naked DSL
    Browser
    Firefox
    Antivirus
    AVG

Wullail

Active Member
Pro User
Posts
467
#2
Check the task manager next time it happens and see if anything obvious is hogging RAM.
 

My Computer

System One

  • OS
    Windows 8 Pro
    Computer type
    PC/Desktop
    Memory
    6 GB
    Screen Resolution
    1280 x 1024
    Hard Drives
    12 TB in 6 disks
    PSU
    TX650
    Keyboard
    G15
    Mouse
    Intellimouse 3.0
    Internet Speed
    100 Mbits
    Browser
    Chrome
    Antivirus
    Trend Micro
Posts
39
#3
Yeah, you should check task manager if memory is still in usage, because some tasks may require some memory, i.e. i have 4 gb ram, and when i fresh install windows, i run windows update, and windows update installer hogs almost all my memory... But of course when it is done installing, it frees the memory.
 

My Computer

System One

  • OS
    8.1 x64
#4
As I said, I did check the task manager and there were no apparent memory hogs.... In fact, when I checked, only about 1% or 2% of memory was in use.

i think it is something to do with hibernation?

i will try to switch off hibernation tonight and see if that makes a difference?

i say "try" because I am still not confident enough with 8.1 to say I can. :(
 

My Computer

System One

  • OS
    7 Pro & 8.1 Pro & 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Self Built & self built
    CPU
    i7 870 & i7 4771 & i7 HP Laptop
    Motherboard
    GA-P55A-UD7 & Asus Z87 Deluxe/Dual
    Memory
    8Gb & 16Gb
    Graphics Card(s)
    HD5770 & None
    Sound Card
    inbuilt & inbuilt
    Monitor(s) Displays
    32' LED TV
    Screen Resolution
    1920 X 1080
    Hard Drives
    About 40Tb
    PSU
    Antec TP-750C & Ditto
    Case
    Antec DF-85 & Antec Nineteen Hundred
    Cooling
    7 fans & 6 fans
    Keyboard
    Logitech MX5500 Combo
    Mouse
    Logitech MX5500 Combo
    Internet Speed
    Naked DSL
    Browser
    Firefox
    Antivirus
    AVG
#5
Sorry, I HAVE set my desktop to "Sleep - Never" so that suspicion was false :(

I don't have a clue why I get the "Low Memory" warning when I leave my desktop switched on all night :(

I will leave my desktop running again tonight. When I get the warning tomorrow I will snapshot the Task Manager display and post it here.

I will close the Firefox browser so the ONLY process running will be uTorrent. I have already closed Disk Manager.

Fingers crossed :)
 
Last edited:

My Computer

System One

  • OS
    7 Pro & 8.1 Pro & 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Self Built & self built
    CPU
    i7 870 & i7 4771 & i7 HP Laptop
    Motherboard
    GA-P55A-UD7 & Asus Z87 Deluxe/Dual
    Memory
    8Gb & 16Gb
    Graphics Card(s)
    HD5770 & None
    Sound Card
    inbuilt & inbuilt
    Monitor(s) Displays
    32' LED TV
    Screen Resolution
    1920 X 1080
    Hard Drives
    About 40Tb
    PSU
    Antec TP-750C & Ditto
    Case
    Antec DF-85 & Antec Nineteen Hundred
    Cooling
    7 fans & 6 fans
    Keyboard
    Logitech MX5500 Combo
    Mouse
    Logitech MX5500 Combo
    Internet Speed
    Naked DSL
    Browser
    Firefox
    Antivirus
    AVG

TairikuOkami

Be nice to all, please?!
Pro User
Trnava

Posts
683
#6
Try to use RAMMap to find the culprit. I myself prefer Process Hacker it is much more informative.
 

Attachments

My Computer

System One

  • OS
    Win 8.1.1 Pro x64
    Computer type
    Laptop
    System Manufacturer/Model
    Lenovo E525
    CPU
    AMD A4-3300M @ 2,0GHz
    Memory
    6GB DDR3 1333MHz
    Graphics Card(s)
    AMD Radeon HD 6480G 512MB shared
    Sound Card
    Creative Sound Blaster X-Fi Surround 5.1
    Screen Resolution
    1366x768
    Hard Drives
    WD 465GB
    Cooling
    Fusion Tweaker
    Keyboard
    Logitech K360
    Mouse
    Logitech M705
    Internet Speed
    50/50 MBps
    Browser
    Yandex
    Antivirus
    No AV & No Firewall
    Other Info
    Headphones: Sennheiser RS170
#7
Okay, I left it on last night downloading 4 OLD TV series. They were 24 years old so no one should object about copywrites etc :p

I got the low memory warning as expected but whatever caused it was well and truly over as Task Manager said 9% of memory was in use. I also attached a couple of RamMaps for anyone who can read them but I suspect the reason for the warning was over?

The hyberfil.sys file is 12.5Gb, pagefile.sys is 44Gb and swapfile.sys is 256Mb if this helps?

I am beginning to suspect I have a dodgy motherboard as I also have problems with my external USB3 HDDs too. I will try to raise another thread about the USB3 problem soon :(
 

Attachments

My Computer

System One

  • OS
    7 Pro & 8.1 Pro & 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Self Built & self built
    CPU
    i7 870 & i7 4771 & i7 HP Laptop
    Motherboard
    GA-P55A-UD7 & Asus Z87 Deluxe/Dual
    Memory
    8Gb & 16Gb
    Graphics Card(s)
    HD5770 & None
    Sound Card
    inbuilt & inbuilt
    Monitor(s) Displays
    32' LED TV
    Screen Resolution
    1920 X 1080
    Hard Drives
    About 40Tb
    PSU
    Antec TP-750C & Ditto
    Case
    Antec DF-85 & Antec Nineteen Hundred
    Cooling
    7 fans & 6 fans
    Keyboard
    Logitech MX5500 Combo
    Mouse
    Logitech MX5500 Combo
    Internet Speed
    Naked DSL
    Browser
    Firefox
    Antivirus
    AVG

popeye

New Member
VIP Member
Guru
United States

Posts
3,090
#8
I've had this happen with older programs/drivers. Found if I run it in compatibility mode, 7, Vista, Xp it goes away. Have to experiment which mode it likes.

What download app are you using?
 

My Computer

System One

  • OS
    Windows 8.1 Pro 64-bit
    Computer type
    Laptop
    System Manufacturer/Model
    Acer V3 771G-6443
    CPU
    i5-3230m
    Motherboard
    Acer VA70_HC (U3E1)
    Memory
    8GB DDR3 PC3-12800 (800 MHz)
    Graphics Card(s)
    HD4000 + GeForce GT 730M
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    17" Generic PnP Display on Intel HD Graphics 4000
    Screen Resolution
    1600x900 pixels
    Hard Drives
    Samsung SSD 850 EVO 250 GB
    ADATA SSD SP900 128GB
    PSU
    90 watt brick
    Mouse
    Bluetooth
    Antivirus
    Comodo
    Other Info
    Asus RT-AC56R dual-band WRT router (Merlin firmware). Intel 7260.HMWWB.R dual-band ac wireless adapter.
#9
Just a quick response - uTorrent.

But it also happens with JUST Disk Manager running too.

I would imagine both programs would be current and fully compatible with 8.1 :D
 

My Computer

System One

  • OS
    7 Pro & 8.1 Pro & 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Self Built & self built
    CPU
    i7 870 & i7 4771 & i7 HP Laptop
    Motherboard
    GA-P55A-UD7 & Asus Z87 Deluxe/Dual
    Memory
    8Gb & 16Gb
    Graphics Card(s)
    HD5770 & None
    Sound Card
    inbuilt & inbuilt
    Monitor(s) Displays
    32' LED TV
    Screen Resolution
    1920 X 1080
    Hard Drives
    About 40Tb
    PSU
    Antec TP-750C & Ditto
    Case
    Antec DF-85 & Antec Nineteen Hundred
    Cooling
    7 fans & 6 fans
    Keyboard
    Logitech MX5500 Combo
    Mouse
    Logitech MX5500 Combo
    Internet Speed
    Naked DSL
    Browser
    Firefox
    Antivirus
    AVG

popeye

New Member
VIP Member
Guru
United States

Posts
3,090
#10
Just a quick response - uTorrent.

But it also happens with JUST Disk Manager running too.

I would imagine both programs would be current and fully compatible with 8.1 :D
Take it or leave it. Just telling you my experience. :)
 

My Computer

System One

  • OS
    Windows 8.1 Pro 64-bit
    Computer type
    Laptop
    System Manufacturer/Model
    Acer V3 771G-6443
    CPU
    i5-3230m
    Motherboard
    Acer VA70_HC (U3E1)
    Memory
    8GB DDR3 PC3-12800 (800 MHz)
    Graphics Card(s)
    HD4000 + GeForce GT 730M
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    17" Generic PnP Display on Intel HD Graphics 4000
    Screen Resolution
    1600x900 pixels
    Hard Drives
    Samsung SSD 850 EVO 250 GB
    ADATA SSD SP900 128GB
    PSU
    90 watt brick
    Mouse
    Bluetooth
    Antivirus
    Comodo
    Other Info
    Asus RT-AC56R dual-band WRT router (Merlin firmware). Intel 7260.HMWWB.R dual-band ac wireless adapter.
#11
Okay this time was during the day. Firefox, Skype, uTorrent and a directory utility were running.

I was going to walk around and do some errands so I Windows/L, shut off sound and turned off the screen.

I was gone for 2 and a half or three hours tops.

As you can see from the warning, it says Firefox. As you can see from Task Manager 23% of memory is in use and Firefox is using 465Mb. I have 17 tabs open in Firefox. Prior to this I NEVER have Firefox running overnight.

This making sense to anyone here? :confused:
 

Attachments

My Computer

System One

  • OS
    7 Pro & 8.1 Pro & 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Self Built & self built
    CPU
    i7 870 & i7 4771 & i7 HP Laptop
    Motherboard
    GA-P55A-UD7 & Asus Z87 Deluxe/Dual
    Memory
    8Gb & 16Gb
    Graphics Card(s)
    HD5770 & None
    Sound Card
    inbuilt & inbuilt
    Monitor(s) Displays
    32' LED TV
    Screen Resolution
    1920 X 1080
    Hard Drives
    About 40Tb
    PSU
    Antec TP-750C & Ditto
    Case
    Antec DF-85 & Antec Nineteen Hundred
    Cooling
    7 fans & 6 fans
    Keyboard
    Logitech MX5500 Combo
    Mouse
    Logitech MX5500 Combo
    Internet Speed
    Naked DSL
    Browser
    Firefox
    Antivirus
    AVG

CountMike

Well-Known Member
VIP Member
Guru
Belgrade , Serbia

Posts
4,664
#12
Yes, it make sense with FF (probably all other browsers). FF uses as much ram as possible to keep open tabs open so it does not have to download same pages again when you switch focus on tabs. It also depends on size of page in the tabs, so it may take more or less memory for them. I have 5 tabs open right now and is using 71 MB of RAM. Have a program called MemInfo MemInfo - Carthago Software which sits in the taskbar and can tell me how much RAM is used by all the running programs, percentage etc. It also has memory defragmenter which when run cleans up a lot. As I run it right now it lowered FF RAM usage to 179 MB.
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home made
    CPU
    AMD Ryzen7 2700x
    Motherboard
    Asus Prime x470 Pro
    Memory
    16GB Kingston 3600
    Graphics Card(s)
    Asus strix 570 OC 4gb
    Hard Drives
    Samsung 960 evo 250GB
    Silicon Power V70 240GB SSD
    WD 1 TB Blue
    WD 2 TB Blue
    Bunch of backup HDDs.
    PSU
    Sharkoon, Silent Storm 660W
    Case
    Raidmax
    Cooling
    CCM Nepton 140xl
    Internet Speed
    40/2 Mbps
    Browser
    Firefox
    Antivirus
    WD
#13
Thanks for your response :)

Just to add further to the confusion. I went out again for 2 and a half hours (about).

ONLY uTorrent running (NO Firefox nothing else) :)

Got the warning AGAIN :(

Could I have dud memory? The box says CORSAIR VENGEANCE PRO SERIES DDR3 2X8GB 2400MHZ but the UEFI BIOS says it is 1333MHZ memory? :zip:
 

Attachments

My Computer

System One

  • OS
    7 Pro & 8.1 Pro & 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Self Built & self built
    CPU
    i7 870 & i7 4771 & i7 HP Laptop
    Motherboard
    GA-P55A-UD7 & Asus Z87 Deluxe/Dual
    Memory
    8Gb & 16Gb
    Graphics Card(s)
    HD5770 & None
    Sound Card
    inbuilt & inbuilt
    Monitor(s) Displays
    32' LED TV
    Screen Resolution
    1920 X 1080
    Hard Drives
    About 40Tb
    PSU
    Antec TP-750C & Ditto
    Case
    Antec DF-85 & Antec Nineteen Hundred
    Cooling
    7 fans & 6 fans
    Keyboard
    Logitech MX5500 Combo
    Mouse
    Logitech MX5500 Combo
    Internet Speed
    Naked DSL
    Browser
    Firefox
    Antivirus
    AVG

CountMike

Well-Known Member
VIP Member
Guru
Belgrade , Serbia

Posts
4,664
#14
Probably nothing wrong with memory but BIOS is not set right for it. 1333 MHz memory is default value with most of them. If it does not have or it wrongly red XMP Profile you will have to do it manually together with changing memory voltage that is usually higher than minimum required for it's operation. One example, Kingston HyperX 1600 MHz needs 1.6v for 1600 but defaults to 1333MHz if 1.5v. You'll have to check manuals for MB and RAM to set everything right.
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home made
    CPU
    AMD Ryzen7 2700x
    Motherboard
    Asus Prime x470 Pro
    Memory
    16GB Kingston 3600
    Graphics Card(s)
    Asus strix 570 OC 4gb
    Hard Drives
    Samsung 960 evo 250GB
    Silicon Power V70 240GB SSD
    WD 1 TB Blue
    WD 2 TB Blue
    Bunch of backup HDDs.
    PSU
    Sharkoon, Silent Storm 660W
    Case
    Raidmax
    Cooling
    CCM Nepton 140xl
    Internet Speed
    40/2 Mbps
    Browser
    Firefox
    Antivirus
    WD
#15
Wow! Brain overload.... :(

Didn't I tell you making changes etc to BIOS frightens the **** out of me :(

I'm terrified I might do something wrong and blow the MB or something :(
 

My Computer

System One

  • OS
    7 Pro & 8.1 Pro & 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Self Built & self built
    CPU
    i7 870 & i7 4771 & i7 HP Laptop
    Motherboard
    GA-P55A-UD7 & Asus Z87 Deluxe/Dual
    Memory
    8Gb & 16Gb
    Graphics Card(s)
    HD5770 & None
    Sound Card
    inbuilt & inbuilt
    Monitor(s) Displays
    32' LED TV
    Screen Resolution
    1920 X 1080
    Hard Drives
    About 40Tb
    PSU
    Antec TP-750C & Ditto
    Case
    Antec DF-85 & Antec Nineteen Hundred
    Cooling
    7 fans & 6 fans
    Keyboard
    Logitech MX5500 Combo
    Mouse
    Logitech MX5500 Combo
    Internet Speed
    Naked DSL
    Browser
    Firefox
    Antivirus
    AVG

CountMike

Well-Known Member
VIP Member
Guru
Belgrade , Serbia

Posts
4,664
#16
Wow! Brain overload.... :(

Didn't I tell you making changes etc to BIOS frightens the **** out of me :(

I'm terrified I might do something wrong and blow the MB or something :(
Manual in hand and slowly proceed, can't really blow anything up, first it will not let you and second there's always a way to go back to factory settings.
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home made
    CPU
    AMD Ryzen7 2700x
    Motherboard
    Asus Prime x470 Pro
    Memory
    16GB Kingston 3600
    Graphics Card(s)
    Asus strix 570 OC 4gb
    Hard Drives
    Samsung 960 evo 250GB
    Silicon Power V70 240GB SSD
    WD 1 TB Blue
    WD 2 TB Blue
    Bunch of backup HDDs.
    PSU
    Sharkoon, Silent Storm 660W
    Case
    Raidmax
    Cooling
    CCM Nepton 140xl
    Internet Speed
    40/2 Mbps
    Browser
    Firefox
    Antivirus
    WD

TairikuOkami

Be nice to all, please?!
Pro User
Trnava

Posts
683
#17
What is your disc cache setting in uTorrent?
 

Attachments

My Computer

System One

  • OS
    Win 8.1.1 Pro x64
    Computer type
    Laptop
    System Manufacturer/Model
    Lenovo E525
    CPU
    AMD A4-3300M @ 2,0GHz
    Memory
    6GB DDR3 1333MHz
    Graphics Card(s)
    AMD Radeon HD 6480G 512MB shared
    Sound Card
    Creative Sound Blaster X-Fi Surround 5.1
    Screen Resolution
    1366x768
    Hard Drives
    WD 465GB
    Cooling
    Fusion Tweaker
    Keyboard
    Logitech K360
    Mouse
    Logitech M705
    Internet Speed
    50/50 MBps
    Browser
    Yandex
    Antivirus
    No AV & No Firewall
    Other Info
    Headphones: Sennheiser RS170
#18
Just quickly to attach uTorrent Disk Cache asked for :D

At a quick look it is exactly like yours? :D
 

Attachments

My Computer

System One

  • OS
    7 Pro & 8.1 Pro & 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Self Built & self built
    CPU
    i7 870 & i7 4771 & i7 HP Laptop
    Motherboard
    GA-P55A-UD7 & Asus Z87 Deluxe/Dual
    Memory
    8Gb & 16Gb
    Graphics Card(s)
    HD5770 & None
    Sound Card
    inbuilt & inbuilt
    Monitor(s) Displays
    32' LED TV
    Screen Resolution
    1920 X 1080
    Hard Drives
    About 40Tb
    PSU
    Antec TP-750C & Ditto
    Case
    Antec DF-85 & Antec Nineteen Hundred
    Cooling
    7 fans & 6 fans
    Keyboard
    Logitech MX5500 Combo
    Mouse
    Logitech MX5500 Combo
    Internet Speed
    Naked DSL
    Browser
    Firefox
    Antivirus
    AVG

TairikuOkami

Be nice to all, please?!
Pro User
Trnava

Posts
683
#19
Well I am lost, try to use CleanMem Free, if nothing else, you will be able to eliminate memory leak problem.
 

My Computer

System One

  • OS
    Win 8.1.1 Pro x64
    Computer type
    Laptop
    System Manufacturer/Model
    Lenovo E525
    CPU
    AMD A4-3300M @ 2,0GHz
    Memory
    6GB DDR3 1333MHz
    Graphics Card(s)
    AMD Radeon HD 6480G 512MB shared
    Sound Card
    Creative Sound Blaster X-Fi Surround 5.1
    Screen Resolution
    1366x768
    Hard Drives
    WD 465GB
    Cooling
    Fusion Tweaker
    Keyboard
    Logitech K360
    Mouse
    Logitech M705
    Internet Speed
    50/50 MBps
    Browser
    Yandex
    Antivirus
    No AV & No Firewall
    Other Info
    Headphones: Sennheiser RS170

Users Who Are Viewing This Thread (Users: 0, Guests: 1)