Solved Launch Task Manager Minimized from Task Scheduler


I've added task manager to my scheduled tasks at logon. Everywhere I google, they say to put the /min or -minimized arguments in it to launch it minimized, except neither option works for me. Task Manager launches, but just sits there on my desktop.

Is there a new argument for minimized in Windows 8?


My Computer

System One

  • OS
    Windows 8 Pro, 64-bit
    System Manufacturer/Model
    Dell Latitude E6510
    Internet Speed
    Insanely fast when at work, insanely slow when at home
HOWTO: Start Task Manager automatically with every logon

I probably should have started a new thread for this, but the title of this one was perfect, so I decided to borrow it for my post instead of confusing people with multiple threads on the same topic.

First, to answer the question posed by the original poster, in case he or anyone still cares: "Minimized" isn't a parameter for the Task Manager itself - and never was; this isn't one of the changes that came with Windows 8. Rather, the old way (which still works for most programs) was to create a create a shortcut to the program you want to start minimized, and then to choose "Minimized" in the shortcut's settings, as shown in this example:


Placing a shortcut to Task Manager in the Startup folder no longer works the way it used to, but the reason has nothing to do with this; rather, with Windows 8, the new Task Manager must run with elevated privileges (in order to have access to all the new information it's capable of displaying), and Windows 8 doesn't allow that to happen for shortcuts in the Startup folder. (I don't think that older versions of Windows allowed that, either, but the old Task Manager didn't care; the new Task Manager will refuse to run without it.)

Anyway, on to the main reason for this message:
information   Information
This post will show you how to set up Windows 8 to start Task Manager automatically on every logon, providing almost the same functionality as was provided by the old shortcut method. (There are still some unresolved quirks with this procedure, but for me and probably most of you, this is still better than doing without.)

Starting with Windows Vista, Microsoft greatly expanded the Scheduled Tasks facility in Windows; now with Windows 8, it largely takes the place of older features like the Startup folder and the Run and RunOnce keys in the registry, which only exist now for compatibility with older programs.

Even if you're not a programmer, if you need to make your computer do something at certain times or when certain things happen, you should get familiar with the Task Scheduler (which is a much bigger topic than I can cover here - not to mention only peripherally related to the subject at hand).

To set Task Manager to run with every logon:

  1. Download the following XML file to your desktop:
    View attachment Task Manager.txt
    (This file was posted as a text file, because the site won't allow the posting of XML files directly.)
  2. If the name of the downloaded file appears on your desktop as just "Task Manager" instead of "Task Manager.txt", you need to turn on file extensions temporarily; see Option Two in this tutorial.
  3. Rename the downloaded file from "Task Manager.txt" to "Task Manager.xml".
  4. Open Control Panel. The most convenient way to do this is probably to move the cursor to the lower left corner of the screen, right-click, and select "Control Panel" from the menu that appears. (Touch-screen users: you're on your own. :))

  5. Select "System and Security" from the window that appears. (If the window doesn't look like the image above, you probably know enough to skip to the next step.)

  6. Select "Administrative Tools" from the list.

  7. Double-click "Task Scheduler" in the window that appears.

  8. Select "Import Task..." from the "Actions" list on the right side of the window that appears.
  9. In the File Open dialog that appears, navigate to and select the "Task Manager.xml" file that you downloaded in Step 1 and renamed in Step 3.

  10. Click "OK" in the window that appears.
  11. Close all the open windows and restart your computer.

Note   Note
I mentioned some unresolved quirks above, which you'll probably notice once your computer restarts. First, this causes the computer to go to the desktop shortly after logon. Some people will consider this an extra bonus rather than a quirk, but I haven't figured out a way to prevent this for those people who like seeing the Start screen and their live tiles when the machine starts up. Second, the "Hide when minimized" option doesn't work when Task Manager is started in this way - the initial desktop will show a normal tile for Task Manager in the taskbar. This can be removed by clicking on the tile and then minimizing the app again, but I haven't yet figured a way to get it to start out hidden.

Last edited:

My Computer

System One

  • OS
    Windows 8 (duh)
Nice step-by-step walk-through. I looked through your txt/xml file to see what you were doing differently. Essentially you launch a command prompt window and then launch task manager by using the "/c start /min" argument.

That gets me as close as I got in Windows 7. Thanks!

On a side note, I've noticed that my computer is taking forever to boot into Windows. I just realized that I have 7 items in the startup folders and a bunch of google updaters, adobe updaters and the like in addition to 2 scheduled tasks that I made. I always try to keep a close thumb on anything set to launch at startup, but have become too relaxed on way too many programs. Because of this, the task manager always stalls during boot and never recovers. I have to force close it and then launch it again manually. I run into that same behavior when using your scheduled task. After Windows has settled down and I try launching Task Manager, everything works well, including your scheduled task. Like you mention I end up having to click the task manager twice to get it to disappear for me. I have just removed more than half of the items from my logon queue hoping that that will speed up my boot and cause task manager not to freeze up.

My Computer

System One

  • OS
    Windows 8 Pro, 64-bit
    System Manufacturer/Model
    Dell Latitude E6510
    Internet Speed
    Insanely fast when at work, insanely slow when at home
I also have a boot-up question about minimising task manager at boot-up so I'll add to this instead of starting my own.

I did follow the step-by-step instructions above to see if they resolved my question but alas no.

I dislike the metro interface so I use Start8 to boot up my Win 8.1 to the desktop and get my start button back.
I didn't have the problem the problem of the original poster as I had created a shortcut to TaskMgr and the shortcut had the start minimised parameter set. I copied this into my startup directory and it successfully started TaskMgr minimised each time I booted.

BUT - When I did this in Win7 TaskMgr minimised to the Notification area and in Win 8.1 (and 8) it minimises to the task bar
When I open it and minimise it manually after the boot it correctly minimises to the Notification area.
As I mentioned I replaced my startup method with the one above but it also minimises TaskMgr to the TaskBar.

Most other utilities I start up in this way minimise to the Notification area (but they have a built-in minimise parameter). I do have another utility (CoreTemp) which does not have a built-in minimise parameter and has the same issue as TaskMgr (seen to the right of TaskMgr in the image). I mention this as part of providing as much information as possible.

My Computer

System One

  • OS
    Win XP, Win 7, Win 8, Win 8.1
    Computer type
    Intel Core I7 3930K
    Gigabyte GA-X79-UD5
    Graphics Card(s)
    NVidia GeForce GT 630
    Monitor(s) Displays
    2 x ViewSonic VX2370