• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Intel HD Graphics 2000/3000


XDleader555

New Member
Power User
I'm not sure...

Posts
253
Architecture is 32bit.

Hardware IDs property says currently on Inter(R) Graphics Media Accelerator 3150 (Microsoft Corporation - WDDM 1.0):

PCI\VEN_8086&DEV_A011&SUBSYS_00C71B0A&REV_00
PCI\VEN_8086&DEV_A011&SUBSYS_00C71B0A
PCI\VEN_8086&DEV_A011&CC_030000
PCI\VEN_8086&DEV_A011&CC_0300
Not sure if this will work at all. This driver had nothing blocking it from installing on Windows 8. Download the Custom certificate installer and install that first. Then install the modified driver here that include your Hardware IDs.

Intel Graphics Media Accelerator
-Version 15.12.75.50.7.2230- SIGNED Custom
32bit Download
AWESOME! ANgry Birds Space no more complains about missing OpenGL. Installation went flawlessly. Thank YOU!
Hmmmmmm. :D My experimentation has given me an idea. Thank you for your feedback. I'm now going to try something impossible.
 

My Computer

System One

  • OS
    Windows 8 Pro x64
    CPU
    Intel Core i5-2500k
    Motherboard
    ASRock z77 Extreme 4
    Memory
    Team Elite 8GB (4 x 2GB)
    Graphics Card(s)
    Intel HD Graphics 3000 & Nvidia GT 530
    Sound Card
    Realtek ALC892
    Screen Resolution
    1920x1080
    Hard Drives
    Western Digital Caviar Black 750 GB SATA III 7200 RPM
    PSU
    Antec NEO ECO 620C 620W
    Case
    NZXT GAMMA Classic Series
    Cooling
    Cooler Master Hyper 212 Plus
    Keyboard
    i-rocks RF-6570
    Mouse
    i-rocks RF-7550A
    Internet Speed
    17Mbps

XDleader555

New Member
Power User
I'm not sure...

Posts
253
Hi XDleader555, I have a problem installing the driver. My graphic card is Intel HD Graphics. When I tried to install any of the drivers, I always got error massages, saying that the installer cannot install one or more drivers. My system is Windows 8 CP 64 bit, and I installed it via EFI.

The following is my card id:
PCI\VEN_8086&DEV_0046&SUBSYS_00000000&REV_12
PCI\VEN_8086&DEV_0046&SUBSYS_00000000
PCI\VEN_8086&DEV_0046&REV_12
PCI\VEN_8086&DEV_0046
PCI\VEN_8086&DEV_0046&CC_030000
PCI\VEN_8086&DEV_0046&CC_0300


Thank you very much.
Are you running a laptop or a desktop? You might want to try this driver here if the graphics aren't from a second generation i3,i5,i7.
 

My Computer

System One

  • OS
    Windows 8 Pro x64
    CPU
    Intel Core i5-2500k
    Motherboard
    ASRock z77 Extreme 4
    Memory
    Team Elite 8GB (4 x 2GB)
    Graphics Card(s)
    Intel HD Graphics 3000 & Nvidia GT 530
    Sound Card
    Realtek ALC892
    Screen Resolution
    1920x1080
    Hard Drives
    Western Digital Caviar Black 750 GB SATA III 7200 RPM
    PSU
    Antec NEO ECO 620C 620W
    Case
    NZXT GAMMA Classic Series
    Cooling
    Cooler Master Hyper 212 Plus
    Keyboard
    i-rocks RF-6570
    Mouse
    i-rocks RF-7550A
    Internet Speed
    17Mbps

yfnew

New Member
Posts
7
Hi XDleader555, I have a problem installing the driver. My graphic card is Intel HD Graphics. When I tried to install any of the drivers, I always got error massages, saying that the installer cannot install one or more drivers. My system is Windows 8 CP 64 bit, and I installed it via EFI.

The following is my card id:
PCI\VEN_8086&DEV_0046&SUBSYS_00000000&REV_12
PCI\VEN_8086&DEV_0046&SUBSYS_00000000
PCI\VEN_8086&DEV_0046&REV_12
PCI\VEN_8086&DEV_0046
PCI\VEN_8086&DEV_0046&CC_030000
PCI\VEN_8086&DEV_0046&CC_0300


Thank you very much.
Are you running a laptop or a desktop? You might want to try this driver here if the graphics aren't from a second generation i3,i5,i7.
Thanks for your reply. It's still not working. It has the same error with the one I tried on this thread. I am using a laptop. Since my windows is not English version, i'm not sure if my screenshot will be helpful.
 

My Computer

System One

  • OS
    Windows 8 CP+Mac OS X

Binoy

New Member
Posts
2
Help !!! Alarmed !!!

Sorry for bumping into this discussion. This actually scares me a bit and that's why I am asking this question here. I am planning to buy a desktop with core i3 2105 processor that has an Intel HD 3000 IGP. Now one of the essential requirements is for me to use Windows 8 when it finally releases.
Question: Won't I be able to do a generic windows 8 install and use the system or do I need to go through these elaborate installation/tweaking processes to finally get it running?

I am a non gamer who wants to use the system for office productivity, HD movies, music and some heavy browsing.
 

My Computer

System One

  • OS
    Windows Vista

XDleader555

New Member
Power User
I'm not sure...

Posts
253
Sorry for bumping into this discussion. This actually scares me a bit and that's why I am asking this question here. I am planning to buy a desktop with core i3 2105 processor that has an Intel HD 3000 IGP. Now one of the essential requirements is for me to use Windows 8 when it finally releases.
Question: Won't I be able to do a generic windows 8 install and use the system or do I need to go through these elaborate installation/tweaking processes to finally get it running?

I am a non gamer who wants to use the system for office productivity, HD movies, music and some heavy browsing.
You don't need to go through all the tweaking. I've done it for you. Head to the first page and the second post for the download links. Follow the instructions and you're good to go.

Eventually Intel will release official drivers for the final release of windows8. These drivers are here because Intel has not released any beta drivers. These are a kind of work around.

Conclusion: Get it! For now you can use these drivers for windows 8 CP, and once the final release comes out Intel will most likely have their drivers ready for us to use. (Hopefully)
 

My Computer

System One

  • OS
    Windows 8 Pro x64
    CPU
    Intel Core i5-2500k
    Motherboard
    ASRock z77 Extreme 4
    Memory
    Team Elite 8GB (4 x 2GB)
    Graphics Card(s)
    Intel HD Graphics 3000 & Nvidia GT 530
    Sound Card
    Realtek ALC892
    Screen Resolution
    1920x1080
    Hard Drives
    Western Digital Caviar Black 750 GB SATA III 7200 RPM
    PSU
    Antec NEO ECO 620C 620W
    Case
    NZXT GAMMA Classic Series
    Cooling
    Cooler Master Hyper 212 Plus
    Keyboard
    i-rocks RF-6570
    Mouse
    i-rocks RF-7550A
    Internet Speed
    17Mbps

yfnew

New Member
Posts
7
Hi XDleader555, I have a problem installing the driver. My graphic card is Intel HD Graphics. When I tried to install any of the drivers, I always got error massages, saying that the installer cannot install one or more drivers. My system is Windows 8 CP 64 bit, and I installed it via EFI.

The following is my card id:
PCI\VEN_8086&DEV_0046&SUBSYS_00000000&REV_12
PCI\VEN_8086&DEV_0046&SUBSYS_00000000
PCI\VEN_8086&DEV_0046&REV_12
PCI\VEN_8086&DEV_0046
PCI\VEN_8086&DEV_0046&CC_030000
PCI\VEN_8086&DEV_0046&CC_0300


Thank you very much.
Are you running a laptop or a desktop? You might want to try this driver here if the graphics aren't from a second generation i3,i5,i7.
Thanks for your reply. It's still not working. It has the same error with the one I tried on this thread. I am using a laptop. Since my windows is not English version, i'm not sure if my screenshot will be helpful.
20120414232047.png I got the screenshot for the error message.
 

My Computer

System One

  • OS
    Windows 8 CP+Mac OS X

XDleader555

New Member
Power User
I'm not sure...

Posts
253
Are you running a laptop or a desktop? You might want to try this driver here if the graphics aren't from a second generation i3,i5,i7.
Thanks for your reply. It's still not working. It has the same error with the one I tried on this thread. I am using a laptop. Since my windows is not English version, i'm not sure if my screenshot will be helpful.
View attachment 5590 I got the screenshot for the error message.
Have you run the custom certificate installer? These drivers wont work unless you run it.
 

My Computer

System One

  • OS
    Windows 8 Pro x64
    CPU
    Intel Core i5-2500k
    Motherboard
    ASRock z77 Extreme 4
    Memory
    Team Elite 8GB (4 x 2GB)
    Graphics Card(s)
    Intel HD Graphics 3000 & Nvidia GT 530
    Sound Card
    Realtek ALC892
    Screen Resolution
    1920x1080
    Hard Drives
    Western Digital Caviar Black 750 GB SATA III 7200 RPM
    PSU
    Antec NEO ECO 620C 620W
    Case
    NZXT GAMMA Classic Series
    Cooling
    Cooler Master Hyper 212 Plus
    Keyboard
    i-rocks RF-6570
    Mouse
    i-rocks RF-7550A
    Internet Speed
    17Mbps

yfnew

New Member
Posts
7
Thanks for your reply. It's still not working. It has the same error with the one I tried on this thread. I am using a laptop. Since my windows is not English version, i'm not sure if my screenshot will be helpful.
View attachment 5590 I got the screenshot for the error message.
Have you run the custom certificate installer? These drivers wont work unless you run it.
I did, but since I use EFI, the installer failed to enable the testsigning mode. I enabled it by myself later. Don't know if that is the problem...
Thanks!
 

My Computer

System One

  • OS
    Windows 8 CP+Mac OS X

XDleader555

New Member
Power User
I'm not sure...

Posts
253
Well, I think that's where it's failing. Try installing it through the device manager and inf. Tell me the outcome.
 

My Computer

System One

  • OS
    Windows 8 Pro x64
    CPU
    Intel Core i5-2500k
    Motherboard
    ASRock z77 Extreme 4
    Memory
    Team Elite 8GB (4 x 2GB)
    Graphics Card(s)
    Intel HD Graphics 3000 & Nvidia GT 530
    Sound Card
    Realtek ALC892
    Screen Resolution
    1920x1080
    Hard Drives
    Western Digital Caviar Black 750 GB SATA III 7200 RPM
    PSU
    Antec NEO ECO 620C 620W
    Case
    NZXT GAMMA Classic Series
    Cooling
    Cooler Master Hyper 212 Plus
    Keyboard
    i-rocks RF-6570
    Mouse
    i-rocks RF-7550A
    Internet Speed
    17Mbps

XDleader555

New Member
Power User
I'm not sure...

Posts
253
Guys what version of windows 8 are you running??? Windows 8 developer preview OR windows 8 consumer preview
Consumer Preview. Developer preview is the previous version.
 

My Computer

System One

  • OS
    Windows 8 Pro x64
    CPU
    Intel Core i5-2500k
    Motherboard
    ASRock z77 Extreme 4
    Memory
    Team Elite 8GB (4 x 2GB)
    Graphics Card(s)
    Intel HD Graphics 3000 & Nvidia GT 530
    Sound Card
    Realtek ALC892
    Screen Resolution
    1920x1080
    Hard Drives
    Western Digital Caviar Black 750 GB SATA III 7200 RPM
    PSU
    Antec NEO ECO 620C 620W
    Case
    NZXT GAMMA Classic Series
    Cooling
    Cooler Master Hyper 212 Plus
    Keyboard
    i-rocks RF-6570
    Mouse
    i-rocks RF-7550A
    Internet Speed
    17Mbps

XDleader555

New Member
Power User
I'm not sure...

Posts
253
Well, I think that's where it's failing. Try installing it through the device manager and inf. Tell me the outcome.
Thanks for the reply. it's still not working when I use device manager to install it. I got this error View attachment 5594
Are you running a mac? If you could get me the inf file of the mac driver maybe i can mod a custom driver for you.

You can find it by going to the device manager and right clicking your display adapter and choosing "Properties". Then go to "Details" and from the dropbox choose "Inf name". Mine happens to be oem18.inf.

Next go to C:\Windows\Inf and look for the inf name you found in details. Could you upload that inf as an attachment?

If you are currently using the Microsoft basic display driver then I have no clue as to why the driver wont install.
 

My Computer

System One

  • OS
    Windows 8 Pro x64
    CPU
    Intel Core i5-2500k
    Motherboard
    ASRock z77 Extreme 4
    Memory
    Team Elite 8GB (4 x 2GB)
    Graphics Card(s)
    Intel HD Graphics 3000 & Nvidia GT 530
    Sound Card
    Realtek ALC892
    Screen Resolution
    1920x1080
    Hard Drives
    Western Digital Caviar Black 750 GB SATA III 7200 RPM
    PSU
    Antec NEO ECO 620C 620W
    Case
    NZXT GAMMA Classic Series
    Cooling
    Cooler Master Hyper 212 Plus
    Keyboard
    i-rocks RF-6570
    Mouse
    i-rocks RF-7550A
    Internet Speed
    17Mbps

XDleader555

New Member
Power User
I'm not sure...

Posts
253
Yes I have minecraft. It runs well with some versions of the driver and some it just laggs until you change to short view.
 

My Computer

System One

  • OS
    Windows 8 Pro x64
    CPU
    Intel Core i5-2500k
    Motherboard
    ASRock z77 Extreme 4
    Memory
    Team Elite 8GB (4 x 2GB)
    Graphics Card(s)
    Intel HD Graphics 3000 & Nvidia GT 530
    Sound Card
    Realtek ALC892
    Screen Resolution
    1920x1080
    Hard Drives
    Western Digital Caviar Black 750 GB SATA III 7200 RPM
    PSU
    Antec NEO ECO 620C 620W
    Case
    NZXT GAMMA Classic Series
    Cooling
    Cooler Master Hyper 212 Plus
    Keyboard
    i-rocks RF-6570
    Mouse
    i-rocks RF-7550A
    Internet Speed
    17Mbps

XDleader555

New Member
Power User
I'm not sure...

Posts
253
I'm fine. I own a server of my own. Thanks anyways.
 

My Computer

System One

  • OS
    Windows 8 Pro x64
    CPU
    Intel Core i5-2500k
    Motherboard
    ASRock z77 Extreme 4
    Memory
    Team Elite 8GB (4 x 2GB)
    Graphics Card(s)
    Intel HD Graphics 3000 & Nvidia GT 530
    Sound Card
    Realtek ALC892
    Screen Resolution
    1920x1080
    Hard Drives
    Western Digital Caviar Black 750 GB SATA III 7200 RPM
    PSU
    Antec NEO ECO 620C 620W
    Case
    NZXT GAMMA Classic Series
    Cooling
    Cooler Master Hyper 212 Plus
    Keyboard
    i-rocks RF-6570
    Mouse
    i-rocks RF-7550A
    Internet Speed
    17Mbps

Maquine

New Member
Posts
4
Hi, Can help me?

I have problem with my video card.

my laptop is 15R n5110 Dell

Video Card Id
PCI\VEN_8086&DEV_0116&SUBSYS_04B01028&REV_09
PCI\VEN_8086&DEV_0116&SUBSYS_04B01028
PCI\VEN_8086&DEV_0116&CC_030000
PCI\VEN_8086&DEV_0116&CC_0300

SO
Windows 8 CP

Thk..
Have you tried Version 8.15.10.2622 yet? Version 9.17.10.2657 is a Desktop Driver. Or are you having installation issues?
Thank you XDleader555 for your answers soon.

but still does not work.

my laptop monitor does not work. only an external monitor works well.

try the driver 8.15.10.2622 but did not work.

P. S. excuse for my bad English.


Card Id
PCI\VEN_8086&DEV_0116&SUBSYS_04B01028&REV_09
PCI\VEN_8086&DEV_0116&SUBSYS_04B01028
PCI\VEN_8086&DEV_0116&CC_030000
PCI\VEN_8086&DEV_0116&CC_0300


forgive me, but I can give any suggestions on how to address this issue.?
 

My Computer

System One

  • OS
    Windows 8

XDleader555

New Member
Power User
I'm not sure...

Posts
253
Have you tried Version 8.15.10.2622 yet? Version 9.17.10.2657 is a Desktop Driver. Or are you having installation issues?
Thank you XDleader555 for your answers soon.

but still does not work.

my laptop monitor does not work. only an external monitor works well.

try the driver 8.15.10.2622 but did not work.

P. S. excuse for my bad English.


Card Id
PCI\VEN_8086&DEV_0116&SUBSYS_04B01028&REV_09
PCI\VEN_8086&DEV_0116&SUBSYS_04B01028
PCI\VEN_8086&DEV_0116&CC_030000
PCI\VEN_8086&DEV_0116&CC_0300


forgive me, but I can give any suggestions on how to address this issue.?
If you have suggestions then please do. I really have no clue.
 

My Computer

System One

  • OS
    Windows 8 Pro x64
    CPU
    Intel Core i5-2500k
    Motherboard
    ASRock z77 Extreme 4
    Memory
    Team Elite 8GB (4 x 2GB)
    Graphics Card(s)
    Intel HD Graphics 3000 & Nvidia GT 530
    Sound Card
    Realtek ALC892
    Screen Resolution
    1920x1080
    Hard Drives
    Western Digital Caviar Black 750 GB SATA III 7200 RPM
    PSU
    Antec NEO ECO 620C 620W
    Case
    NZXT GAMMA Classic Series
    Cooling
    Cooler Master Hyper 212 Plus
    Keyboard
    i-rocks RF-6570
    Mouse
    i-rocks RF-7550A
    Internet Speed
    17Mbps

yfnew

New Member
Posts
7
Well, I think that's where it's failing. Try installing it through the device manager and inf. Tell me the outcome.
Thanks for the reply. it's still not working when I use device manager to install it. I got this error View attachment 5594
Are you running a mac? If you could get me the inf file of the mac driver maybe i can mod a custom driver for you.

You can find it by going to the device manager and right clicking your display adapter and choosing "Properties". Then go to "Details" and from the dropbox choose "Inf name". Mine happens to be oem18.inf.

Next go to C:\Windows\Inf and look for the inf name you found in details. Could you upload that inf as an attachment?

If you are currently using the Microsoft basic display driver then I have no clue as to why the driver wont install.
i'm running the Microsoft basic display driver, the inf file is display.inf. View attachment display.zip

Thanks very much.
 
Last edited:

My Computer

System One

  • OS
    Windows 8 CP+Mac OS X

Users Who Are Viewing This Thread (Users: 0, Guests: 1)