What's new

Solved how to stop mouse from waking up my computer

anarchoi

Member
Member
This is really annoying, my mouse keeps waking my computer from S3 sleep everytime it is slighty moved. I want to disable my mouse's ability to wake up my computer.

Disabling wake-on-usb is not an option as i want to be able to wake up my computer when i press a key on my keyboard.

I have tried to check in device manager for the power control options of my mouse but i really don't know how i am supposed to figure which usb device my mouse is in the device manager....
 

My Computer

System One

  • OS
    win8

znod

New Member
Power User
Last edited by a moderator:

My Computer

System One

  • OS
    Win7 Ult on DIY; Win8 Pro on MBP/Parallels; Win7 Ult on MBP/Boot Camp; Win7 Ult/Win8 Pro on HP
    Computer type
    PC/Desktop
    System Manufacturer/Model
    DIY Rig; MacBook Pro (MBP)/Parallels/Boot Camp; HP Pavilion dv6500t Laptop
    CPU
    Intel i7-2600K (sometimes OC'd to 4.8 GHz)
    Motherboard
    ASUS P8P67 Deluxe Rev B3
    Memory
    16 GB Corsair Vengeance
    Graphics Card(s)
    EVGA 570 SC
    Monitor(s) Displays
    Gateway
    Hard Drives
    Dual Boot:
    Win7 Ult RAID 0 on OCZ Revo x2 and
    Win7 Ult RAID 0 on Caviar Black SATA 3's
    PSU
    Cooler Master Silent Pro 1000W
    Case
    Cooler Master 932 HAF
    Cooling
    Zalman CNPS9900MAX-B CPU Fan
    Keyboard
    Logitech Cordless Desktop MX 5500
    Mouse
    Logitech Cordless Desktop MX 5500
    Internet Speed
    20 Mbps Download/2+ Mbps Upload
    Other Info
    Pioneer Blu-ray Burner/DVD Burner

znod

New Member
Power User
You are very welcome. Glad it looks like it has worked.
 

My Computer

System One

  • OS
    Win7 Ult on DIY; Win8 Pro on MBP/Parallels; Win7 Ult on MBP/Boot Camp; Win7 Ult/Win8 Pro on HP
    Computer type
    PC/Desktop
    System Manufacturer/Model
    DIY Rig; MacBook Pro (MBP)/Parallels/Boot Camp; HP Pavilion dv6500t Laptop
    CPU
    Intel i7-2600K (sometimes OC'd to 4.8 GHz)
    Motherboard
    ASUS P8P67 Deluxe Rev B3
    Memory
    16 GB Corsair Vengeance
    Graphics Card(s)
    EVGA 570 SC
    Monitor(s) Displays
    Gateway
    Hard Drives
    Dual Boot:
    Win7 Ult RAID 0 on OCZ Revo x2 and
    Win7 Ult RAID 0 on Caviar Black SATA 3's
    PSU
    Cooler Master Silent Pro 1000W
    Case
    Cooler Master 932 HAF
    Cooling
    Zalman CNPS9900MAX-B CPU Fan
    Keyboard
    Logitech Cordless Desktop MX 5500
    Mouse
    Logitech Cordless Desktop MX 5500
    Internet Speed
    20 Mbps Download/2+ Mbps Upload
    Other Info
    Pioneer Blu-ray Burner/DVD Burner

nabilalk

New Member
For anyone that has a Logitech wireless keyboard and mouse combo, according to Logitech, the only way to prevent the mouse from waking up your computer is to disable the wake in power management in both the mouse and the keyboard. That is unfortunate because I for one want to be able to wake up with the keyboard but not the mouse. If anyone has a solution for that, I would be interested in hearing it. My Unifying mouse or keyboard wakes the computer even when it is set not to - Logitech FAQ
 

My Computer

System One

  • OS
    Windows 8.1 Professional amd64
    Computer type
    Laptop
    System Manufacturer/Model
    HP DV6T7000cto

Edwin

Well-Known Member
VIP Member
Guru
You should be able to do so through the Control Panel:

View attachment 38141

Perhaps it is necessary to uninstall the Logitech software first.
Often I will install an applicable software package, allow it to install drivers then uninstall the 'bloatware' that often comes with it; and sadly to say, Logitech is terrible for bloatware!
(not all software packages will work that way though)
 

My Computers

System One System Two

  • OS
    Windows 7 Home Premium
    Computer type
    PC/Desktop
    System Manufacturer/Model
    HP Pavillion

nabilalk

New Member
Nope, tried that. Did all the device manager stuff, adjusting the power management. It is an issue that Logitech has and has documented. I just wanted to post to let others know, since Logitech is a popular choice for wireless devices.
You should be able to do so through the Control Panel:

View attachment 38141

Perhaps it is necessary to uninstall the Logitech software first.
Often I will install an applicable software package, allow it to install drivers then uninstall the 'bloatware' that often comes with it; and sadly to say, Logitech is terrible for bloatware!
(not all software packages will work that way though)
 

My Computer

System One

  • OS
    Windows 8.1 Professional amd64
    Computer type
    Laptop
    System Manufacturer/Model
    HP DV6T7000cto

kenanyigiter

New Member
Nabilalk,
Your comment was great help to me, as you have stated, a user is required to disable the keyboard too in order to disable the mouse or inhibit the mouse from waking the PC from sleep. Hence disable keyboard to disable mouse. My mouse kept on waking the PC even though I went into the Power management in the mouse Control Panel.
I'm using a wireless Logitech mouse, M510.
I'm using a HP wireless keyboard, RK713A.
Many thanks, (also thanks to Eightforums)
Ken, MEng.


For anyone that has a Logitech wireless keyboard and mouse combo, according to Logitech, the only way to prevent the mouse from waking up your computer is to disable the wake in power management in both the mouse and the keyboard. That is unfortunate because I for one want to be able to wake up with the keyboard but not the mouse. If anyone has a solution for that, I would be interested in hearing it. My Unifying mouse or keyboard wakes the computer even when it is set not to - Logitech FAQ
 

My Computer

System One

  • OS
    7

orcmansao

New Member
Windows 7, standard PS/2 keyboard, usb wireless mouse
HID mouse driver Power Management wake up event turn off didn't work.
The usb wireless dongle has also a keyboard HID driver (even if a wireless keyboard isn't present).
Solution: Device Manager > Keyboards has two devices:
HID Keyboard device
Standard PS/2 Keyboard​
Turn off Power Management wake up event for the HID Keyboard device. (The HID mouse turned off also)​
 

My Computer

System One

  • OS
    windows 7

Steey

New Member
Windows 7, standard PS/2 keyboard, usb wireless mouse
HID mouse driver Power Management wake up event turn off didn't work.
The usb wireless dongle has also a keyboard HID driver (even if a wireless keyboard isn't present).
Solution: Device Manager > Keyboards has two devices:
HID Keyboard device
Standard PS/2 Keyboard​
Turn off Power Management wake up event for the HID Keyboard device. (The HID mouse turned off also)​


This is the solution I've been looking for since I got a wireless mouse. I registered specifically to thank you for your research and as a reasurrance for other people who might have a similar problem in the future. It's a shame this isn't more widely known!
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    Laptop

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top