• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

FrmMain error delays boot-up


ncJohn

New Member
Posts
7
#1
Lately my system takes a long time to boot up, and it seems to be because of something called FrmMain. I have no idea what that is, but the bootup stalls with the desktop partially displayed, and then a window pops up with an error message that lasts less than a second so I can't see any more of the message, just that it's something about FrmMain. After that window flashes onscreen, then the bootup finishes.
From looking on google, it seems to have something to do with MS Visual Studio, but I don't have that installed, whatever it is.
Can anyone tell me how to get rid of this?
Thanks
 

My Computer

System One

  • OS
    Windows 8.1 Pro 64-bit
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Dell Optiplex 9010 MT
    CPU
    Core i7 3770
    Motherboard
    Dell Inc. 0M9KCM (CPU 1)
    Memory
    16GB
    Graphics Card(s)
    1024MB ATI AMD Radeon HD 7500 Series
    Monitor(s) Displays
    ASUS PB238 ([email protected]), Viewsonic VP2365WB ([email protected])
    Screen Resolution
    1920x1080
Posts
71
#2
Here is some information about FrmMain:
Understanding Windows Forms | Writing Windows Forms Applications in Visual Studio .NET 2003 | InformIT

Basically, FrmMain is part of Visual Studio, which is a computer language used for writing Windows programs. Therefore, there is probably a program loading at startup which utilizes FrmMain functionality. In other words, just about anything could be the culprit.

A simple way to see what is causing the computer to boot slow is to disable all startup items, then reboot, to see if this solves the problem. If it does, then you can re-enable them one at a time, rebooting after each re-enable, to see which one causes the delay. You can then disable that startup item.

Another way you can do this is to disable all non-Microsoft services, then reboot, to see if this solves the problem.

For both of these procedures (startup items and non-Microsoft services), you can run MSCONFIG. You will go either to the Startup tab or to the Services tab.
* On the Services tab, you will first need to check "Hide all Microsoft services", so that only the non-Microsoft services will show on the screen.
 

My Computer

System One

  • OS
    Linux Mint 18.2 xfce 64-bit (VMWare host) / Windows 8.1 Pro 32-bit (VMWare guest)
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Dell
    CPU
    Haswell
    Memory
    4 GB
    Monitor(s) Displays
    Acer 23"
    Screen Resolution
    1920 x 1080
    Hard Drives
    Two hard drives, 1TB each: One for Linux, one for my data.
    Keyboard
    IBM Model M
    Browser
    Firefox, Opera
    Antivirus
    Sophos (Linux), Trend Micro (Windows)
    Other Info
    I use Samba to share my data drive with the other computers at my house and with my guest session in VMWare Workstation Player.
Posts
7
#3
Okay, I'll see what I can do with that.
Thanks
 

My Computer

System One

  • OS
    Windows 8.1 Pro 64-bit
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Dell Optiplex 9010 MT
    CPU
    Core i7 3770
    Motherboard
    Dell Inc. 0M9KCM (CPU 1)
    Memory
    16GB
    Graphics Card(s)
    1024MB ATI AMD Radeon HD 7500 Series
    Monitor(s) Displays
    ASUS PB238 ([email protected]), Viewsonic VP2365WB ([email protected])
    Screen Resolution
    1920x1080