What's new

Solved External HD permissions - how to get rid or easy way to se

netuser

New Member
Hi,

I just bought a new laptop with windows 8 for wife. On my old laptop I have windows 8 too. I have 2 TB HD connected to my Old laptop which contain almost all of my Media files etc.

Now I wanted to pass some stuff to my wife so I connected the External drive to the new laptop but to my surprise the windows 8 don't even want me to open any folder on it and give error message about the permissions etc. So I google a little and try to fix this Permission thing and try to take owner ship of folder on new laptop but Quickly it turned in to horror.

When I take owner on the folder it work well but then I cant open any file inside it, I have to go and manually take owner of each and every file, I have 1000s of file I just cant do it 1 by 1. it will take forever. If I click on folder and check box to apply to child sub folder and etc, it just start giving me error message for each file saying it cant change permission etc for each file name.

How I am suppose to use an External HD on another computer ? What kind of sick joke is this ? The external drives basic is that you go somewhere and plug and use the content on that computer why Microsoft made it so difficult ? If it was for security purpose then why anyone can change the ownership and see the file so at the end why making the life difficult for normal user ?

Anyway I am not here to complain but this thing is just driving me crazy for 2 days now.

So if anyone can please help solve this ? What is the simple and easy way to do it please ?

Thanks so much for all your help :)
 

My Computer

System One

  • OS
    Windows 8.1

Enigma

New Member
Member
Is the drive a USB 2.0 or 3.0? If it's 3.0 then Win8 should already have default 3.0 drivers installed, but this could still be a cause of the issue. Try installing all available Windows Updates marked as Important, and install the newest versions of all available drivers for the laptop.

It's also possible that the drive may contain errors or even bad sectors, try checking it for errors (right-click the driv in My Computer/This PC, then "Properties", then "Tools" tab, and under "Error Checking" click "Check".

Also check Take Ownership Shortcut - Windows 7 Help Forums for a Take Ownership right click context menu entry. Download the file and merge the .reg file into your Registry. Right click on the file(s)/folder(s) then click "Take Ownership". You may also want to take ownership of the entire drive by right clicking the drive and clicking "Take Ownership" (dont do this for the C drive or you may end up with serious issues!)

Hope that helped!
 

My Computer

System One

  • OS
    Windows 8.1 Pro x64, Windows Server 2012 R2 x64
    Computer type
    Laptop
    System Manufacturer/Model
    Lenovo G700
    CPU
    Intel Core i7-3632QM, 2.20 GHz
    Motherboard
    Lenovo
    Memory
    6 GB DDR3
    Graphics Card(s)
    NVIDIA 720M, Intel HD 4000
    Monitor(s) Displays
    1 monitor
    Screen Resolution
    1600x900 (max)
    Hard Drives
    1 TB HDD (5400 RPM), 1.5 TB HDD (5400 RPM) installed in a 12.7mm disc drive caddy
    Case
    Lenovo
    Keyboard
    Lenovo
    Mouse
    Laptop/notebook keyboard/touchpad
    Internet Speed
    It varies, since I'm mobile most of the time
    Browser
    Chromium (the open-source browser which Google Chrome is derived from)
    Antivirus
    Kaspersky, Malwarebytes, Spybot, Privatefirewall
    Other Info
    I will add more information here later

oneeyed

New Member
Pro User
While the ownership shortcut is nice I think it's still a bit too dangerous (it could lead you to take ownership of a OS folder by mistake which is... bad). Check this link : permissions - Permissionless external drive with NTFS - Super User, and follow exactly what it says in the 1st answer post. This should solve your problem.
  • While logged-in as Administrator, right-click the drive's root directory and select Properties.
  • Click the Security tab, then the Advanced button.
  • In the Advanced Security Settings dialog for the drive, click the Owner tab, then the Edit button.
  • Click the Administrators group, check Replace owner on subcontainers and objects and click OK. If asked about replacing existing permissions with ones giving you Full Control, click Yes.
  • Back in the Security tab and on the original Properties sheet again, click the Edit button, and in the Security dialog click Remove for all entries for all accounts listed under "Group or user names", except for the well-known ones of System, Administrators, Users and Authenticated Users.
  • Click Add, and in the "Select Users, Computer or Groups" dialog under "Enter the object names to select", type Everyone and click OK. You should verify that Everyone has been added to the list.
  • Click Everyone, check Full Control, then click on Apply.
  • Click Advanced again to go back to the Advanced Security Settings dialog box and click the Change Permissions button. Check Replace permission entries on all child objects and click OK and OK.
  • Click OK.
This not only grants ownership to your pc's administrator, it also gives full control to the Everyone group so you will never have permissions problems with this drive from any PC.
 

My Computer

System One

  • OS
    Windows 8.1 (x64)
    Computer type
    PC/Desktop

netuser

New Member
Thanks for the replies :)

Just I am confused about step 3 and 4, I don't have any Owner Tab, does they mean the line Owner and click on Change ? Than if it is change owner I don't see anywhere Admin group as said in 4th step How do I do all this ?


  • In the Advanced Security Settings dialog for the drive, click the Owner tab, then the Edit button.
  • Click the Administrators group, check Replace owner on subcontainers and objects and click OK. If asked about replacing existing permissions with ones giving you Full Control, click Yes.
 

My Computer

System One

  • OS
    Windows 8.1

oneeyed

New Member
Pro User
Here are screenshots detailing most of the steps, all in a zip. You are right, the owner is the setting on top of the advanced window (with the change link). If administrators isn't already present, just type Administrators in the box and click Check Name, if you didn't make a typo, the system will accept it. Same for the Everyone entry.

Keep in mind if you have a lot of data on this drive this could actually take a long time, since windows will change permissions on all files and subfolders. You should try 1st on a folder if you're worried, just create a new folder in your external drive, select it and apply all the steps on it, when you're satisfied it works, do the same but by selecting the whole drive.
 

Attachments

  • My Pictures.zip
    394.7 KB · Views: 92
Last edited:

My Computer

System One

  • OS
    Windows 8.1 (x64)
    Computer type
    PC/Desktop

netuser

New Member
Sorry guys to bump my thread again, I have to chenge my laptop due to some issue and got new laptop and now I am having same problem, try to do what was said before, it work except for one folder where are my TV series videos, It is just not letting me change any thing for it and I am getting Access denied

I also tried the DOS CMD in in Admin elevated mode and I am getting Access denied

icacls D:\TV /grant netuser:F /T

I get following error

processed file: D:\TV
D:\TV\.unwanted: Access is denied.
Successfully processed 1 files; Failed processing 1 files

I also tried same command on D while drive but at the end

Successfully processed xxxxx files; Failed processing 1 files

What do I am stuck and cant read any video files :(

All other folder and their content is working, just this one is denied

Thanks
 

My Computer

System One

  • OS
    Windows 8.1

netuser

New Member
Marking it as solved as I did a clean up of all Groups and users in security tab and restatred to apply above mentioned solution (in images) and this time it worked :( realy not user freindly , it is mess to do each time :S
 

My Computer

System One

  • OS
    Windows 8.1

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top