• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Device manager shows "Unknown Device" on reinstallation of driver


gita

New Member
Posts
1
#1
Hi,

On a fresh clean Windows 8 image, my software driver (signed) installs fine and shows up properly in the Device Manager. However once i uninstall it , subsequent reinstalls show up as 'Unknown Device' in the Device Manager.

From the device details, I find that it refers to /looks for the .inf file in c:\windows\inf folder but the file itself is missing from the location. The FileRepository has all the required files. But trying to update from there also fails.

Could anyone help me with troubleshooting this problem. What could be going wrong.

Thx,
Gita
 

My Computer

System One

  • OS
    windows 7

MrShowdown

Well-Known Member
Power User
Jakarta, Indonesia

Posts
1,048
#2
Please fill your system specs to get help efficiently.
What is your computer make/model?
 

My Computer

System One

  • OS
    Windows 10 Pro x64
    Computer type
    Laptop
    System Manufacturer/Model Number
    Lenovo Y520
    CPU
    Intel Core i5 7300HQ
    Motherboard
    OEM Lenovo
    Memory
    4GB DDR4-2400
    Graphics Card(s)
    NVIDIA GeForce GTX 1050
    Sound Card
    Realtek HD
    Monitor(s) Displays
    1 (2)
    Screen Resolution
    1920x1080
    Hard Drives
    Seagate 1TB 5400 RPM
    Keyboard
    OEM Lenovo
    Mouse
    Logitech G502 Proteus Core
    Internet Speed
    100 Mbps
    Browser
    Google Chrome
    Other Info
    PC:

    AMD Athlon X4 760K
    8GB DDR3-1866
    AMD Radeon RX 460
    Seagate 500 GB 7200 RPM