• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved AMD Catalyst Control Center does not open (show settings)


CK1985NL

Member
Member
Posts
161
#1
I plugged in my new videocard and installed the drivers, but I have a problem. AMD Catalyst Control Center will not open. It's really difficult because I can not do anything to set. I can not set the picture and make wider, so get on all four sides of the black screen (see picture) I must necessarily be in AMD Catalyst Control Center. I've removed the drivers and reinstalled, but I can unfortunately not get in AMD Catalyst Control Center (settings). Please help!

black sides.jpg
 

My Computer

System One

  • OS
    Windows 10 Pro 64Bit
    CPU
    AMD FX-8150 Black Edition, sAM3+ 3.60 GHz, Octa-Core, 16MB, 125W
    Motherboard
    Asus Sabertooth 990FX AM3+
    Memory
    Corsair Vengeance 32GB DDR3 kit (4x 8GB), CMZ32GX3M4X1866C10'
    Graphics Card(s)
    EVGA GTX 970 Superclocked ACX 2.0
    Monitor(s) Displays
    Philips 32"PFL9606H/12
    Hard Drives
    Samsung 850 Pro series 1 TB

TairikuOkami

Be nice to all, please?!
Pro User
Trnava

Posts
683
#2

My Computer

System One

  • OS
    Win 8.1.1 Pro x64
    Computer type
    Laptop
    System Manufacturer/Model Number
    Lenovo E525
    CPU
    AMD A4-3300M @ 2,0GHz
    Memory
    6GB DDR3 1333MHz
    Graphics Card(s)
    AMD Radeon HD 6480G 512MB shared
    Sound Card
    Creative Sound Blaster X-Fi Surround 5.1
    Screen Resolution
    1366x768
    Hard Drives
    WD 465GB
    Cooling
    Fusion Tweaker
    Keyboard
    Logitech K360
    Mouse
    Logitech M705
    Internet Speed
    50/50 MBps
    Browser
    Yandex
    Antivirus
    No AV & No Firewall
    Other Info
    Headphones: Sennheiser RS170
#3
What happens when you try to open CCC? Does it crash? Have you tried running it as an admin?
 

My Computer

System One

  • OS
    Windows 8.1 Pro
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Custom Build
    CPU
    i7 4770
    Motherboard
    ASUS H87M-Plus
    Memory
    Crucial, god knows what model. 1033 240pin 16gb
    Graphics Card(s)
    MSI AMD Radeon HD 7870
    Sound Card
    Onboard
    Monitor(s) Displays
    Dell Ultrasharp 21.5" / ASUS 17" secondary
    Screen Resolution
    1920x1080
    Hard Drives
    Corsair 60GB Force Series LS 2.5inch SSD
    1TB Western Digital
    500GB Hitachi
    PSU
    Coolmaster 600W
    Case
    In-Win Dragonslayer
    Cooling
    Fans, lots of fans
    Keyboard
    Logitech G105
    Mouse
    Sharkoon Fireglider
    Internet Speed
    Terrible
    Browser
    Chrome / Firefox
    Antivirus
    Windows Defender / MalwareBytes

CK1985NL

Member
Member
Posts
161
#4
@ TairikuOkami

I have the latest driver (14-4-win7-Win8-win8.1-64-dd-ccc-WHQL) but not the beta (I've tried the beta, but the same problem) I don't know if I have installed and updated NET Frameworks from 2.0 to 4.5, where can I find or see?

EDIT: I see I've NETFramework 4.5 already installed on my PC.
 

My Computer

System One

  • OS
    Windows 10 Pro 64Bit
    CPU
    AMD FX-8150 Black Edition, sAM3+ 3.60 GHz, Octa-Core, 16MB, 125W
    Motherboard
    Asus Sabertooth 990FX AM3+
    Memory
    Corsair Vengeance 32GB DDR3 kit (4x 8GB), CMZ32GX3M4X1866C10'
    Graphics Card(s)
    EVGA GTX 970 Superclocked ACX 2.0
    Monitor(s) Displays
    Philips 32"PFL9606H/12
    Hard Drives
    Samsung 850 Pro series 1 TB

CK1985NL

Member
Member
Posts
161
#5
@ Ending

No, it doesn't crash, but I haven't tried in admin. I'll try and let you know.
 

My Computer

System One

  • OS
    Windows 10 Pro 64Bit
    CPU
    AMD FX-8150 Black Edition, sAM3+ 3.60 GHz, Octa-Core, 16MB, 125W
    Motherboard
    Asus Sabertooth 990FX AM3+
    Memory
    Corsair Vengeance 32GB DDR3 kit (4x 8GB), CMZ32GX3M4X1866C10'
    Graphics Card(s)
    EVGA GTX 970 Superclocked ACX 2.0
    Monitor(s) Displays
    Philips 32"PFL9606H/12
    Hard Drives
    Samsung 850 Pro series 1 TB

CK1985NL

Member
Member
Posts
161
#6
@ Ending

I tried ccc in admin mode, but no result. He will not open.
 

My Computer

System One

  • OS
    Windows 10 Pro 64Bit
    CPU
    AMD FX-8150 Black Edition, sAM3+ 3.60 GHz, Octa-Core, 16MB, 125W
    Motherboard
    Asus Sabertooth 990FX AM3+
    Memory
    Corsair Vengeance 32GB DDR3 kit (4x 8GB), CMZ32GX3M4X1866C10'
    Graphics Card(s)
    EVGA GTX 970 Superclocked ACX 2.0
    Monitor(s) Displays
    Philips 32"PFL9606H/12
    Hard Drives
    Samsung 850 Pro series 1 TB

CK1985NL

Member
Member
Posts
161
#7
Great, I made it finally. You really need to try removing everything of amd. I've looked at amd files through task management. Press properties and must refer to something windows: system 32, there is somewhere a few files from ati (amd) you need to remove all. Then reboot your PC and install all the drivers again. Then it must work. Thank you all for your help.
 

My Computer

System One

  • OS
    Windows 10 Pro 64Bit
    CPU
    AMD FX-8150 Black Edition, sAM3+ 3.60 GHz, Octa-Core, 16MB, 125W
    Motherboard
    Asus Sabertooth 990FX AM3+
    Memory
    Corsair Vengeance 32GB DDR3 kit (4x 8GB), CMZ32GX3M4X1866C10'
    Graphics Card(s)
    EVGA GTX 970 Superclocked ACX 2.0
    Monitor(s) Displays
    Philips 32"PFL9606H/12
    Hard Drives
    Samsung 850 Pro series 1 TB

loveandpower

New Member
Power User
United States

Posts
406
#8
Uninstall all ATI/AMD display drivers

feel free to use a tool such as this for example

Display Driver Uninstaller (DDU) 12.9.7.0

Uninstall all of your frameworks ( this will take some time I know.. )

and then install the graphic driver. It will probably try to install it's own framework version.
 

My Computer

System One

  • OS
    windows 8.1
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    iBUYPOWER
    CPU
    AMD 8320
    Graphics Card(s)
    Radeon 7850
    Screen Resolution
    1024x768
    Case
    Azza Solaris
    Internet Speed
    50MBps download/10MBps upload
    Browser
    Chrome/Firefox/Internet Explorer
    Antivirus
    Malwarebytes PRO

CK1985NL

Member
Member
Posts
161
#9
@ loveandpower

Thanks, it's working now. I downloaded display driver uninstaller and I will keep that save for another time.
 

My Computer

System One

  • OS
    Windows 10 Pro 64Bit
    CPU
    AMD FX-8150 Black Edition, sAM3+ 3.60 GHz, Octa-Core, 16MB, 125W
    Motherboard
    Asus Sabertooth 990FX AM3+
    Memory
    Corsair Vengeance 32GB DDR3 kit (4x 8GB), CMZ32GX3M4X1866C10'
    Graphics Card(s)
    EVGA GTX 970 Superclocked ACX 2.0
    Monitor(s) Displays
    Philips 32"PFL9606H/12
    Hard Drives
    Samsung 850 Pro series 1 TB

loveandpower

New Member
Power User
United States

Posts
406
#10
Good to hear it's working post back if any other problems start to occur. :)
 

My Computer

System One

  • OS
    windows 8.1
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    iBUYPOWER
    CPU
    AMD 8320
    Graphics Card(s)
    Radeon 7850
    Screen Resolution
    1024x768
    Case
    Azza Solaris
    Internet Speed
    50MBps download/10MBps upload
    Browser
    Chrome/Firefox/Internet Explorer
    Antivirus
    Malwarebytes PRO

CK1985NL

Member
Member
Posts
161
#11
@ loveandpower

Thanks, actually I have now another problem, I got BSOD. I Made a new thread and I made a rar file with minidump file in it. Maybe you can help me to solve this problem. Thanks.
 

My Computer

System One

  • OS
    Windows 10 Pro 64Bit
    CPU
    AMD FX-8150 Black Edition, sAM3+ 3.60 GHz, Octa-Core, 16MB, 125W
    Motherboard
    Asus Sabertooth 990FX AM3+
    Memory
    Corsair Vengeance 32GB DDR3 kit (4x 8GB), CMZ32GX3M4X1866C10'
    Graphics Card(s)
    EVGA GTX 970 Superclocked ACX 2.0
    Monitor(s) Displays
    Philips 32"PFL9606H/12
    Hard Drives
    Samsung 850 Pro series 1 TB

loveandpower

New Member
Power User
United States

Posts
406
#12
will take a look at it, but I'm no expert when it comes to deciphering BSOD issues.
 

My Computer

System One

  • OS
    windows 8.1
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    iBUYPOWER
    CPU
    AMD 8320
    Graphics Card(s)
    Radeon 7850
    Screen Resolution
    1024x768
    Case
    Azza Solaris
    Internet Speed
    50MBps download/10MBps upload
    Browser
    Chrome/Firefox/Internet Explorer
    Antivirus
    Malwarebytes PRO

CK1985NL

Member
Member
Posts
161
#13
@ loveandpower

Thanks a lot.
 

My Computer

System One

  • OS
    Windows 10 Pro 64Bit
    CPU
    AMD FX-8150 Black Edition, sAM3+ 3.60 GHz, Octa-Core, 16MB, 125W
    Motherboard
    Asus Sabertooth 990FX AM3+
    Memory
    Corsair Vengeance 32GB DDR3 kit (4x 8GB), CMZ32GX3M4X1866C10'
    Graphics Card(s)
    EVGA GTX 970 Superclocked ACX 2.0
    Monitor(s) Displays
    Philips 32"PFL9606H/12
    Hard Drives
    Samsung 850 Pro series 1 TB
Posts
1
#14
Plz I have a problem
My Pc is Gigabyte AMD 78
Processor Athlon II 2 x 250
Ram Kingstone Hyber blu 1600
My Video card is built in
The PC case is tiger X6
I want to buy Nvidia FX4800 QUADRO but I know that I 've to buy a powerful power supply..........
I've got an idea and I don't know if its is good or dangerous:
I won't buy a new powerful power supply....... instead I will leave the current power supply and I will buy a cheaper one (200 Watts), and connect the Nvidia FX 4800 with that power supply only.........while my PC still works using the Tiger X6 power supply.
Is that good?
Plz tell me thanks
 

My Computer

System One

  • OS
    Widows 7

CK1985NL

Member
Member
Posts
161
#15
Hi medo322002. I don't have an idea by myself. But I think someone will help you as soon as possible. Good luck further...
 

My Computer

System One

  • OS
    Windows 10 Pro 64Bit
    CPU
    AMD FX-8150 Black Edition, sAM3+ 3.60 GHz, Octa-Core, 16MB, 125W
    Motherboard
    Asus Sabertooth 990FX AM3+
    Memory
    Corsair Vengeance 32GB DDR3 kit (4x 8GB), CMZ32GX3M4X1866C10'
    Graphics Card(s)
    EVGA GTX 970 Superclocked ACX 2.0
    Monitor(s) Displays
    Philips 32"PFL9606H/12
    Hard Drives
    Samsung 850 Pro series 1 TB