What's new

After Implementing VPN, Some "Metro" Apps Non-Responsive

VideoSavant

Member
Member
I'm using Hamachi and Privoxy on my Windows 8 (release version via TechNet). I just did a clean Windows 8 install on Wednesday, and when I implemented my VPN via Hamachi/Privoxy on Thursday, some Metro apps are unable to access the network. On the other hand, everything seems to work just fine from the desktop, including both Firefox and Chrome browsers.

I also had this problem when I was using the Developer Preview, and at that time I searched around online to find others with the same problem but no solution. Like others, I chalked this up to the beta nature of the release and didn't worry about it, assuming that MS was aware and that a fix would be done prior to the official release. Now, with the final release, I'm seeing what appears to be the same behavior.

Does anyone have any suggestions on how to configure the network via Windows, or through changes to the Hamachi and Privoxy configurations?

Thanks.
 

My Computer

System One

  • OS
    Windows 7, Service Pack 1
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Homebrew
    CPU
    Intel Q8300
    Motherboard
    Gigabyte EP43-UD3L
    Memory
    6 GB
    Graphics Card(s)
    NVidia GForce 8400 GS
    Monitor(s) Displays
    Samsung SA300
    Screen Resolution
    1920x1080
    Hard Drives
    Kingston SV300S37A120G SSD
    Western Digital WD3200AAJS-65VWA0
    Hitachi HDS721010CLA332
    Seagate ST2000DL003-9VT166
    Keyboard
    Logitech K800
    Mouse
    Logitech M525
    Internet Speed
    50 Mb
    Browser
    Cool Novo
    Antivirus
    Microsoft Security Essentials

VideoSavant

Member
Member
Why has this been marked solved? Not Solved!

Edit: OK -- it looks like the "Solved" status has been removed...
 

My Computer

System One

  • OS
    Windows 7, Service Pack 1
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Homebrew
    CPU
    Intel Q8300
    Motherboard
    Gigabyte EP43-UD3L
    Memory
    6 GB
    Graphics Card(s)
    NVidia GForce 8400 GS
    Monitor(s) Displays
    Samsung SA300
    Screen Resolution
    1920x1080
    Hard Drives
    Kingston SV300S37A120G SSD
    Western Digital WD3200AAJS-65VWA0
    Hitachi HDS721010CLA332
    Seagate ST2000DL003-9VT166
    Keyboard
    Logitech K800
    Mouse
    Logitech M525
    Internet Speed
    50 Mb
    Browser
    Cool Novo
    Antivirus
    Microsoft Security Essentials

cluberti

Cat herder
VIP Member
Pro User
Do you have to configure specific proxy settings for either of those? I don't remember anymore as I haven't used them in a long time, but modern apps (because they're in an appcontainer sandbox) use different methods to get internet access than desktop apps, and proxies can play havoc with these if not configured properly.
 

My Computer

System One

  • OS
    Windows 8.1 x64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Custom
    CPU
    Intel Core i7 4790K @ 4.5GHz
    Motherboard
    Asus Maximus Hero VII
    Memory
    32GB DDR3
    Graphics Card(s)
    Nvidia GeForce GTX970
    Sound Card
    Realtek HD Audio
    Hard Drives
    1x Samsung 250GB SSD
    4x WD RE 2TB (RAIDZ)
    PSU
    Corsair AX760i
    Case
    Fractal Design Define R4
    Cooling
    Noctua NH-D15

VideoSavant

Member
Member
There are some settings for both Hamachi and Privoxy, but the setup for both is pretty straightforward, which is a key part of the attraction of this combination for users who aren't networking experts.

I found the discussion about this problem that I mentioned in my earlier note here:

proxy settings for metro apps

Because this was a pre-release thread, it has hit a dead-end, and the conversation about this problem continuing in the official Win8 release is here:

Windows 8 RTM still has problems with "metro" apps going through proxy servers

It seems odd that Microsoft knew about proxy issues with Metro apps during beta testing and did not address the problem. Anyway, the release discussion is going pretty far into the weeds and while I'm still working through the suggestions detailed there, I've still not resolved the issue with my own setup.
 

My Computer

System One

  • OS
    Windows 7, Service Pack 1
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Homebrew
    CPU
    Intel Q8300
    Motherboard
    Gigabyte EP43-UD3L
    Memory
    6 GB
    Graphics Card(s)
    NVidia GForce 8400 GS
    Monitor(s) Displays
    Samsung SA300
    Screen Resolution
    1920x1080
    Hard Drives
    Kingston SV300S37A120G SSD
    Western Digital WD3200AAJS-65VWA0
    Hitachi HDS721010CLA332
    Seagate ST2000DL003-9VT166
    Keyboard
    Logitech K800
    Mouse
    Logitech M525
    Internet Speed
    50 Mb
    Browser
    Cool Novo
    Antivirus
    Microsoft Security Essentials

VideoSavant

Member
Member
OK, I found a solution for my problem. I'm not a networking whiz, so I'm not going to try to list the steps here, but rather point you to a couple of threads where you can find all the info that eventually got all my Metro app connectivity working as it should.

Here are the two threads, in chronological order:

proxy settings for metro apps

Windows 8 RTM still has problems with "metro" apps going through proxy servers

The first thread goes back to pre-release days, while the second was started shortly after RTM.

Because I tried a number of "fixes" for the connectivity issue and the last proposed solution was the one that fixed the problem, it's possible that one or more of the earlier steps is not necessary. On the other hand, none of the first three steps broke anything (as far as I can tell -- it's been a a day or so w/o problem), and I have not attempted to undo any of them.

* The first step involves making changes to the Local Group Policy. This is explained here in the first thread:

Message from TommyBeck on Tuesday, March 06, 2012 2:14 PM.

Note that when I set this on the release version there was no setting specifically for Metro apps. So, I ended up selecting the setting for Internet (not Intranet) apps.

* The next change involves the System Registry. That info can be found in a reply written by Brent Landry on Tuesday, August 21, 2012 5:57 PM. This is pretty straightforward.

* The third step is actually two steps, one downloading/installing a Enable Loopback utility that registers each Metro app you have installed on your computer. You need to download the utility, run it for all of your currently installed Metro apps (select all, hit refresh if not all appear), and then move to the next step. The details on the utility can be found in the second thread, in a reply written by Manas Chaudhari on Monday, September 17, 2012 1:02 PM.

* The final step (and the one that returned connectivity to ALL my Metro apps) was to run a series of commands from the command prompt with Administrator privileges. That information can be found in the second thread in a post by AnindyaMaiti on Saturday, September 22, 2012 4:52 AM. This step assumes that you have entered your local proxy into your Internet Explorer settings, so note that if you haven't already done so, you need to do that BEFORE running the script.

Note that this solution still requires that you run the Enable Loopback utility whenever you install new Metro apps. Obviously, that's not as friction-free as it would ideally be. But it works (for me, at least).

Finally, as noted, I'm not a network expert, so I am presenting this solution with the caveat that doing each of these four steps worked for me. If someone figures out that one or more steps are not required, I have no pride of authorship. Hopefully someone network-savvier than me can eventually simplify into a self-contained message what I've detailed here. Likewise, I'm not marking this as solved for all the reasons noted above.

If you're having this problem, I hope this fixes it for you.
 
Last edited:

My Computer

System One

  • OS
    Windows 7, Service Pack 1
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Homebrew
    CPU
    Intel Q8300
    Motherboard
    Gigabyte EP43-UD3L
    Memory
    6 GB
    Graphics Card(s)
    NVidia GForce 8400 GS
    Monitor(s) Displays
    Samsung SA300
    Screen Resolution
    1920x1080
    Hard Drives
    Kingston SV300S37A120G SSD
    Western Digital WD3200AAJS-65VWA0
    Hitachi HDS721010CLA332
    Seagate ST2000DL003-9VT166
    Keyboard
    Logitech K800
    Mouse
    Logitech M525
    Internet Speed
    50 Mb
    Browser
    Cool Novo
    Antivirus
    Microsoft Security Essentials
Top