Windows 8 and 8.1 Forums

Problem sharing PPPoE internet connection

  1. #1

    Posts : 2

    Problem sharing PPPoE internet connection

    I have a problem sharing PPPoE internet connection after installing Win8 in top of Win7.

    On my computer (say, "Computer A") I have 2 LAN ports on the motherboard:
    1-st one ("Ethernet 1") is connected to internet provider
    2-nd one ("Ethernet 2") is connected to "Computer B"

    I am trying to set up internet an connection on "Computer A" and share it to "Computer B";
    I created a broadband connection and checked the checkbox in its sharing tab, allowing other users of the network to be able to use my internet connection (I specified the "Ethernet 2" connection as the "home network connection" in this tab)

    Then I configure the TCP/IP v4 protocol on the "Ethernet 2" connection in the following way:
    subnet mask
    default gateway: (but after closing and opening the protocol properties window this field became blank)

    I tested both computers can be ping-ed from each other.
    After this simple configuration I am connecting to the internet.
    I have the internet on "Computer A", but NO internet on "Computer B".
    Moreover, on computer B, while I am trying to ping some site, its IP addess is determined correctly, but sill no internet.

    Can anyone help me, I killed several days trying to solve this problem. Once again I had no such problem on windows 7 with the same hardware

    Computer A:
    MB P5Q-E
    Ethernet 1 adapter: Marvell Yukon 88E8056 PCI-E Gigabit Ethernet Controller
    Ethernet 2 adapter: Marvell Yukon 88E8001/8003/8010 PCI Gigabit Ethernet Controller
    Windows 8 Profesional

    Computer B:
    Samsung N150 Netbook
    Windows XP

      My System SpecsSystem Spec

  2. #2

    Posts : 1
    8 and 7

    Have you tried RIGHT clicking on the network adapter, and selecting properties, and then clicking the sharing tab.
    Tick "Allow other network users to connect through this computers internet connection."
      My System SpecsSystem Spec

  3. #3

    Posts : 2

    Yes, i tried setting the "Allow other network users to connect through this computers internet connection." checbox on the broadband connection (in this case secon Computer B at least resolves internet addresses to IP).
    I also tried ticking this checkbox on the "Ethernet 2" adapter
      My System SpecsSystem Spec

  4. #4

    Have you tried going into services.msc and change the "internet connection sharing" setting from disabled to Automatic. I would also set it up with Ethernet connection 1 as the Home Network.

    Go to bottom of page in link for more information.

    Internet Connection Sharing ( ICS ) not working in Windows 8 CP

    I'll assume that my advice solved this problem "since it's marked as solved" as I have already solved this problem with the same fix many times already.

    For some reason they disabled this setting by Default which did not use to be the case.

    The gateway IP showing up as the DSN server is simply because the router is being used for the DNS which is the way to go in my book .

    There is absolutely no reason to type DNS servers into the IPv4 properties if you already have DNS servers set up in the routers settings.
    Last edited by chev65; 22 Jun 2013 at 10:50.
      My System SpecsSystem Spec

  5. #5


    Another suggestion for you (keep going )

    Just read your first post again and I would not be happy with the dns setting being the same as gateway. I checked my properties which are as shown and would suggest giving them a try obviously keeping your own IP numbers.

    Another thing I not is that you have the same machine address as the gateway ---- that is a nono they need separate addresses maybe try

    Apart from my IP numbers the settings are from my laptop which connects via Ethernet or WiFi so hopefully they would work on yours - fingers crossed. DNS numbers are public from Google or you could get them from your ISP.

    Best wishes

    Attached Thumbnails Attached Thumbnails tcpip.PNG  
      My System SpecsSystem Spec

Problem sharing PPPoE internet connection
Related Threads
How to Create a WiFi Hotspot in Windows 8 and 8.1 This tutorial will show you how to create a virtual WLAN network on your WiFi equipped computer, to be used as a Hotspot to share the Internet connection with other WiFi devices when the router does not allow or support WLAN. For this...
My friend lives in an area where the only possible internet connection is through a CDMA USB device. They have multiple computers all connected through a host computer sharing this CDMA connection. Recently they had a major problem with the Windows XP machine that was acting as host. So they...
Hi Folks, After too many hours of reading and trying various things. It appears that Internet Connection Sharing (ICS) from USB 3G Modems has been broken in Windows 8.1. On my Desktop PC, which uses Windows 2000 Server, I am able to share a Huawei E156B USB 3G Modem to 1 of the Ethernet ports...
Hi guys, I am having trouble with ICS on win 8. On my old laptop (win xp) I used to be able to share my 3Connect dongle internet to connect to Xbox live. I recently got a new laptop with win 8 and whenever I share this internet connection I can never connect on my Xbox (the network to internet part...
Okay, so in Windows 7 I am able to connect my wireless to my phone, and run an ethernet cable over to my Xbox. If I use the ICS feature and configure it under services to allow ports 88 and 53 UDP, it works fine. This also allows my Xbox to seemingly add to this list of ports as it finds...
Hi, Hosted network is started and my phone is connected; but i cant access internet by Wifi ICS in Windows 8.1 Pro. But in Windows 7 it's fine. Please help. ================Windows 8.1 WLAN driver================ Microsoft Windows (c) 2013 Microsoft Corporation. All rights reserved.
though I have set it as usual username and password, I use PPPOE by the way I've checked not to ask me again, also for all users, only one on this computer though. I use windows 8 x64 enterprise. I put network shortcut in the startup , I tried scheduling a task that runs rasdial or rasphone ,...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook