• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Problem sharing PPPoE internet connection


bocovp

New Member
Posts
2
#1
I have a problem sharing PPPoE internet connection after installing Win8 in top of Win7.

On my computer (say, "Computer A") I have 2 LAN ports on the motherboard:
1-st one ("Ethernet 1") is connected to internet provider
2-nd one ("Ethernet 2") is connected to "Computer B"


I am trying to set up internet an connection on "Computer A" and share it to "Computer B";
I created a broadband connection and checked the checkbox in its sharing tab, allowing other users of the network to be able to use my internet connection (I specified the "Ethernet 2" connection as the "home network connection" in this tab)

Then I configure the TCP/IP v4 protocol on the "Ethernet 2" connection in the following way:
IP 192.168.137.1
subnet mask 255.255.255.0
default gateway: 192.168.137.1 (but after closing and opening the protocol properties window this field became blank)
DNS 192.168.137.1

I tested both computers can be ping-ed from each other.
After this simple configuration I am connecting to the internet.
I have the internet on "Computer A", but NO internet on "Computer B".
Moreover, on computer B, while I am trying to ping some site, its IP addess is determined correctly, but sill no internet.

Can anyone help me, I killed several days trying to solve this problem. Once again I had no such problem on windows 7 with the same hardware

Computer A:
MB P5Q-E
Ethernet 1 adapter: Marvell Yukon 88E8056 PCI-E Gigabit Ethernet Controller
Ethernet 2 adapter: Marvell Yukon 88E8001/8003/8010 PCI Gigabit Ethernet Controller
Windows 8 Profesional

Computer B:
Samsung N150 Netbook
Windows XP
 

My Computer

System One

  • OS
    Win8

Jarhead69

New Member
Posts
1
#2
Have you tried RIGHT clicking on the network adapter, and selecting properties, and then clicking the sharing tab.
Tick "Allow other network users to connect through this computers internet connection."
 

My Computer

System One

  • OS
    8 and 7

bocovp

New Member
Posts
2
#3
Yes, i tried setting the "Allow other network users to connect through this computers internet connection." checbox on the broadband connection (in this case secon Computer B at least resolves internet addresses to IP).
I also tried ticking this checkbox on the "Ethernet 2" adapter
 

My Computer

System One

  • OS
    Win8
#4
Have you tried going into services.msc and change the "internet connection sharing" setting from disabled to Automatic. I would also set it up with Ethernet connection 1 as the Home Network.

Go to bottom of page in link for more information. :)

Internet Connection Sharing ( ICS ) not working in Windows 8 CP

I'll assume that my advice solved this problem "since it's marked as solved" as I have already solved this problem with the same fix many times already.

For some reason they disabled this setting by Default which did not use to be the case.

The gateway IP showing up as the DSN server is simply because the router is being used for the DNS which is the way to go in my book .

There is absolutely no reason to type DNS servers into the IPv4 properties if you already have DNS servers set up in the routers settings.
 
Last edited:

My Computer

System One

  • OS
    Windows 8.1 Pro WMC
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    Home built
    CPU
    Q9650 @ 4.05 GHz
    Motherboard
    Gforce 780i SLI FTW
    Memory
    8GB Gskill DDR2 1200Mhz
    Graphics Card(s)
    GTX-480
    Sound Card
    Asus D2 Xonar
    Monitor(s) Displays
    HannsG
    Screen Resolution
    1680x1050
    Hard Drives
    Gskill 120GB SSD
    PSU
    Thermal Take 1000watts
    Case
    Thermal Take Xtreme
    Cooling
    9 fans air cooled
    Keyboard
    G15 logitech
    Mouse
    G9 logitech
    Internet Speed
    50mbps

kaybee327

Member
Member
Halifax, UK

Posts
63
#5
Bocovp

Another suggestion for you (keep going ) :dinesh:

Just read your first post again and I would not be happy with the dns setting being the same as gateway. I checked my properties which are as shown and would suggest giving them a try obviously keeping your own IP numbers.

Another thing I not is that you have the same machine address as the gateway ---- that is a nono :mad: they need separate addresses maybe try 192.168.137.15

Apart from my IP numbers the settings are from my laptop which connects via Ethernet or WiFi so hopefully they would work on yours - fingers crossed. DNS numbers are public from Google or you could get them from your ISP.

Best wishes

Keith
 

Attachments

My Computer

System One

  • OS
    Win 8 64bt
    System Manufacturer/Model Number
    Asus Aspire
    CPU
    Sempron 2.8
    Motherboard
    Asrock
    Memory
    4GB
    Graphics Card(s)
    Intel
    Sound Card
    Realtek
    Monitor(s) Displays
    Samsung
    Screen Resolution
    1024 x 768
    Hard Drives
    2 x ide
    1 x sata
    Internet Speed
    Up to 24 :)