Windows 8 and 8.1 Forums

"This devise could not be locked....Error 4630

  1. #1

    Posts : 2

    "This devise could not be locked....Error 4630

    Just installed a Canon DR-C 225 scanner and everytime I start the scan SW I get, "The devise could not be Locked. Check that another application isn't using the devise -4630." I shut all other applications down, shut down the computer and started again, no change. Ugh

      My System SpecsSystem Spec

  2. #2

    United States
    Posts : 3,093
    Windows 8.1 Pro 64-bit
      My System SpecsSystem Spec

  3. #3

    Posts : 2


    I saw on another post somewhere that sometime changing the USB cable works? Surprised me completely that when I did, problem was solved.
      My System SpecsSystem Spec

  4. #4

    Posts : 1
    Windows 10

    For 4 years I have been dealing with this problem! I finally found a SOLUTION!!! I have read this thread at least 40 times hoping someone would post a solution that would work for me. I feel compelled to share my solution and I hope it works for you.

    I own a Canon ImageFORMULA P-150. I love the thing. It is an inexpensive multisheet duplex scanner. When I first setup the scanner it worked perfectly for some time. Back then, my computer was running windows 7. Occasionally I would try to use the scanner after being away from the computer for a while and I would get "Error -4630: The device could not be locked. Check that another application is not using the device."

    When this problem first popped up, all I needed to do was reboot my computer and everything would work. So... I searched the internet for a solution and when I couldn't find one I resigned myself to rebooting the computer every once in a while. Fast forward a couple of years and Microsoft eventually got me to upgrade to Windows 10. After the Windows 10 update, I was having to reboot the computer every time I needed to use the scanner.

    Then... (about 3 weeks ago) I had to reboot he computer multiple times. And now, (last 3 days), I couldn't get the scanner to work.

    Solutions I already tried that did not work:
    I tried everything I could find to fix this problem except for (a) replace my canon p-150 and (b) switch computers. I tried multiple USB cables, I fiddled with the auto-start switch on my scanner, I tried using power over USB and power from the wall, I tried changing which port the USB was plugged into on the computer (front ports, back ports, USB 2.0, USB 3.0, USB 1.0), I tried unplugging other USB devices to decrease the number of devices on the bus, I tried reinstalling the driver, I upgraded the driver, I disabled the driver and re-enabled it, I fiddled with the start-up settings for CaptureOnTouch, added a 'ServicesPipeTimeout' setting in regedit, unplugged and re-plugged the USB cable, and probably some more things that I can't remember.

    My first thought when I originally ran into this issue was that there was a race condition that was causing this error to occur. I think the error description is correct, "The device could not be locked. Check that another application isn't using the device". Some other application, service, or driver had laid claim to my P-150 and keeping Canon's software from using it. After reading many forum posts I ran across information about Windows Image Acquisition (WIA, stisvc). The "Services" application describes WIA as "Provides image acquisition services for scanners and cameras". Eureka! Maybe this service was failing to relinquish my P-150 to the Canon software. IT WAS! Below are the steps to follow to disable it (These are windows 10 instructions, hopefully other windows versions are similar)

    1. Run "services.msc"
    2. Find "Windows Image Acquisition (WIA)" and right-click it
    3. Select "Properties"
    4. Change "Startup Type:" to "Disabled".
    5. Reboot computer

    Important Notes
    1. I tried setting "Startup Type" to "Automatic (Delayed Start)", that did not work
    2. I tried to "Stop" and "Pause" the service but that did not work, I received error "1061: The service cannot accept control messages at this time. Maybe WIA is broken on my machine, who knows.
    3. This is not a great solution, I imagine the WIA service is necessary for some tasks and I would prefer to not have to disable it. Maybe someone can propose a better solution.
      My System SpecsSystem Spec

"This devise could not be locked....Error 4630
Related Threads
Hello, Following the forum guidelines I am posting a compressed file from your SF Diagnostic tool. This was done shortly after a BSOD. Thanks for your support in helping me understand what is the cause of those frequent BSOD. Joce
"Activation error not found", error 0xC0000022 in Windows Updates & Activation
Hey guys, I'd really appreciate some help here. Much thanks in advance to anyone who can solve this problem... I took my Acer laptop into a repair shop to fix a broken power button and ever since then Windows 8 has been asking me to activate. I don't know how this happened as the repair guy...
Locked in "Repair" Mode in Performance & Maintenance
My Dell laptop, new this past Christmas and running Win 8, has entered into a repair mode: "Repairing disk errors. This may take over an hour to complete" It has run for 48 hours. Advice on how to proceed?
hello all. I just got my new pc with MS Windows 8. I tried to set up the "People" app and I keep receiving an error which tells me that "Your password has changed. Please enter your password." Howvever there is no place to re-enter my password nor did I change my password. Since I get...
Solved Win8 Desktop "locked" in Installation & Setup
I have done a re-install of WIN8 due to stabilty and speed issues. It is a DUAL boot with Ubuntu 13.04, but this is not the problem. The DESKTOP (I use Classic Shell) to get to the Desktop not the START screen. This worked well with my previous install. However, I can't put ANYTHING on the...
Hi everyone Devise Manager tells me i have issues Any ideas ??
Co-posted at SevenForums: HTG Explains: How Windows 8′s Secure Boot Feature Works & What It Means for Linux - How-To Geek Microsoft Secure Boot Could Ban Windows From PCs | Wired Enterprise | ...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook