Windows 8 and 8.1 Forums


USB port problems with Windows 8.1; device malfunctioning.

  1. #1

    USB port problems with Windows 8.1; device malfunctioning.


    Okay, so I got an error message a while ago stating that "Power Surge On Hub Port: A USB device has exceeded the power limits of its hub port", I ignored this message for a while until my USB, wireless mouse receiver stopped working completely (BTW at this point I had a WiFi adapter, Bluetooth receiver,wireless mouse receiver, wired keyboard, webcam and I had my phone and tablet both charging off of the PC), I then unplugged my phone and tablet from the computer (assuming that they were taking too much power) but this did not work, I restarted my computer with only a keyboard and mouse plugged in. After the restart neither of the device were working so I unplugged the mouse and tried it in a different computer, it didn't work here either but it gave the "USB device has malfunctioned and Windows does not recognize it" error message. After that problem, all of my USB device have slowly started to stop working in both of my computers and I can't figure out what the problem is. So far, as of this post my WiFi adapter has stopped working along with my wireless mouse, wired mouse, wired keyboard bluetooth adapter and webcam.

      My System SpecsSystem Spec

  2. #2


    Oh, and by the way, I have already tried to uninstall, re-install and update all the drivers and stuff.
      My System SpecsSystem Spec

  3. #3


    Posts : 2,480
    Windows 10 Pro x64


    Try attaching something else to the usb ports.
      My System SpecsSystem Spec

  4. #4


    Quote Originally Posted by softwaremaniac View Post
    Try attaching something else to the usb ports.

    Okay, I tried that, anything else that I plug in to the PC works fine. Anything that doesn't already work will not work in any computer which is concerning.

    Thanks for the reply by the way, really appreciate it.
      My System SpecsSystem Spec

  5. #5


    Posts : 2,480
    Windows 10 Pro x64


    Is it possible that the HW malfunctoned?
      My System SpecsSystem Spec

  6. #6


    Quote Originally Posted by softwaremaniac View Post
    Is it possible that the HW malfunctoned?
    Yes and it seems that is the case here, but I don't understand why this is happening. Everything was working fine for a VERY long time. Could the power surge on my USB ports have caused my devices to malfunction? Is there a way to fix this?
      My System SpecsSystem Spec

  7. #7


    Posts : 2,480
    Windows 10 Pro x64


    Yes. You could try this:
    Method 1:

    Run the fixit from the following link.

    Hardware devices are not working or are not detected in Windows
    </title> <link href="//az623152.vo.msecnd.net/cdnresources/1.51/content/smccss.css" rel="stylesheet" /> <link href="//az623152.vo.msecnd.net/cdnresources/1.51/common/css/default/fixit.css" rel="stylesheet" /> <link href="//az623152.vo.msecnd.net/cdnr

    Method 2:

    Re-install the USB Controllers.

    a) Click Start and type devmgmt.msc, and then press Enter.
    b) Expand the Universal Serial Bus Controllers section.
    c) Uninstall each of the devices under the USB Controller section by right-clicking on each one, and then clicking Uninstall.
    d) Close the Device Manager and restart your computer.

    Windows will automatically re-install the USB controllers in your computer, without you having to do anything further. Your computer should now run USB devices properly.
    But I'm not optimistic about this, especially since no computer recognizes them.
      My System SpecsSystem Spec

  8. #8


    Quote Originally Posted by softwaremaniac View Post
    Yes. You could try this:
    Method 1:

    Run the fixit from the following link.

    Hardware devices are not working or are not detected in Windows
    </title> <link href="//az623152.vo.msecnd.net/cdnresources/1.51/content/smccss.css" rel="stylesheet" /> <link href="//az623152.vo.msecnd.net/cdnresources/1.51/common/css/default/fixit.css" rel="stylesheet" /> <link href="//az623152.vo.msecnd.net/cdnr

    Method 2:

    Re-install the USB Controllers.

    a) Click Start and type devmgmt.msc, and then press Enter.
    b) Expand the Universal Serial Bus Controllers section.
    c) Uninstall each of the devices under the USB Controller section by right-clicking on each one, and then clicking Uninstall.
    d) Close the Device Manager and restart your computer.

    Windows will automatically re-install the USB controllers in your computer, without you having to do anything further. Your computer should now run USB devices properly.
    But I'm not optimistic about this, especially since no computer recognizes them.
    Okay, I just tried both of these and the wireless mouse seems to be unaffected but I did notice something with the WiFi adapter. The adapter is now recognised by Windows but just can't find any networks. This happens on both of my computers.
      My System SpecsSystem Spec

  9. #9


    Posts : 2,480
    Windows 10 Pro x64


    Install drivers from the manufacturer's website.
      My System SpecsSystem Spec

  10. #10


    Quote Originally Posted by softwaremaniac View Post
    Install drivers from the manufacturer's website.
    I tried that as well but I encountered some problems...
    If you can't view the file attached to this reply, try the Google Drive link:
    https://drive.google.com/file/d/0B-_...ew?usp=sharing
    Click image for larger version
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
USB port problems with Windows 8.1; device malfunctioning.
Related Threads
Hello! Recently I've come across an issue with my Toshiba laptop (Windows 8) and I am completely puzzled as to what this issue is. When I open my primary account, my mouse will work for around a minute, allowing me to open programs etc. But then it will stop. Just stop working, in one set area....
47143 47144 47145 so i opened my port 25565 (or so i thought) went to test to see if its open on multiple sites and....all of them say its closed. :confused:
CDMA software requires a COM port to communicate with a cell phone. I'm using HW Virtual Serial Port v3.1.2 (single port, standalone install). I have a separate modem and router. My Win8.1 PC is hardwired to the modem. Windows firewall is off. Windows Defender is off. Motorola Mobile Drivers...
I have been several problems for a while since I installed Windows 8. Firstly my screen and WiFi randomly stop working (at different times). The screen goes blank (black) and it won't do anything (even caps lock) so I think it's completely frozen. Usually I hard reset, but today I got...
I recently purchased Alienware 17. I decided to stick a somewhat large mSATA SSD drive in, use it as my boot, and installe the 8.1 preview build. So this is a relatively fresh install with little more than the drivers and browser running. Upon putting the computer to sleep, hibernating, or...
Hi there I've noticed that when I connect a USB2 external drive to a USB3 port it actually performs better than when even on a "Hi-Speed" USB2 port. -- transfer rate from USB2 to HDD is around 10 - 15 Mb/s faster than when on a USB2 port. I have two USB3 slots on my computer -- I have a Targus...
Under display drivers in my device manager, I have two things listed. AMD Radeon 6600M and 6700M Series, and Intel(R) HD Graphics 3000. The AMD Radeon is the one showing the error code 43. I've scanned for driver updates, it says the driver is up to date. I've tried using AMD's driver updater...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook