Windows 8 and 8.1 Forums

8GB of ram installed but I can only use 4GB of it?

  1. #1

    Posts : 2
    Windows 8.1 SL OEM

    8GB of ram installed but I can only use 4GB of it?

    Is this normal? if not then how do I use ALL of the memory?
    It detects that I have 8gb of ram but it only uses 4gb of it
    I saw that 4gb was in hardware reserve and i dunno how to allocate more memory for use
    Click image for larger version
    Click image for larger version
    Click image for larger version

    I have Windows 8.1 SL OEM

    AMD FX-8350 8-Core @ 4GHz | Cooler Master Seidon 120v Liquid Cooling System | AMD Radeon R7 250 2gb DDR3 with Boost | ASRock 990FX Extreme4 | Kingston HyperX Fury 4gb (2x) | ThermaTake 700w LitePower| WD Caviar Green 2TB HDD | Corsair Carbide 300R Windowed

    1. BIOS is updated
    2. I can only change the DRAM Frequency in the BIOS, I currently set it to 1600 in hopes of fixing it
    3. Msconfig > Boot > Advanced > Maximum memory unticked
    4. I have also put both sticks in slot 1 & 3 but no luck
    5. Kingston HyperX Fury is not on my mobo's compatibility list
    6. Regedit-> Hkey local machine->CurrentControlSet->Control->SystemResources->ReservedResources -> No Value set
    7. I tried to boot my pc using each sticks themselves, still no luck but:
    Click image for larger version
    Click image for larger version
    Click image for larger version

    8. There are no programs that are hogging the ram yet
    9. I have contacted the Kingston representative over at
    10. for more details: 8GB of ram installed but i can only use 4GB of it? - RAM - Memory

    Will be adding more information when asked!

    Thanks in advance! :)

    - Josh
    Attached Thumbnails Attached Thumbnails fart.jpg   image.jpg   image.jpg   image.jpg   w_t_f.jpg  

      My System SpecsSystem Spec

  2. #2

    Hello there photoshoplol,you think you could check in BIOS,if you have a "memory remap feature" or something similar,to make your memory usable?
      My System SpecsSystem Spec

  3. #3

    Posts : 2
    Windows 8.1 SL OEM

    Nope, All I can do i change the DRAM frequency and the DRAM voltage

    btw i have a P2.70 version of the UEFI if that helps
      My System SpecsSystem Spec

  4. #4

    Posts : 689
    Windows 8.1 Pro with Media Center

    Go to Run...

    • Type in "MSCONFIG" (without quotes)
    • Click on the Boot tab,
    • Click Advanced Options
    • Make sure the Maximum Memory: box is un-checked. (you might also make sure the Number of processors box is also un-checked as well).

    Click image for larger version

    Click image for larger version

    If the boxes were checked, this should solve your issue. If the boxes were not checked, we need to look elsewhere.

    Please let us know.
      My System SpecsSystem Spec

  5. #5

    Central IL
    Posts : 3,468
    Linux Mint 17.2

    Download speccy from Speccy - System Information - Free Download and post the URL that comes up after you run the program. With Windows 8.x.x x64bit, it should be using all 8gb. I am gambling also that it is a bios issue. Others have had RAM issues with this same Motherboard. See AsRock 990FX Extreme4 won't run 32GB DDR3-1866 at more than 1600Mhz [Solved] - DDR3 - Memory

    Run Memtest to check all RAM. If you have an extra USB pocket stick. Install Clonezilla on it. It comes with Memtest as a part of the software. Clonezilla live It can be ran as a USB or DVD install.

    Looking at the spec's on this motherboard. Depending on what CPU you are using. Limits the RAM installed, that can be used. ASRock > 990FX Extreme4
      My System SpecsSystem Spec

8GB of ram installed but I can only use 4GB of it?
Related Threads
Installed my new SSD in Installation & Setup
Just finished installing my new SSD that was cloned with Macrium Reflect v5. Except for a few minor problems everything went OK. The first problem was Macrium Reflect wouldn't allow me to clone to a smaller drive. I had to shrink my C partition with MiniTool Partition Wizard. My second problem was...
KB2919442 installed then not installed in Windows Updates & Activation
Hi, I'm using Windows 8.1 Pro 64 Bit If I go to Control Panel/Windows Update/View Update History KB2919442 is shown as installed successfully on the 12 March 2014 "BUT" if I go to Control Panel/Windows Update/Installed Updates there is no KB2919442 listed. If I download KB2919442 directly...
so I was downloading the updates to windows 8.1, but it wasn't going anywhere so I rebooted. Then on reboot, I try again and it's not showing up on the store. I hit the back button a few times and saw the link again, but it says it's already installed. Now I am pretty sure it didn't get...
Win 8 Pro on ASUS M5A97 LE R2.0 Mobo Bios 1709, 32GIG Patriot (4x 8gig), FX6300 6 core 3.5Ghz Proc, Samsung 128g 840 Pro SSD, WD 2tb 7200 Hdd, Gigabyte GT 610 Video (Nvidia 314.22 Driver) Question Is Why Only 15.4 Gig Available. Thanks ! ! , SEE below AD's for additional Requested Info Thanks...
Installing WMC Add-On appears to change W8's cd key to that used to install the add-on. I had to re-activate the OS after that. The new OS's name is shown as "Windows 8 Pro with Windows Media Center". I am wondering if the CD Key for W8 Pro remains valid. What is the process of reinstalling W8...
Help! Win 8 installed over Win 7 in Installation & Setup
Okay, so I decided I wanted to try windows 8, so I grabbed the ISO from the Microsoft website, created a separate hard drive partition, and I am quite certain that during the installation process, I had installed to the new partition. However, when I tried to access win7 again after installing, it...
I am asking as my Windows 8 will not boot with more than 12 GByte RAM :cry:
Eight Forums Android App Eight Forums IOS App Follow us on Facebook