Windows 8 and 8.1 Forums

Driver realtek RTL 8139

  1. #81

    Posts : 828
    Windows 7 x64 Ultimate/Windows 8.1/Linux

    Ok, a couple more ideas - we will be rebooting a few times...

    1. Open Device manager - Winkey + R type devmgmt.msc
    2. Open network Adapters
    3. Select the Realtek adapter, right click and select Uninstall
    4. Reboot
    5. When the system has started check the status of the adapter and record any errors.
    6. Open msconfig - WinKey + R type msconfig.exe
    7. When msconfig opens, select the Boot tab
    8. On the Boot tab page, place a check in the Boot log box
    9. Reboot
    10. When the system has restarted go to C:\Windows and find ntbtlog.txt. Post this here.

    Part two:

    1. Boot the PC to safe mode - Select shift + F8 during boot

    If you can't get to safe mode using Shift + F8 do the following.

    a. Boot from the Windows 8 DVD
    b. Select Next
    c. Select Repair your computer
    d. Select Troubleshoot\Advanced Options\Command Prompt
    e. Type - Bcdedit /set {bootmgr} displaybootmenu yes
    f. Type exit
    g. Reboot
    h. At the boot screen select F8
    i. Select Safe mode with Networking

    2. Check the status of the adapter and record any errors
    3. Go to C:\Windows and find ntbtlog.txt. Post this here.

    Please make sure to identify which ntbtlog.txt is from safe mode.

      My System SpecsSystem Spec

  2. #82

    Posts : 1,851
    8250 x86 + 7 SP1 x86 + Ubuntu 12.04 LTS x86

    Quote Originally Posted by Calico View Post
    Moving on, after you merged the data GMan gave you, the code change to 31. This code is telling us Windows couldn't load the drivers, which may mean they're the wrong drivers.
    My thought on this at this point is that everything was now set to go well, but perhaps the service itself was not installed and ready to use: RTL8023XP

    To try starting it manually:

    net start RTL8023XP

    Prateek, did you download this Windows 8 .iso you're installing from, from Microsoft's server? If not, then someone hacked the .iso and that's the cause.

    Other than that, I've given all I know to this thread. If the driver is not installing well and easily on a clean Windows, there is a funk somewhere in the chain, obviously.

    It's not Windows 8, as said many times before. Best of luck with everything.
      My System SpecsSystem Spec

  3. #83

    i have down loaded the windows 8 iso from microsoft .... so it's the original one
      My System SpecsSystem Spec

  4. #84

    now i think i should follow the instruction of clico .. may be that will help ..
      My System SpecsSystem Spec

  5. #85


    i am posting the boot log as you asked me to ... the one with capital N was log in normal mode and the other with S is safe/networking mode ..
    Driver realtek RTL 8139 Attached Files
      My System SpecsSystem Spec

  6. #86

    Gman i guess you guys all are software genius . i hope you guys find out something for guy's like us .. who do not know anything about software and other things.. i hope .. you can understand our feelings ..
      My System SpecsSystem Spec

  7. #87

    Posts : 1,851
    8250 x86 + 7 SP1 x86 + Ubuntu 12.04 LTS x86

    Quote Originally Posted by prateek3651 View Post
    Gman i guess you guys all are software genius . i hope you guys find out something for guy's like us .. who do not know anything about software and other things.. i hope .. you can understand our feelings ..
    If I had access to the machine physically, one way or another, I'd have it running in no time. To be honest though, in all my years of helping people and doing my own machines, I've never seen anything like what is happening here.

    I already said many times what I think could be affecting things, and that is the bios. For one, the DMI Pool needs to be cleared and I'm not very confident that it ever has been done, based on responses. And for two, code 10 can easily happen as said, because there are no more hardware resources to use. An excellent reason why this could be happening on your 8 but not 7 is that in 8, some feature could have a driver installed and activated that your 7 does not.

    Moving on - you might try your luck by having the first driver ever in this thread extracted and ready on a USB stick, CD, DVD or your Windows 7 partition or drive.

    Then, go to clean install Windows 8. When it first reboots during install, access the device manager in the method shown below, to install the Realtek lan driver at that point:

    Device Manager - Access During Windows 7 Installation - Windows 7 Forums

    Installing the Realtek driver then might give it priority over others and force it not to give code 10 when at desktop.

    But to repeat it all - must disable all unnecessary stuff in bios like serial/parallel ports etc....and clear the DMI pool too.

    You're also welcome to take some screenshots of your Windows 7 device manager Realtek property tabs and the device manager itself, so we can see those.
      My System SpecsSystem Spec

  8. #88

    Posts : 828
    Windows 7 x64 Ultimate/Windows 8.1/Linux

    I pretty much agree with GMan. From what I can see, the driver is not the issue. It seems more likely there's an incompatibility between your motherboard/BIOS (out of interest, what is the motherboard/BIOS) and Windows 8. The problem, as I mentioned earlier, Device Manager Code 10 errors are really quite useless, all they tell us, is that 'something' didn't do what it should have. Most of the time, the 'something' is the driver, either being the wrong type, outdated or corrupted. Unfortunately, in this case, we know the driver works, so something else is causing the adapter to fail initialisation. And therein lies the mystery.

    It could be a resource issue, but in that case, I would have would have expected a Code 12 error message, however, one thing you might try, if possible. If your motherboard has on on-board graphics chip, it may be worth removing your main card and enabling the on-board. See what happens...

    You could also try the process GMan mentioned above, by installing the driver during the boot process. Certainly a change of priorities may well work.

    In the end, it may simply come down to a simple clash between something on your system and Windows 8. If you can borrow a network card for a short time, it would be well worth testing.
      My System SpecsSystem Spec

  9. #89

    Posts : 1,851
    8250 x86 + 7 SP1 x86 + Ubuntu 12.04 LTS x86

    Quote Originally Posted by Calico View Post
    It could be a resource issue, but in that case, I would have would have expected a Code 12 error message
    Many, many years ago I had a motherboard which was making code 10 for a device happen and device manager said it couldn't find resources. Disabling the unused parallel and serial ports in the bios immediately fixed it all up.
      My System SpecsSystem Spec

  10. #90

    i tried installing new network card on mother board , as soon i attached it the board and try to run system .. my display was gone i removed boot again .. ans what i see it's working .. my board is not accepting the new pci .. network card ..Click image for larger version
      My System SpecsSystem Spec

Page 9 of 10 FirstFirst ... 78910 LastLast
Driver realtek RTL 8139
Related Threads
After installing W8 on a Toshiba satellite laptop, all went well except Realtek AC97 won't install. Re-installing the driver didn't work. Windows reveals a code 10 and mentions the driver did not install correctly. Naturally there are no sound devices present with this occurrence. Plugging in...
Realtek or AMD Audio Driver in Sound & Audio
What would be a better option for a Sound Driver? I used to have "Realtek High Definition Audio Codec" when I used Windows 7, but a few months ago I installed Windows 8.1 and just kept the generic "AMD High Definition Audio Device". Haven't really noticed that much of a difference. That's why I...
Realtek RTL8139 driver bug. in Drivers & Hardware
Hello, I have a Realtek RTL8139 card wich works perfectly on windows 8. But when I upgrade to Windows 8.1, the card stops working, in the Device Manager the driver have one yellow mark on it and says: "Code 12: Insufficient Resources" something like that. Anyone can help me please, I'm back...
Hello My MB has ALC898 audio chip. Should I stay with the default Windows 8.1 HD audio or install the driver from Realtek (which is R2.71 the latest version) My system is used for gaming BTW. Thanks.
Realtek ALC660 driver in Sound & Audio
Hi, I have tried to install the latest realtek driver R 2.71 and the installation went smooth. But after that my speakers sound was crackling. My hardware id is HDAUDIO\FUNC_01&VEN_10EC&DEV_0660&SUBSYS_10430000. Can you provide a solution to this problem or another driver? My OS is Windows 8...
I installed Windows 8 Enterprise today for testing purposes, I did it for my father too, and I was happy seeing, how well it works. So I did the same on my PC too, but I have one serious problem. I can't install the audio driver at all! When I try to install it starts installing it, it copies...
Thanks for anyone, who helps me :D I have "an old fashion motherboard,, with realtek's VT1818S High Definition Audio 8-Channel soundcard build in to the Asus m4a77 motherboard. Usually with W7 windows i had to install the driver from asus's website... so far when i get to the installation point it...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook