Windows 8 and 8.1 Forums


Problems unfolding with todays updates. Why me again ?

  1. #1


    Posts : 562
    W10 x64 pro and W8.1 x86

    Problems unfolding with todays updates. Why me again ?


    Today I installed all the offered updates, seven security in total I think plus an optional. I Iooked in detail at the notes for each and saw nothing alarming.

    First unexpected happening was the appearance of a new 'Browser Choice' tile on my start menu. Right click and its gone, OK, can live with that.

    After another reboot and having let things run for 30 minutes or so I do a disk clean, a reboot and a defrag. All seemed fine and then I notice the live weather tile is just blue. Opening the app also gives just a blue screen. Brilliant !!!!!

    For curiosity I start uninstalling the updates and find that uninstalling the IE11 cumulative breaks the app even more... if that is possible. Now opening the app reverts me to the desktop, however I can see the weather app icon in the tray. Clicking that to expand it opens to the blue screen and then automatically reverts back to the desktop.

    So its all well and truly pancaked... yet again. Thank you Microsoft.

    I'm not even going to attempt to troubleshoot this as I have become thoroughly disillusioned with what was a superb OS. I have a suspicion that all the W10 stuff over the summer has also played its part in making what was once a snappy and responsive OS become somewhat less so. That's very hard to pin down and hard to say for sure... but I have a plan. I'm going to nail this once and for all and know for sure.

    I've picked up from a disk image from May this year and turned OFF Windows Update. Defender is updated as always via an automatic task. I'm going to see how this feels and responds compared to how its been the last few weeks. There has been this indefinable lack of sparkle to its performance of late.

    I would like to add some updates manually but I'll image the disc (as I always do) first. Flash player updates and IE11 cumulative come to mind but I might skip this months IE11 one and go back to September.

    Watch this space

      My System SpecsSystem Spec

  2. #2


    Yep, same here in regards to the weather app (blue screen with constant loading spinner). Wondering if this could be related to a server issue causing an updating snafu. I'm still getting the weather tiles but it doesn't seem to be updated. Shows yesterdays temperatures...
      My System SpecsSystem Spec

  3. #3


    Posts : 562
    W10 x64 pro and W8.1 x86


    The weather app on my restored image is working fine.

    Off the wall question... do you have LibreOffice installed ? as that has caused issues in the past with W8.1
      My System SpecsSystem Spec

  4. #4


    Nope, don't have Libre Office installed.

    I'm probably going to hold off on reinstalling a recent image to fix this minor inconvenience of the malfunctioning weather app unless, of course, I am faced with a multitude of other issues. So far, it's only been this particular app that seems to be acting a bit nutty. Perhaps MS develops patch or it miraculously fixes itself. Whatever the case, its something I can live with at the moment.

    Cheers.
      My System SpecsSystem Spec

  5. #5


    Posts : 79
    Windows 8.1


    The weather app issue is quite common for those not on Windows 10. It doesn't seem to have anything to do with LibreOffice, as far as I can see. Here is a thread on the MS site with many people also facing this issue. On that thread, there are some workarounds, although not everyone has success with them, or that they work only until you restart the machine. There was some speculation that an MS security update in late September might have broken it, but that's speculation. Still, MS need to fix this, and their silence is deafening...
      My System SpecsSystem Spec

  6. #6


    Posts : 562
    W10 x64 pro and W8.1 x86


    Quote Originally Posted by HelloItsMeAgain View Post
    Nope, don't have Libre Office installed.
    Thanks, it was worth asking. Hope you do get it sorted or even better, that MS acknowledge the problem and offer a fix.

    Gort... thanks for the link. A lot to read in all that ! All I can say is that in my case it failed yesterday following install of the latest round of updates. Coincidently I hit a similar issue a few days ago when rebuilding a 'clean' image.... and I know you replied to that thread.

    So something is going on, something that seems to affect different setups in different ways.
      My System SpecsSystem Spec

  7. #7


    Thanks for the link, Gort.

    Yep, it does sound like this problem with the weather app comes in waves for Win 8 users with different setups. The issue sounds similar to apps installed on a smartphone where a version update is available that supposedly improves functionality such as adding features or fixing problems but ends up breaking the app due to some bug in the software.

    We'll see how long it takes MS to update the app.
      My System SpecsSystem Spec

  8. #8


    Posts : 562
    W10 x64 pro and W8.1 x86


    One discovery I made. The 'configuration' folder mentioned in the long MS thread only appears from the end of September onwards. I've been able to look back through month end backups (mounting them with Acronis to browse the files and folders). Before this date and its not present.
    Attached Thumbnails Attached Thumbnails September.PNG   October.PNG  
      My System SpecsSystem Spec

  9. #9


    UK
    Posts : 275
    Windows 8.1 64 bit


    Yep, the Weather App stopped working on my PC - another fine example of Microsoft QA.

    I tried the fix recommended in the above link which worked for me. Here is the fix:

    Go to your User AppData folder for the Weather App configuration e.g.:

    %localappdata%\Packages\Microsoft.BingWeather_8wekyb3d8bbwe\LocalState\Configuration

    There should be just one file configuration_3.0.4.366.sqlite. Rename that file configuration_3.0.2.258.sqlite
      My System SpecsSystem Spec

  10. #10


    Posts : 79
    Windows 8.1


    Yeah, that does work, although some complain that after a few starts it reverts back to broken. I've had it like that for a couple of days, doing a couple of restarts and a couple of starting from shutting down, and it seems to be still working. Worth a try if you want to use the app.

    Mind you, any more of this, then I'll just go back to using a bookmark of the BBC weather page for my local area, which is probably just as fast to access, at least when I'm using a browser.
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Problems unfolding with todays updates. Why me again ?
Related Threads
Yet more weirdness from MS. An hour ago a warning popped up (action centre) reporting Defender was out of date. I haven't missed an update as can be seen. Why Defender itself reports the definitions as created on the 4th Aug I have no idea unless that was the last time they changed from MS. The...
Solved Several problems since installing five updates in Windows Updates & Activation
I installed five updates on 15/09/2014. (Updates: KB2995004, KB2993100, KB2990532, KB2979582, KB2975719) When I tried to print a document today I noticed that my default printer was missing. It appeared in the list of installed Printers (Control Panel) but not the dialog box. I restarted my...
Hey guys , as the title already mentions I'm experiencing some hard issues with new windows updates. So, yesterday I wanted to refresh my updates via Windows Updates. Everything worked fine before but afterwards everything just went wrong. After I installed the new updates i couldn't login in...
Hello there My computer is messed up a bit, and i can't find any solution for these problems by myself, so i decided to request help here, hoping someone can. So my first problem is that i cant install any update from Windows Update nor ones that i tried to install manually. Usually i have...
Hi guys, recent errors have come up in my system and I'm not sure what the cause is or the best way of fixing it. If I run sfc /scannow I get either this: http://img855.imageshack.us/img855/5637/6du9.png Or after restarting/shutting down some other message telling me a system repair is...
I've been having some problems after installing some updates. For example, after installing these updates, every time I run uTorrent, I get a Blue Screen of Death, almost instantly. The problem is not with the software because I always used the same and nothing ever happened like that. The Blue...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook