Hello,
I recently bought a new MSI laptop running Windows 8.1. However, every time I open Windows Update, it sits there like this
After a while, it will eventually load. However, when I press "install updates", the green bar starts to move then freezes indefinitely. I checked Event Viewer and it states the following errors:
Log Name: System
Source: Service Control Manager
Date: 7/26/2015 4:12:19 PM
Event ID: 7024
Task Category: None
Level: Error
Keywords: Classic
User: N/A
Computer: Chris
Description:
The Background Intelligent Transfer Service service terminated with the following service-specific error:
The system cannot find the file specified.
Event Xml:
<Event xmlns="Bad Request
<System>
<Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" />
<EventID Qualifiers="49152">7024</EventID>
<Version>0</Version>
<Level>2</Level>
<Task>0</Task>
<Opcode>0</Opcode>
<Keywords>0x8080000000000000</Keywords>
<TimeCreated SystemTime="2015-07-26T20:12:19.949551500Z" />
<EventRecordID>82467</EventRecordID>
<Correlation />
<Execution ProcessID="772" ThreadID="10592" />
<Channel>System</Channel>
<Computer>Chris</Computer>
<Security />
</System>
<EventData>
<Data Name="param1">Background Intelligent Transfer Service</Data>
<Data Name="param2">%%2147942402</Data>
<Binary>42004900540053000000</Binary>
</EventData>
</Event>
And
Log Name: System
Source: Microsoft-Windows-Bits-Client
Date: 7/26/2015 4:12:19 PM
Event ID: 16392
Task Category: None
Level: Error
Keywords:
User: SYSTEM
Computer: Chris
Description:
The BITS service failed to start. Error 0x80070002.
Event Xml:
<Event xmlns="Bad Request
<System>
<Provider Name="Microsoft-Windows-Bits-Client" Guid="{EF1CC15B-46C1-414E-BB95-E76B077BD51E}" />
<EventID>16392</EventID>
<Version>0</Version>
<Level>2</Level>
<Task>0</Task>
<Opcode>0</Opcode>
<Keywords>0x8000000000000000</Keywords>
<TimeCreated SystemTime="2015-07-26T20:12:19.948551000Z" />
<EventRecordID>82466</EventRecordID>
<Correlation />
<Execution ProcessID="1036" ThreadID="9644" />
<Channel>System</Channel>
<Computer>Chris</Computer>
<Security UserID="S-1-5-18" />
</System>
<EventData>
<Data Name="ErrorCode">2147942402</Data>
</EventData>
</Event>
And
Log Name: System
Source: Microsoft-Windows-DistributedCOM
Date: 7/26/2015 4:12:19 PM
Event ID: 10010
Task Category: None
Level: Error
Keywords: Classic
User: SYSTEM
Computer: Chris
Description:
The server {4991D34B-80A1-4291-83B6-3328366B9097} did not register with DCOM within the required timeout.
Event Xml:
<Event xmlns="Bad Request
<System>
<Provider Name="Microsoft-Windows-DistributedCOM" Guid="{1B562E86-B7AA-4131-BADC-B6F3A001407E}" EventSourceName="DCOM" />
<EventID Qualifiers="0">10010</EventID>
<Version>0</Version>
<Level>2</Level>
<Task>0</Task>
<Opcode>0</Opcode>
<Keywords>0x8080000000000000</Keywords>
<TimeCreated SystemTime="2015-07-26T20:12:19.946542400Z" />
<EventRecordID>82465</EventRecordID>
<Correlation />
<Execution ProcessID="940" ThreadID="3284" />
<Channel>System</Channel>
<Computer>Chris</Computer>
<Security UserID="S-1-5-18" />
</System>
<EventData>
<Data Name="param1">{4991D34B-80A1-4291-83B6-3328366B9097}</Data>
</EventData>
</Event>
I have already run System File Checker via Command Prompt but it detected no integrity violations. I also ran Chkdsk and after a few seconds it said "Windows has scanned the file system and found no problems. No further action is required" I have been searching around the web for solutions to this problem but none of them have solved my problem. Any help would be appreciated. Thank you