Windows 8 and 8.1 Forums


'more information' shows 'this page doesn't exist'

  1. #1


    Posts : 176
    Windows 8.1 update 1

    'more information' shows 'this page doesn't exist'


    Before installing 'optional' update I like to know what they will be doing, but for the last few weeks I keep getting 'this page doesn't exist'.

    Are Microsoft pages securely protected and that is why I am having problems, could some security software stopping the pages from opening?

    I turned all security software off to see if that would do the trick, but it didn't.

    All other pages open fine when I'm browsing so why don't the Microsoft pages?

    Or could there be something that I've forgotten about that is causing these pages not to load correctly, but why only these Microsoft pages?

    All help will be greatly welcomed.

      My System SpecsSystem Spec

  2. #2


    What browser are you using? Also, you should re-install it if it's not IE.
      My System SpecsSystem Spec

  3. #3


    Posts : 176
    Windows 8.1 update 1


    Instead of resetting Firefox, I started it in 'safemode' and it's still the same.
      My System SpecsSystem Spec

  4. #4


    Posts : 79
    Windows 8.1


    Yeah, I've been witnessing this. However, after a few more goes, the page does turn up. It's probably just server overload. Annoying, to say the least.
      My System SpecsSystem Spec

  5. #5


    Posts : 123
    Windows 8.1


    Go to the bottom of the page and click on the link 'United Kingdom - English' then change to 'United States - English'.
    I presume that changes to US servers.
      My System SpecsSystem Spec

  6. #6


    Posts : 176
    Windows 8.1 update 1


    Quote Originally Posted by Helmut View Post
    Go to the bottom of the page and click on the link 'United Kingdom - English' then change to 'United States - English'.
    I presume that changes to US servers.
    Pages are loading with no problems today, don't know why.

    I've tried quite a few and they all seem alright now.
      My System SpecsSystem Spec

'more information' shows 'this page doesn't exist'
Related Threads
I'm checking some hidden optional updates and I want to get some information about them, but each one comes as 'This page doesn't exist'. Is anyone else having a problem or is it just me, and if it is, why? Thanks
So i have another problem. I'm using built-in Admin so i enabled User Access Control: Admin Approval Mode For built in Administrator account and edited HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\UIPI\Default as 0x00000001 (1) to be able to use metro apps on...
My ADSL modem starts up and operates correctly. However, every time the PC and modem boot from cold, the Chrome browser starts and shows the error nag screen shown below. All is OK when the modem is fully booted. How can I stop this nag screen appearing? 59905
I got this error message: Print processor doesn't exist in my Win 8.1 x64 system. Per suggestions found on the net, I checked that winprint.dll is present in Windows\System32\spool\prtprocs\x64 Another tip that I've found ...
It has been almost impossible to look at a web page that has a slide show on it, every time I click on next it has to reload the whole page which takes forever to finish before I can click on next again and move on to the next slide. I have tried the same web page in Chrome and on Safari and the...
Hello experts. Every time I reboot my Windows 8 machine, I get the following message. 35886 It's a little bit crazy, because I don't have a folder called 'Conduit' on that path. 35887 Any thoughts anyone??? Thanks!!!
Hello, for the last few days I have had a bit of trouble with my network connection on my laptop. I recently moved up to my college and am now on their network. However, I didn't have this problem at first. But recently if I go to my network connections, there is always a wired connection listed...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook