Windows 8 and 8.1 Forums

Update for Intel Storage Controller Failed 3 times so far.

  1. #1

    Update for Intel Storage Controller Failed 3 times so far.

    Today I got the subject "Important" U/D from MS which has failed 3 times.

    The full name of the U/D is as follows:

    Intel Corporation - Storage Controller - Intel(R) 7 Series/C216 Chipset Family SATS AHCI Controller

    I finally marked to HIDE. Is there a solution??


      My System SpecsSystem Spec

  2. #2

    Posts : 1,950
    windows 8.1 Update 1 Pro 64bit

    Go to Intel's website and see if this is really the driver update required. If it is you can download it from there.
      My System SpecsSystem Spec

Update for Intel Storage Controller Failed 3 times so far.
Related Threads
I am struggling to find any working Windows 8.1 x64 drivers for an Intel 82541ER Ethernet Controller. Any help or ideas much appreciated. Greg
I have an HP EliteBook 8760w laptop (XU099UT#ABA) running Windows 8.1 64-bit with an Intel hardware RAID 0 array that contains two 750 GB WD hard drives (WDD7500BPKT-75PK4T0). I just upgraded the Intel RST driver to the latest version ( I recently discovered that if I go into the...
Hello, Sorry for posting Windows XP related stuff, But for this one time I have a question about the screen resolution, I can't go further than 800x600, I'm using the lasted driver from the Intel site.. Specs of this very old machine: - Pentium III @1.00Ghz - 256MB SDRAM - Windows XP Pro...
Hello eightforum users, i Got an really big problem.. i just reinstalled my PC, obviously with windows 8. and i cant seem to play games, i mostly play COD4 and whenevery i join a game, i get an Dirextx error, or my PC just reboots.. i dont know if it has something to do with my LPC INTERFACE...
I have tried everything that I know how to do to find this with no success. I have a dell precision m4600.
Hi, I don't know what happened, I was wanting to get AHCI working in Windows 8 but someone had suggested to change a Windows registry setting and I did so so now it is no longer listed. Long story short, I don't know how I can recover these settings without a backup. And I don't have one!!! :-|...
I've tried 5 times now to upgrade from 7 to 8 Pro. 4 times I tried using a USB image and the last time I tried using Windows' downloadable installer. Each time, the install completes and right after the restart for first boot it begins to load Windows and then blue screens, saying...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook