Windows 8 and 8.1 Forums

DISM error reported but no obvious side-effects noticed.

  1. #1

    DISM error reported but no obvious side-effects noticed.

    To be honest, I'm not really certain if I have a problem or not but, I'm just curious more than anything else. Like many on here, I couldn't get the KB2919355 update to install but I resolved it by deleting the contents of C:\Windows\SoftwareDistribution\Download. Everything is working fine and I'm receiving all the new released updates - hence the topic title no obvious side-effects noticed.

    But (isn't there always a but), DISM is still reporting errors. Scanhealth reports that the errors are repairable but restore helath fails with error 0x800f081f. SFC/Scannow reports no errors.

    The strange thing is that I've looked at the log file and I can see no apparent errors reported. I've posted an extract below from one of the sections which shows (I think) that everything is fine and dandy.

    Operation: Detect and Repair
    Operation result: 0x0
    Last Successful Step: Entire operation completes.
    Total Detected Corruption: 0
    CBS Manifest Corruption: 0
    CBS Metadata Corruption: 0
    CSI Manifest Corruption: 0
    CSI Metadata Corruption: 0
    CSI Payload Corruption: 0
    Total Repaired Corruption: 0
    CBS Manifest Repaired: 0
    CSI Manifest Repaired: 0
    CSI Payload Repaired: 0
    CSI Store Metadata refreshed: True

    The only thing that sticks out is a warning which appears a number of times:
    2014-05-18 22:12:33, Warning DISM DISM Provider Store: PID=5308 TID=7148 Failed to Load the provider: C:\Users\Steve\AppData\Local\Temp\0E0BB710-76C3-48A5-A9A0-CF74C1A27460\PEProvider.dll. - CDISMProviderStore::Internal_GetProvider(hr:0x8007007e)

    So in summary, I can't be certain that I have any corruption problems and with a fully updated syatem everthing appears to be as it should be.

    To satisfy my curiousity, is there any logical explanation for this and am I missing something obvious


      My System SpecsSystem Spec

  2. #2

    Barney, from what I understand, if SFC /scannow is not showing any integrity violations, you're ok. I have a similar problem, in that DISM says errors are repairable, but can not find the source files. Like you, my log shows no corruption. I've been told by several forum members, not to be concerned about it. (But I still don't like it) I have this situation on both a laptop (only recently started doing this) and a desktop, so it evidently is common. I know this isn't an answer to your problem, but hope it relieves your concerns a little.

    See these threads. one here and one at Sysnative Forums

    SFC Scannow and DISM Results Clarification

    [SOLVED] DISM Scan Problem Windows 8.1 - Sysnative Forums
    Last edited by JohnBurns; 30 May 2014 at 09:30.
      My System SpecsSystem Spec

  3. #3

    Thanks John for your reply. My situaion is exactly the same as yours and as I'm guessing none of yoiur computers have gone up in a ball of flames, I'll stop worrying
      My System SpecsSystem Spec

DISM error reported but no obvious side-effects noticed.
Related Threads
I have two operatings systems. Windows 7 on one drive and Windows 8 on the other. I have a program called PowerDirector 11 installed on the Windows 7 drive. I went to install the said program on the Windows 8 drive, (to be able to access it from either drive) and when I try to open or run the .exe,...
Error Code 0x800f0906 When Trying to Use Dism in Performance & Maintenance
Hello. I am having an issue when trying to run the "Dism /online /cleanup-image /restorehealth" command in an elevated command prompt in Windows 8.1. Whenever I attempt to do so, it fails and returns: Error: 0x800f0906 The source files could not be downloaded. I have ran the command several...
DISM and SFC error, 0x800f0906 in Performance & Maintenance
Heya all! Recently I got problems when running SFC or DISM to repair my system. As far as I know it concerns the shortcuts in the folder Administrative Tools, there I changed under Properties the Run option to Maximised Windows and since then SFC and DISM have shown this error that the services...
Hi, I've been having many problems with my comp, and I think many of them can be attributed to my HDD. Not sure whether or not it's corruption or a failing disk or what have you, but I tried to do the sfc /scannow command and the Dism /Online /Cleanup-Image /RestoreHealth command and neither...
dism error 87 in General Support
every time I get this "DISM.exe / Image: F: \ 7work \ WIM / Add-Package / Package Path: F: \ 7work \ LP \" try to run I get an error situation. error 87? What should I do now. I have so many looked on google but I'm desperate. thanks (google translate)
Hello Everyone: I am trying to install Dragon Naturally Speaking 11 to my Windows 8 Machine It was installed at one time. Then, I got a wierd dialog box from Office 2013 that asked me if I wanted to do something to...I don't even remember what it said. I clicked yes to it because I was...
The application has failed to start because its side by side configuration is incorrect. Hi everyone this is an error I'm getting with my new computer while trying to run a program. Is there something I can do to fix this?
Eight Forums Android App Eight Forums IOS App Follow us on Facebook