Windows 8 and 8.1 Forums

Stuck on "reverting changes" for four hours. Please help!

  1. #1

    Stuck on "reverting changes" for four hours. Please help!

    hey all. my husband and i recently got an asus tf810c windows 8 tablet and it has been really frustrating!

    we bought it from amazon, we switched it on, set it up, but when we came to update it, it would hang on 0% all night, not changing. after numerous troubleshooting steps and fixes, we ended up getting it to install and then it went to configure windows, but ended up failing and reverting changes.. we gave up with the tablet and requested a replacement, which we received today.

    the replacement...has exactly the same problem. i managed to get it to update first time though, but then once again we are stuck on "reverting changes" and have been for the past 4 hours!! we even spoke to asus tech support and the guy was unable to resolve our issue. he told us to switch it off, reset it, but every time it would come back on to the same screen. since we don't have a keyboard/dock, we can't press any buttons to get past this screen. we're stuck at it.

    if anyone could please help us out it, that would be really appreciated! i need this tablet for work haha

      My System SpecsSystem Spec

  2. #2

    Posts : 30
    Windows 8.1

    Hi! Try and install the updates and most importantly BIOS updates from the manufacturer's website. These may allow you to progress with your updates.
      My System SpecsSystem Spec

Stuck on "reverting changes" for four hours. Please help!
Related Threads
Hi all, So I'm kind of stuck.. I currently have the problem where I am in an endless cycle of "loading files" -> "Windows Boot Manager" (see: How To Boot Into Safe Mode On Windows 8 (The Easy Way)). I have tried to load all of the options -- and none successfully load. I also end up at...
So i just got a new MSI Laptop and i downloaded some games from steam and you know that kind of stuff. Then i had to download windows 8.1 (not from disc) and then it started downloading normally and then all of a sudden this "Failure configuring windows features Reverting changes" popped up and...
So I restored my system because I had no other choice from it not booting before and it was working for a day, then when I restarted it said 'installing XX / 93 updates' so I let that run, and when It finally finished, it restarted said 'configuring windows updates XX% complete...' and then it...
FIle history stuck in "Restore in progress" in Performance & Maintenance
I have build a new pc, went to turn on File History and set it up and it began to restore from an old build. It is not restoring (and i don't need it too) but it is stuck. It won't turn off, or finish or fail. Been weeks now. The location does exist, but regardless, I have deleted the files...
Good Day People, I have a little problem with my computer and its running right now on windows 8.1, When i tried to switch other profile from my main profile i will stuck on the scree "Please wait" i've tried to wait for it for a day and its still stuck on that screen and i am forced to manually...
After I installed Windows 8 I started having the "0 KB Total, 0% Downloaded" issue while attempting to update, sometimes it does work, but most of the time it doesn't
It's been there for literally over a day. At first it appeared to be using the hard drive now it's just sitting there being pretty. Trying to go from CP to RP btw. Wow literally 3 minutes after I posted this it just decided O LOL I SAW YOU POST SO IM GONNA WORK NOW. and it worked...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook