Windows 8 and 8.1 Forums

Remote Procedure Call is Stopped After Any Update!

  1. #1

    Posts : 9
    Windows 8.1 Pro

    Remote Procedure Call is Stopped After Any Update!

    Hi im new here and this is my first post. I am a MCP, MCTS, MCSA, N+, and A+.

    This is not for work its my personal PC.

    I have been having a problem with Windows 8.1 Pro for a few months now. Every time windows, java, drivers, or anything updates and the PC is restarted, after login, it acts as though its a fresh install. When everything is loaded, the start window is blank and so is the desktop. When I press the windows key, to go to desktop, there is an error. I can not remember exactly what it says but next time I update i will edit it in. It basically says that, "The desktop cannot be found." along with it listing the directory for it.

    So I searched for months and have not found a fix or a lot of people with the same thing. I did however get a clue about RPC (remote procedure call). I figured out a quick fix for this but every time there is a new update its back to the beginning. These are the steps I take

    press windows key to view desktop
    close all errors
    Services tab
    Find RPC (remote procedure call) witch will be stopped every time.
    Start the service (Witch appears to do nothing)
    Details tap
    Find explorer.exe and end the process
    Click File
    Run New Task

    After all of that the desktop starts to load and everything is back to normal except the appearance settings. I then restart the PC and as long as there is not other update in that time, Everything is just the way its suppose to be, appearance and everything.

    I tried just restarting Explorer.exe and it will just cycle and give the same error.

    I am sure yall can see how annoying the bug is. So if anyone has the same problem or a fix please let me know!



      My System SpecsSystem Spec

  2. #2

    Posts : 7
    windows 8.1 pro

    Have you tried changing the RPC service properties from manual to Automatic ? Could help .
    But most cases of RPC troubles are heavy malware infection wich stop the service even if windows starts it properly
      My System SpecsSystem Spec

  3. #3

    Posts : 9
    Windows 8.1 Pro

    yes i have tried changing it. I know its not malware. my system is very very secure and my server runs 2 am daily through scans on all my systems. The only thing i can find on it, is when it updates, there is a registry error for RPC and RPC locater. Apparently there was a bug from the windows 8.0 pro to 8.1 pro update than is causing this for a few people. however there is no fix yet, The only "fix" i can find is a batch file you can download that suppose to fix it. I scanned it and it was clean and it really did change some RPC registry values but did not fix it..
      My System SpecsSystem Spec

  4. #4

    Posts : 9
    Windows 8.1 Pro

      My System SpecsSystem Spec

Remote Procedure Call is Stopped After Any Update!
Related Threads
Hi guys. My SO is Win8 64 and I've accessing this pc almost everytime by remote desktop. From inside my network and from my work pc (port 3389 open). Last week, suddenly it stopped working. I didn't make any change. I have already tried to change the rdp port to 3391 but I'm still unable to connect...
I just got a new computer today. Yay! I have a little problem though. My old computer was running Win 8.1. The new Computer came with 8. I only have one monitor so I was using Remote Desktop to access the old computer and transfer things over. At some point I decided to upgrade the new one to 8.1....
Hi all, I have an Acer Aspire 5600u and the Win 8.1 update has pushed through and since my remote has stopped working, I have looked on their website and there is no updated driver for it. I have gone through device manager and scanned the internet for an updated driver but also no help. I...
Hello, I am experiencing some minor issues with my Graphics Card. Let me say first that this is an old graphics card, which was however updated to Windows 8. Today, when I updated the computer to 8.1, I came across a "Outdated Driver" error. On this computer, I have a ATI (AMD) Radeon 2400HD...
Hello all, I have two Win8 Pro x64 laptops and I always Remote Desktop into laptop #2. But since a Windows Update, Remote Desktop is always asking me for login credentials! :mad: Even when I select to Save the info, after I close Remote Desktop and then re-open it, it will again prompt me for...
Read more at: Microsoft: Don't call it Metro. Call it 'Windows 8' | ZDNet
Eight Forums Android App Eight Forums IOS App Follow us on Facebook