Windows 8 and 8.1 Forums

Windows Update fails -- corrupted files?

  1. #1

    Posts : 4
    Windows 8.1

    Windows Update fails -- corrupted files?

    About half a year ago, give or take, I ordered a Windows 8 OEM disk to install on my laptop. Machine runs fine, even upgrading to the 8.1 Preview and eventually to 8.1, and dual-booting Ubuntu GNOME. Life is good.

    The most recent system update, however, continuously fails for some reason, giving me no error messages.
    I've tried running sfc /scannow and DISM commands, but both of those fail, saying that there are corrupted system files preventing them from working.

    The normal way to fix corrupted system files with Windows 8 would be to Refresh. However, I can't refresh with my install disk because it's not an 8.1 disk. I've tried using the trick with creating a useable ISO file, but that trick fails because the Product Key I'm using is a developer's license, not retail.

    Any more ideas without starting from scratch? Thanks in advance.

      My System SpecsSystem Spec

  2. #2

    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64

    1. Delete everything under: C:\Windows\SoftwareDistribution\Download
    2. Re-run Dism first:
      dism /online /cleanup-image /restorehealth
    3. Then run: sfc /scannow
      Note: You might have to run sfc multiple times until you get a clean message
      My System SpecsSystem Spec

  3. #3

    Posts : 4
    Windows 8.1

    1. Completed
    2. Stays at 20% for about 10 minutes, then says that the repair source could not be found (error code 0x800f081f)
    3. No errors, for some reason

    Is it an installation CD that DISM is looking for? This is a bit confuising.

    EDIT: Tried installing update in question, it's been stuck at 3% for 20 minutes. Windows Update also claims that it has already failed once today.
    Last edited by Wyatt Conlaed; 06 May 2014 at 22:02.
      My System SpecsSystem Spec

  4. #4

    Posts : 7
    Windows 8.1

    You are not the only one experiencing this. I have the same problem and evidently many others do too.

    DISM /restoreHealth fails with 0x800f081f AFTER 8.1 update - Microsoft Community

    kb2919355 Component Store corruption - The Hotfix Share

    What is interesting is after running the "failed" command, the CBS.log indicates no problems were found.

    Operation: Detect and Repair
    Operation result: 0x0
    Last Successful Step: Entire operation completes.
    Total Detected Corruption: 0
    CBS Manifest Corruption: 0
    CBS Metadata Corruption: 0
    CSI Manifest Corruption: 0
    CSI Metadata Corruption: 0
    CSI Payload Corruption: 0
    Total Repaired Corruption: 0
    CBS Manifest Repaired: 0
    CSI Manifest Repaired: 0
    CSI Payload Repaired: 0
    CSI Store Metadata refreshed: True

    A poster in this thread indicates the command line error message is a bug but does not cite a source. Of course, not a peep from Microsoft.
      My System SpecsSystem Spec

  5. #5

    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64

    OK, let us try from the elevated command:
    1. Dism /Online /Cleanup-Image /StartComponentCleanup
    2. Dism /Online /Cleanup-Image /RestoreHealth
    3. SFC /scannow
      My System SpecsSystem Spec

  6. #6

    Posts : 4
    Windows 8.1

    DISM cleanup also fails. If it's really just a bug, then I'm over-reacting.

    EDIT 5/10: Apparently the update decided to work last night, because when I booted my laptop up this morning the update had installed... I'm leaving it up to a bug in the system. As a side note, is anyone having trouble with Silverlight?
    Last edited by Wyatt Conlaed; 10 May 2014 at 12:46.
      My System SpecsSystem Spec

  7. #7

    Posts : 4
    Windows 8.1

    Update 5/14/14

    Okay, so the update that's been causing all my problems has finally installed with no error, as have the most recent couple. I'm chalking this issue up to buggy software and an issue with the /sfc commands.
      My System SpecsSystem Spec

Windows Update fails -- corrupted files?
Related Threads
Solved SFC Scan Cannot Fix some Corrupted Files in Performance & Maintenance
Hi there. Not entirely sure if this is the right section to post in but basically I ran an SFC Scan and it reported that it couldn't fix some corrupted files. I was wondering if someone could help me fix this. I would attach the to this post but for some reason its not allowing me....
Windows update fails in Installation & Setup
I recently re-installed windows 8 regular on my ASUS X450LC laptop using the recovery media. I tried to upgrade to 8.1. It wont let me install 8.1 unless I do windows update. After running windows update, it says there are 100+ updates and takes close to 2 hours to download and update. At 98%...
Hello, today I am posting in the Eight Forums to ask about how to fix a corrupted looking Windows 8 start menu with no corrupted files found. I know that's a really bad way to explain the situation. I have uploaded a screenshot which I hope explains the issues. I wanted to add the blank squares do...
So my problem is that I wanna replace my modified imageres.dll files back to normal ones witch I have safe but it won't let me replace them, saying i dont have permission to do that, obviously because they are running with some program. When i installed this Mac OS theme and replaced original...
I just has a big issue with my computer at home and I had to backed everything up into a usb to make a clean install now the usb shows the same three files in pretty much all folders and I can't erase them and I can't see the rest of the files that are supposed to be in those folders.... I've...
Windows 8 Update Fails in Windows Updates & Activation
Hi all, I've run into the same problem twice now regarding windows 8 updates. Basically what happens is it will run an automatic update and restart, (even though I had them disabled, hell, I even selected it not even LOOK for automatic updates, yet it still automatically updated and restarted...)...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook