Windows 8 and 8.1 Forums


KB2919355 breaks down logon screen and lock screen

  1. #11


    Warsaw
    Posts : 14
    Windows 8.1 Pro x64 Update 1


    Cheers,

    I spent 2 hours on the call with MS, the reason was old graphic driver for ati radeon and wrong method of gpu swiching.

    Solved by updating ati drivers to the lastest BETA (!) from amd.com, then setting up gpu switch method to manual or based on power source, then switch to high performance gpu and reboot. Solved in my case.

      My System SpecsSystem Spec

  2. #12


    Posts : 4
    win8.1


    Could you be more specific aboout the solution?
    I seem to have the exact same problem.
      My System SpecsSystem Spec

  3. #13


    Warsaw
    Posts : 14
    Windows 8.1 Pro x64 Update 1


    Sure. If you have notebook with ATI Radeon:

    1. Perform complete uninstall of any AMD graphic drivers (also Catalyst Control Center).
    2. Download beta drivers 14.4 (or 14.3 if you find somewhere):
    2a) 32-bit Windows 7 or 8: Desktop
    2b) 64-bit Windows 7 or 8: Desktop
    3. Install them.
    4. reboot and go to catalyst control center, then go to GPU switch mode and select "based on power source or manually". After several screen blinks and about 20 seconds, click on "High performance GPU".
    5. Lock you notebook or reboot to see whether background is that one you selected.

    If you have a desktop computer: just install lastest beta drivers for Radeon.

    If you don't have Radeon GPU, maybe you need to try with NVidia lastest beta drivers.
      My System SpecsSystem Spec

  4. #14


    Posts : 4
    win8.1


    I have a Radeon HD 7600M Series GPU on my Samsung Laptop (also Intel HD4000 GPU).
    I already have the Cat 14.4 beta Driver installed ( I got that from your post).

    The driver works fine. I didn't try setting the Default to Radeon GPU yet. Will try that next.

    Thanks, I'll let you know how it goes.
      My System SpecsSystem Spec

  5. #15


    Posts : 5
    Windows 8.1 Pro


    I've installed the 14.3 and it doesn't resolve the issue. Maybe I'll try the 14.4
      My System SpecsSystem Spec

  6. #16


    Posts : 2
    Windows 8.1


    Hi.

    There is no GPU switch mode with Samsung NP350E7C-S07PL (Radeon 7600m, Intel 4000) and Catalyst 14.4.
    Any other solutions?

    See the screenshot.

    Click image for larger version

    And another funny thing (in Polish):

    Click image for larger version
      My System SpecsSystem Spec

  7. #17


    Posts : 4
    win8.1


    Now it works.
    Installed the newer Catalyst 14.4 RC1 drivers.
    That did the trick.
    Thank you for attention
    Last edited by Aufpassen; 25 Apr 2014 at 07:09.
      My System SpecsSystem Spec

  8. #18


    Posts : 2
    Windows 8.1


    Doesn't work for me.

    I've clean amd drivers with amd cleanup utility, then I've removed all Intel application.
    Then I've installed CCC 14.4 RC1 (~288MB), but Radeon needs Intel, otherwise Radeon don't work. And then lock screen was OK. (because all works on standard drivers).
    Then I've installed newest Intel 4000 drivers. After restart everything is at is was - lock screen is broken.

    I've attached cards properties, CCC and Intel infos (I can't change Intel info page nor card properties to English).

    Maybe Intel drivers/app is too new?

    Click image for larger version

    EDIT: And now it works. I update samsung recovery app and settings app with SW Update, and then I was forced to restart OS twice, so I did. And after restart logon screen display properly. Strange.
    Last edited by malcu89; 27 Apr 2014 at 07:05.
      My System SpecsSystem Spec

  9. #19


    Posts : 2
    8.1 Pro (Retail)


    So, I am having this same issue. I have tried the suggestions from this thread, but nothing has helped so far.

    I am using onboard/iGPU graphics from intel 4770k, and connect my monitor via HDMI port on the motherboard (ASUS Maximus VI Hero), with Windows 8.1 Pro x64. I was using nvidia graphics drivers when I had GTX780Ti installed, but I have removed that dedicated card and now only use the iGPU. I stopped using the dedicated card several months ago, so I do not think it is related to this problem, but it could be. I have run Display Driver Uninstaller in safe mode to try to remove any old remnants of my nvidia drivers that may have been causing the problem. I have completely removed all graphics drivers, then updated to the latest intel HD Graphics 4600 drivers, via Windows Update.

    As soon as I run the KB2919355 update (Windows8.1-KB2919355-x64.msu) and restart, I am stuck at logon screen (all black). Then I am forced to do a System Restore to revert the update, and everything is back to normal.

    I also tried to update my motherboard BIOS, but that did not seem to help. I have tried changing various settings within the BIOS (i.e. set default display device to "iGPU" instead of "Auto"), but none of these changes have helped.

    The only other thing that may be of interest is the fact that I was using modified imageres.dll for custom system icons. However, I do not think this is contributing to the problem. I have since removed/restored the imageres.dll and run sfc /scannow to restore any other system files that may have been altered. Additionally, my laptop, which is running Windows 8.1 x64 (non-pro), has the same modified icons and it has no problem with the update. Everything installs and works perfectly on that machine. (FWIW, that machine is running a dedicated nvidia graphics card (gt750 mobile), so is not using the iGPU like the desktop machine is -- since this is really the only significant difference between the two machines, it leads me to believe that the intel iGPU is not agreeing with the KB2919355 update)

    At this point I am running out of options. I am relatively computer-savvy and generally a good problem-solver, but I am stumped by this one. Any novel ideas or suggestions would be greatly appreciated!
      My System SpecsSystem Spec

  10. #20


    Posts : 4
    win8.1


    It is a graphics driver problem. I had that confirmed by Microsoft. You can install the updateŽif you use the right graphics driver beforehand. I have a AMD System so I cannot say which driver you need.
      My System SpecsSystem Spec

Page 2 of 3 FirstFirst 123 LastLast
KB2919355 breaks down logon screen and lock screen
Related Threads
So I disabled the lock screen as it's just another unnecessary click to login, but what I want to be able to do is customise the background image of the login/ctrl+alt+del screen. I know you can change the "accent" colour but I don't want to use a solid colour. How do I go about this?
My PC was working fine before today, until I used Ultra UXtheme patcher for Win8 x64 and then applied a custom VS for Win8. After a restart, Windows Explorer was not launching, so I opened task manager and did a sfc /scannow. After a reboot, I get to the Windows 8 boot menu (I have a dual-boot on...
Hello Friends, Similar issue was solved in this topic: https://www.eightforums.com/customization/33591-problem-changing-windows-8-1-lock-screen-image.html but it was only "similar". Let me descrive: I made a clean install of Windows 8.1 Pro x64 (system was not preinstalled on my Dell Vostro)....
Hi was wondering if others experience this. Trying to figure out the cause and if there is a fix. When I turn on or restart my computer after the teal windows logo with the spinning wheel the screen will flash off quickly then come back on black and then 10 seconds later show the lock screen. ...
Kind of screen glitch that appears before windows 8 lock screen appears at start /restart and a notable delay in starting/restarting time than with my 1st win8 install. I think this appeared after I installed my windows 7 back ( dont ask me why..)( a clean install) and installed my win8 back...
i m unable to change my windows 8 appearance as this menu is disable in my windows can anyone please help me as i m new to windows 8 ?
I upgraded from Windows 7 to Windows 8 Pro. Everytime or almost everytime I click on an app or go to the desktop and try to get on IE 10 (desktop version), my screen flashes and goes black for a few seconds then returns me to the screen with the space needle, then I click on it and it signs me...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook