Windows 8 and 8.1 Forums

WU KB 2876415 Fails

  1. #1


    Texas
    Posts : 1,022
    Windows 8.1

    WU KB 2876415 Fails


    Windows Update tried to install KB2876415, but threw a Code 80070002. I've retried, redownloaded, troubleshot, shut down, and so far, after four tries, I can't get it to install.

    Anyone know what the update is and why it refuses to install?

    Thanks in advance.

      My System SpecsSystem Spec

  2. #2


    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64


    1. Turn off any anti virus software
    2. Delete everything under
      C:\Windows\SoftwareDistribution\Download
      C:\Windows\SoftwareDistribution\DataStore
    3. from Command Prompt(Admin). Run: sfc /scannow
    4. Reboot and run Windows Updates
    5. If still fails. Download
      Download Update for Windows 8 for x64-based Systems (KB2876415) from Official Microsoft Download Center

      and try to install it manually
      My System SpecsSystem Spec

  3. #3


    Texas
    Posts : 1,022
    Windows 8.1


    Thanks, Top Gun. And now for the rest of the story . . .

    Windows Update keeps showing KB2876415, but when I tried the things you listed, and finally had to follow the link you gave, I was told the KB is already installed! So, I checked my updates and sure enough, there it is . . .

    And WU continues to insist that it needs to be installed.

    So, I guess it's about half solved?
      My System SpecsSystem Spec

  4. #4


    San Jose - California
    Posts : 2,847
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64


    You could try to download a trial version of Windows 8 Manager:
    Optimize Windows, Tweak Windows, Repair Windows, Clean Windows, Speed Up Windows - Yamicsoft
    And follow the steps from the screen shot below:

    Click image for larger version
      My System SpecsSystem Spec

  5. #5


    Texas
    Posts : 1,022
    Windows 8.1


    Thanks, Top Gun:

    I'll try it as soon as I can free up some time.
      My System SpecsSystem Spec

WU KB 2876415 Fails
Related Threads
Solved Browser fails x2 in Browsers & Mail
I have passwords saved on a Chrome account, and while attempting to log-in to a certain web site I was informed of a Sync data issue and would therefore have to enter my email address & password going into saved passwords via the settings menu I realised all saved passwords were gone. I have tried...
Running Windows 8.1 and File History was working OK for my computer, actually on two different computers worked just fine. (I never could get File History to work with Windows 8). Then suddenly this feature just up an quit. Got a little "red" flag in the Action Center. Using the control panel an...
Updates always fails in Windows Updates & Activation
I have just bought a new ASUS Transformer TX300 notebook on last Friday. I was very irritated about the poor performance of this i7 CPU notebook. The machine runned very lag and I have to wait even I just type something. (But at the very beginning when I tested the machine in the shop every...
Laptop: Dell Inspiron 17RSE 7720 | 3rdGEn i7 3610QM CPU | DDR3 2x4GB RAM 1600MHz | nVidia 3DVision Enabled 17-inch screen running on 2GB GDDR5 nVidia 650M GT (3D enabled with NO optimus) SATA Mode: AHCI Hard Disks: 1. 32GB mSATA boot drive (Only windows core files and programs installed on it)...
upgrade to win 8.1 fails in Installation & Setup
I bought a Win 8 Pro 64 bit upgrade dvd in order to upgrade from Win 7-64bit. After completion I downloaded win 8.1 pro upgrade from the store. At the end of the installation it says "getting devices ready". It starts the process showing the rate and it gets stuck at 6%. Turned off the laptop...
On the gaming PC that I'm fixing for my son's friend, the WEI fails to complete, and fails the "video" portion... could the old 9800 GTX 512MB video card be failing? I've installed the newest nVidia drivers and all seems to running well, but I can't use WEI to get a baseline before I start tweaking...
Autocheck fails in Performance & Maintenance
During start up I receive a message that windows can not find FbDraf.exe and it skips the auto check. This problem is familiar with other versions of windows and I believe it has something to do with a previous windows defrag program that didn't get uninstalled but still exist inside of the basic...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook