Windows 8 and 8.1 Forums

Kb2756872

  1. #1


    Posts : 3
    Windows 8

    Kb2756872


    Hi,

    I'm having a problem installing this update on my new laptop (It came with Windows 8, I haven't upgraded). I'm getting the error 80073718. I couldn't find much on the internet hence the post. I've tried downloading the update as a standalone and running that, but that fails as well. I've also tried disabling all none Microsoft services and tried to update after a restart but I get the same error. Any help would be appreciated.

    Cheers.

      My System SpecsSystem Spec

  2. #2


    Posts : 2,156
    Win7 Ult on DIY; Win8 Pro on MBP/Parallels; Win7 Ult on MBP/Boot Camp; Win7 Ult/Win8 Pro on HP


    Search on "problem install Kb2756872." Quite a few seem to be having a problem with it.
      My System SpecsSystem Spec

  3. #3


    Redmond
    Posts : 651
    Windows 8.1 x64


    If you're having issues, please attempt to install one more time, and then go to \Windows\Logs\CBS and upload a copy of the cbs.log file located there (you may want to copy it to your desktop and zip/rar it up first).
      My System SpecsSystem Spec

  4. #4


    Posts : 3
    Windows 8


    Thanks for your replies. I did have a search but couldn't find much regarding my particular problem. I've attached the cbs.log file as requested. Cheers.
    Kb2756872 Attached Files
      My System SpecsSystem Spec

  5. #5


    Redmond
    Posts : 651
    Windows 8.1 x64


    What is the actual error you receive when installing the update, and why specifically are you trying to install it? Is WU saying this package is needing to be installed?

    I ask because according to your CBS log, the package is already installed.
      My System SpecsSystem Spec

  6. #6


    Redmond
    Posts : 651
    Windows 8.1 x64


    Nevermind, I see the failure, and it seems to have something to do with wmpmde.dll - not sure what's going on with this file, but it's complaining about it's SxS manifest (either on the system itself or in the update package, although if you've downloaded the package multiple times the likelihood there's a package issue becomes less likely):
    Code:
      (125)  StageFile (2): flags: 8 app: (null) comp: Microsoft-Windows-WMP-MediaDeliveryEngine, Version = 6.2.9200.16420, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral file: [ml:22{11},l:20{10}]"wmpmde.dll" srcfile: @0xef70590728
    2013-01-17 22:51:53, Info                  CSI    00000012 Unable to validate file installation request; attempt to stage a file that is not part of the corresponding component.
    2013-01-17 22:51:53, Error                 CSI    00000013@2013/1/17:22:51:53.966 (F) base\wcp\componentstore\csd_transact.cpp(2233): Error c015001f [Error,Facility=FACILITY_SXS_ERROR_CODE,Code=31 (0x001f)] originated in function CCSDirectTransaction::StageComponentFile expression: (null)
    [gle=0x80004005]
    2013-01-17 22:51:54, Info                  CBS    Added C:\windows\Logs\CBS\CBS.log to WER report.
    2013-01-17 22:51:56, Info                  CBS    Added C:\windows\Logs\CBS\CbsPersist_20130116231716.log to WER report.
    2013-01-17 22:51:56, Info                  CBS    Added C:\windows\Logs\CBS\CbsPersist_20130116225511.log to WER report.
    2013-01-17 22:51:56, Info                  CBS    Added C:\windows\Logs\CBS\CbsPersist_20130116222156.log to WER report.
    2013-01-17 22:51:56, Info                  CBS    Added C:\windows\Logs\CBS\CbsPersist_20130116205521.log to WER report.
    2013-01-17 22:51:56, Info                  CBS    Added C:\windows\Logs\CBS\CbsPersist_20130115205852.log to WER report.
    2013-01-17 22:51:56, Info                  CBS    Not able to add pending.xml to Windows Error Report. [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND]
    2013-01-17 22:51:56, Info                  CBS    Not able to add pending.xml.bad to Windows Error Report. [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND]
    2013-01-17 22:51:56, Info                  CBS    Not able to add SCM.EVM to Windows Error Report. [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND]
    2013-01-17 22:52:10, Error                 CSI    00000014 (F) c015001f [Error,Facility=FACILITY_SXS_ERROR_CODE,Code=31 (0x001f)] #640825# from CCSDirectTransaction::OperateEnding at index 96 (0x0000000000000060) of 126 (0x000000000000007e) operations, disposition 0[gle=0xd015001f]
    2013-01-17 22:52:10, Error                 CSI    00000015 (F) HRESULT_FROM_WIN32(ERROR_SXS_FILE_NOT_PART_OF_ASSEMBLY) #626628# from Windows::COM::CComponentStore::InternalTransact(...)[gle=0x80073718]
    2013-01-17 22:52:10, Error                 CSI    00000016 (F) HRESULT_FROM_WIN32(ERROR_SXS_FILE_NOT_PART_OF_ASSEMBLY) #613307# from Windows::ServicingAPI::CCSITransaction::ICSITransaction2_AddFiles(Flags = 1, a = @0xef70d01410, fn = @0xef70d01c10, fp = @0xef70d02410, disp = 0, op = 0)[gle=0x80073718]
    2013-01-17 22:52:10, Info                  CBS    Failed to add to transaction package: Package_474_for_KB2756872~31bf3856ad364e35~amd64~~6.2.1.0 [HRESULT = 0x80073718 - ERROR_SXS_FILE_NOT_PART_OF_ASSEMBLY]
    2013-01-17 22:52:10, Error                 CBS    Failed to stage execution package: Package_474_for_KB2756872~31bf3856ad364e35~amd64~~6.2.1.0 [HRESULT = 0x80073718 - ERROR_SXS_FILE_NOT_PART_OF_ASSEMBLY]
    2013-01-17 22:52:10, Info                  CSI    00000017@2013/1/17:22:52:10.467 CSI Transaction @0xef6c4351c0 destroyed
    2013-01-17 22:52:10, Info                  CBS    Perf: Stage chain complete.
    2013-01-17 22:52:10, Info                  CBS    Failed to stage execution chain. [HRESULT = 0x80073718 - ERROR_SXS_FILE_NOT_PART_OF_ASSEMBLY]
    2013-01-17 22:52:10, Error                 CBS    Failed to process single phase execution. [HRESULT = 0x80073718 - ERROR_SXS_FILE_NOT_PART_OF_ASSEMBLY]
    Have you run an SFC check on your system, or run CheckSUR?
      My System SpecsSystem Spec

  7. #7


    Posts : 3
    Windows 8


    Success!

    I did run a SFC check before posting here but it did not find any integrity violations.


    I ran CheckSUR just before;
    The Scanhealth reported, "No component store corruption detected."
    The Restorehealth reported, "The restore operation completed successfully. The component store corruption was repaired. The operation completed successfully."


    I then ran WU but still got the error.

    After that I ran SFC and CheckSUR again and then tried WU and it installed!

    Thanks for your help cluberti.
      My System SpecsSystem Spec

  8. #8


    Redmond
    Posts : 651
    Windows 8.1 x64


    No problem.
      My System SpecsSystem Spec

  9. #9


    Quote Originally Posted by loafofbread View Post
    Success!

    I did run a SFC check before posting here but it did not find any integrity violations.


    I ran CheckSUR just before;
    The Scanhealth reported, "No component store corruption detected."
    The Restorehealth reported, "The restore operation completed successfully. The component store corruption was repaired. The operation completed successfully."


    I then ran WU but still got the error.

    After that I ran SFC and CheckSUR again and then tried WU and it installed!

    Thanks for your help cluberti.
    Can I please have the downloads to these programs that you ran to fix your problem. I have been having the same issue and I would like to fix it without doing a complete recovery. I actually just got doing a full recovery. I was trying to update everything. While doing this I ran into this same problem. Funny thing is before I ran recovery I did not have this problem. I ran the recovery 3 days ago. So unless this update is newer than 2/7/2013 than Something is different than it was before I ran the recovery.
      My System SpecsSystem Spec

  10. #10


    Redmond
    Posts : 651
    Windows 8.1 x64


    In the spirit of "help me help you", and with some comedy thrown in, here's what you'll need to do:
    CheckSUR
    SFC /scannow
      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Kb2756872
Related Threads
Solved KB2756872 Known Issue Windows Update in Windows Updates & Activation
Update for Windows 8 for x64-based Systems (KB2756872) Will not install. Things I have tried and been unsuccessful with: System update readiness System file checker/Scannow or SFC I have tried downloading the update manually.
Eight Forums Android App Eight Forums IOS App Follow us on Facebook