Windows 8 and 8.1 Forums


Android ICS with Mouse support on vmware

  1. #11


    Hafnarfjörður IS
    Posts : 4,376
    Linux Centos 7, W8.1, W7, W2K3 Server W10


    Hi there
    did you manage to get any apps from the Google Play store to work !!!

    It gets quite addictive playing around with this sort of stuff.

    Can you install apps from the Google Play store or do you have to register your "VM" as a phone !!!!.

    You can run this under vmware on an x-64 system -- the VM itself will ensure that it runs as an x-86 VM.

    cheers

    jimbo

      My System SpecsSystem Spec

  2. #12


    Orbiting the Moon
    Posts : 2,975
    Windows 10 x64


    Jimbo:
    Do you have internet connection on your VM?

    I use Android in VBox and couldn't manage to connect with the image from my previous link.
    But i found out a better VM now.

    For those who try in VirtualBox:
    How To Run Android 4.0 In Virtualbox (Internet Connection Supported) | Keyable

    “Buildroid for VirtualBox” 20120518 update | BuilDroid

    (a ready to use vm with internet access is available)

    EDIT: it's an OVA which can also be imported in VMware (and it had VMDK hdd's)
      My System SpecsSystem Spec

  3. #13


    Thanks, Hopachi - up and running but still no Angry Birds.......sigh!
      My System SpecsSystem Spec

  4. #14


    Orbiting the Moon
    Posts : 2,975
    Windows 10 x64


    Any problems or errors?

    I always get this:
    1. install works
    Click image for larger version

    2. app is listed
    Click image for larger version

    3. app is NOT running
    Click image for larger version

    Previously tested in VBox (needs disable absolute pointing device) ---> angry birds not working (actually all self-installed games not working)
    Now tested in VMware Player (hard disk needs to be IDE) ---> and also not working

    Apps like a file manager or text editor work. But no games so far except the ones already present (Lunar Lander, Defender and another one or two).
      My System SpecsSystem Spec

  5. #15


    No - I get "incompatible with your device" - I'm on VBox. I did note that they added a "permission" to Angry Birds of "check phone state and identity" which knocked out my old Android Tab - maybe that has something to do with it...
      My System SpecsSystem Spec

  6. #16


    Orbiting the Moon
    Posts : 2,975
    Windows 10 x64


    Does it install? That thing with permissions can be problematic.
    Also when you boot with the asus (iso) image it gives warnings (no asus product...). All apps have xml configurations and some don't run on all tablets. (I've extracted all the apps - apk's from the asus version and installed them on buildroid version => and not all of them work! => the same error as angry birds). Most apps work because they are generic and run on all devices (like simple text editors)

    In my screenshot nr.3 above it looks like a crash. And with the same results in VBox.

    One thing to notice: we don't have sound in our Android VM (or maybe I'm the only one here) and it can be an issue.
    I've tested Angry Birds in a Win XP VM with no sound card and Angry Birds could not start (error). If we could enable sound in Android then I guess it will be better for the apps that check for sound.

    Thanks for noticing the error.
    Hopachi
      My System SpecsSystem Spec

  7. #17


    Orbiting the Moon
    Posts : 2,975
    Windows 10 x64


    Didn't get "incompatible with your device here" because I was installing manually with my own apk's.

    But with no results either. People talk about a script that improves compatibility:
    This app is incompatible with your device? - SlateDroid.com

    I didn't manage to get it yet.
    Almost all the apps from a x86 eeepc work on the buildroid version x86 also.
    Yes there is sound support in buildroid4 using it in VirtualBox. There is no sound so far in VMware.

    It can also be a matter between ARM and x86 platforms:
    Android is ARM based originally and we're testing x86 versions here, but the apps on the market store are for ARM.
    The apps i got working were all preinstalled in a x86 edition. Even with sound and network, Angry Birds refuses to run (the notorious screenshot above).

    We'll have to try the script first. than we'll know more.
    Last edited by Hopachi; 28 Jun 2012 at 11:28.
      My System SpecsSystem Spec

  8. #18


    Orbiting the Moon
    Posts : 2,975
    Windows 10 x64


    Forget the script...

    No way to find a decent link and the chances for it to work on x86 are low.

    This is better:
    Run ARM Apps On Android x86 4.0.4 Ice Cream Sandwich | Keyable

    And VirtualBox has the upper hand for graphics acceleration on Linux (will work on Android too):
    Setup Hardware OpenGL for Linux Android x86 VirtualBox (also runs ARM apps) | Keyable

    Hope those links work for those that are interested.

    But here is all-included: Hardware OpenGL for Linux | BuilDroid (but NO Windows renderer yet!?)

    I'll post something after some tests, when I get the time.

    Hopachi
      My System SpecsSystem Spec

  9. #19


    Posts : 5,360
    7/8/ubuntu/Linux Deepin


    Can you just install it onto your HD ?

    No idea - I have never used Android for anything.
      My System SpecsSystem Spec

  10. #20


    Posts : 1,308
    Windows 8 enterprise x64


    Google will ship soon a $ 200 tablet with the new upgrade version 4,1 ( Jellybeans) , I already pre-order the 16 Gb , at that price what can I loose.

    https://play.google.com/store/device...id=nexus_7_8gb
      My System SpecsSystem Spec

Page 2 of 3 FirstFirst 123 LastLast
Android ICS with Mouse support on vmware
Related Threads
When I installed Win8 on one computer I need a H.P. printer driver. So I went to H.P. support/download did not find the needed driver so I called their Tech. support. A friendly support guy looked at my system and told me my copy of Microsoft Win8 bought at Best Buy was not a legit copy, also my...
mouse opens help and support in General Support
So I got this problem on windows 8.1 that all the time I press on my desktop or open a app or Google Chrome and I have no idea how it happend or how to fix it. Thanks in advance
I can't run MirrorOp on my Windows 8 Notebook PC. Whenever I try to open it, it crashes. I encountered similar problems with many applications that turn your Android device into a wireless touchpad (Logitech Touch Mouse Server, et cetera).Most of them crash or donot respond when I run them on my...
Good news about VMs again. The latest VMware Workstation 9 brings a new UI and it's designed for Windows 8. Read about it here: VMware Announces VMware Workstation™ 9 Also VMware Player 5 is available for download....
Hi all After a bit of googling found the fix This guy solved it -- works fine Now I can uset W8 x-64 on a Desktop with 16GB (I must have VMware working) Fix vmx86.sys error with Vmware workstation 7 and 8 | JB: Tech & Security Cheers jimbo
Hi all To install W8 developer edition (current version) as a VM with vmware workstation you have to download / upgrade to version 8. Version 7.1X and earlier won't work. Vmware player (current version) gives same problem as vmware workstation 7.1x. When you install choose W7 as the OS...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook