Windows 8 and 8.1 Forums

Couldn't Mount File (Seems New Unknown Kind of Problem)

  1. #1

    Posts : 1
    Windows 8

    Couldn't Mount File (Seems New Unknown Kind of Problem)

    Hello guys,
    I'm a new guy here so please forgive me for my title if it's quite unappropriate. Actually I created this account just to ask you about my ISO mounting error that I encountered awhile ago. I already read the rules about creating a thread of a same old topic in here, but seriously I'm not even sure mine is the same error as they've encountered, so here I am.

    The name of the error is just like the title "Couldn't Mount File" while the message inside is "The disk image isn't initialized, contains partitions that aren't recognizable, or contains volumes that haven't been assigned drive letters. Please use the Disk Management snap-in to make sure that the disk, partitions, and volumes are in a usable state."

    Of course I've already searched about this kind of problem in the internet many times but I never find the right answer. Well, maybe you already know that this kind of message is showing quite a lot in the internet asking for a solution. Unfortunately, mine is totally different (perhaps).
    This error started to pop up yesterday when I'm trying to mount a game ISO file from my friend. I'm using a second-hand laptop and it already has Cyberlink application as it can be used to mount ISO too. From the first time, I don't know that actually Windows 8 already can Mount without 3rd party applications, so I just use that Cyberlink to mount my ISO files until yesterday that the trial period is over and I can't mount any ISO files again. I've tried to open the ISO with Cyberlink twice but it keeps refusing as the trial period is over asking to upgrade it into Platinum (paid version). Then, I tried to just choose the command "Open" (at that time, it was still not associated to File Explorer so the Mount option wasn't available) and the installation launcher is showed. Actually I'm not really sure if this "Open" command already attending the "Mount" command with it, so I just continued to install the game and at the end the installation it was asking me to insert disk 1. Well, I think it was just a normal failure because I was not appropriately mount the file before, so I tried to Mount it then (this time, it was already associated with File Explorer, so I used the default Mount from Windows 8).
    And... Guess what? A funny error is occured.
    I can mount the ISO and there's a new window popping up, but then in around 1-3 seconds the window is closed by itself and disappeared into nowhere to be found in the File Explorer. In short, ISO file selected -> Mount -> a new window appeared showing the insides of the ISO file -> in 1-3 seconds the new windows is closed by itself.
    Once again, I think it was just a normal system failure, so I tried again. In the second chance, the new window is not showing up but the error message above substituted it (coudn't mount file).
    How can I solve this problem? I've tried to mount the file with Daemon Tools Ultra and mounted it into a different drive other than F: It's my default mount drive. From the properties, F: is a Microsoft Virtual DVD-ROM. Well, the error message was not showing up but it was asking for Insert Disk again. What the heck? I don't really understand. It's an ISO file so why do I have to insert a disk while it's already mounted. And, the ISO files that I can normally mount before was starting to get this error too.
    So, for now I can only assume that MAYBE this problem either come from the Drive F: or the Disk Management things or the ISO file that is not installed/mounted appropriately before.

    I'm so confused what else that I have to try as I'm not an expert too. Please help me, and please use understandable languages. Well, I'm not a super-newbie. I'm just a normal average computer lover who still can understand things, but not the expert-level complicated things. I'm sorry if my post is very long, I just want to make sure you can understand my problem entirely and sorry if my English is a mess too. I will really appreciate & grateful if there's someone who tried to help me....

      My System SpecsSystem Spec

  2. #2

    Hello there seravhyn and welcome to eightforums.
    I am not using either daemon or Cyberlink as i do mount iso files with virtual clone drive and so far have succeeded with each and every time I tried.Give it a go,maybe due to that trial period being over,the iso file is still associated to the app and kind of "blocked" by it.
    Cant be much more of help,never had that kind of issues,hang in there!
      My System SpecsSystem Spec

Couldn't Mount File (Seems New Unknown Kind of Problem)
Related Threads
How to Mount and Attach a VHD or VHDX File in Windows 8 This tutorial will show you how to mount and attach either a VHD (Virtual Hard Disk) or VHDX (Hyper-V Virtual Hard Disk) file as a drive in the Computer window for all users in Windows 8. Mount and attach is the same. You must be signed...
Hi guys. I have this problem with files that are like viruses. I used Avast! to scan the files but it doesn't detect any virus! HELPWhoever knows this virus or knows the solution, please help. It's eating up my memory :confused:They are named as 3590F75ABA9E485486C100C1A9D4FF06ZZZ..Z.....ZZZZZ and...
Unknown File in General Support
I found this file - - I don't know where it came from, what it is for, what am I to do with it, and I can't open it. Does anyone know anything about this file or this kind of file and what it is for and what to do with it etc. Could you please help me out? I'd really...
In Windows 8.1, when I try to use the native ISO mounting function, either from the right-click menu, or by double clicking the iso file, I am getting the error: Couldn't Mount File Sorry, there was a problem mounting the file. Yet most of the time, the virtual CD/DVD drive appears as it ...
Not able to mount iso file in Virtualization
Hi, I didn't install any 3rd party app to mount iso. Yesterday, i tried to mount a iso file, it didn't worked. Then googled about it, tried sfc /scannow, no success. Then i checked "Default programs - associate file extension...", there is no entry for .iso. Please help. 27780 Tried Daemon...
couldn't mount image in Virtualization
i use windows 8 professional edition, when i want to mount the image, the warning message came and it says "couldn't mount image because its in use" although i'm not mount it, do you have any answers ? thanks :D
Hi, i accedentally deleted volume for ubuntu in triple boot , now getting unknown file system grub rescue. Plz. Help me . My windows 8 n 7 files r extremely imp for me. Thanks.
Eight Forums Android App Eight Forums IOS App Follow us on Facebook