Windows 8 and 8.1 Forums


Hyper-V new vm doesn't start

  1. #1


    Posts : 12
    Win 8.1 pro

    Hyper-V new vm doesn't start


    Hello, I've installed Win Pro 8.1 on a new desktop and added the Hyper-V feature. Checking the bios shows Virtualization is enabled, and I contacted intel about the processor who verified it supports virtualization (dell said it doesn't). I can start the VM manager, create an Internal Lan Switch and go through the steps to create a new VM machine. When I click on Connect the VM window opens, then I start it. At that point the VM screen says "Connecting to Vm1. It cycles through for a while then shows an message " it couldn't start try again if this persists contact your system admin" (paraphrasing). What I find more odd is the bottom pane that opens in the VM manager when I connect to the VM shows the VMs state(?) and the image loads with a login screen. Has anyone seen this happen and have any suggestions? One other thing, when I try to stop the virtual machine in the Manager it says stopping but never really does it hangs up. The manager is responsive but no commands seem to execute. I then go to Services in msc and stop it and it says stopping the service and hangs there with the service grayed out and not able to select start, stop, refresh etc.

      My System SpecsSystem Spec

  2. #2


    A Finnish ex-pat in Leipzig, Germany
    Posts : 1,452
    Windows 8.1 Pro with Media Center


    Hi Urquhart, welcome to the Eight Forums.

    What OS is installed / will be installed on that vm? how much RAM you have assigned to it? How much RAM does your host system have?

    Kari
      My System SpecsSystem Spec

  3. #3


    Posts : 12
    Win 8.1 pro


    Hi Kari, thanks! I want to install Windows Server 2008r2 enterprise (the iso I am using has all versions of 2208r2) Creating the VM I used the default setting of 512 mb. My desktop has 12 gb of memory.
      My System SpecsSystem Spec

  4. #4


    A Finnish ex-pat in Leipzig, Germany
    Posts : 1,452
    Windows 8.1 Pro with Media Center


    OK, that rules out the most common error, not enough RAM. You situation is quite an opposite, I would assign at least a gig or two to this vm.

    Please take a screenshot of the complete error dialog and post it here. If it has a link / button to more details or similar, be sure to click that before taking the screenshot.

    Kari
      My System SpecsSystem Spec

  5. #5


    Posts : 12
    Win 8.1 pro


    Will do, It'll be several hours I'm at work now. Thanks!
      My System SpecsSystem Spec

  6. #6


    Posts : 12
    Win 8.1 pro

    This is the message and hyper-v manager pane


    Click image for larger versionClick image for larger version

    The manager looks like this, it never stops( new Virtual Machine2 ) in this picture Click image for larger version

    So I decide to surrender and try to stop the vmClick image for larger version

    The vm won't shut down at this point so I have to stop the server which really does nothing about altering the state of the vm's if I go to the service and shut that down it tries but becomes inactive and can't be started,stopped,refreshed etc. so at that time it's a restart of the computer....
    Last edited by urquhart; 10 Jul 2014 at 21:28.
      My System SpecsSystem Spec

  7. #7


    A Finnish ex-pat in Leipzig, Germany
    Posts : 1,452
    Windows 8.1 Pro with Media Center


    Your screenshot telling "Video remoting was disconnected unexpectedly" is the most revealing piece of information. It suggests that you have installed / enabled RemoteFX.

    RemoteFX when enabled needs additional virtual hardware to be installed on vm. If you have RemoteFX enabled, open the settings for your vm (it must be shut down or turned off), select Add Hardware on the left pane, select RemoteFX Video Adapter on the right pane (list of devices), click Add, click OK.

    See screenshot below, notice that as I have no Windows Server virtual machines this example screenshot does not show RemoteFX Video Adapter but is here only to show where and how you should find it:

    Click image for larger version

    Your vm should be able to boot now.

    Kari
      My System SpecsSystem Spec

  8. #8


    Hafnarfjörður IS
    Posts : 4,376
    Linux Centos 7, W8.1, W7, W2K3 Server W10


    +1 for Kari --had similar problem when trying to use W2012 server as a VM with HYPER-V -- normally I use VMware but I just wanted to play with this for a while.

    Thanks

    Cheers
    jimbo
      My System SpecsSystem Spec

  9. #9


    A Finnish ex-pat in Leipzig, Germany
    Posts : 1,452
    Windows 8.1 Pro with Media Center


    Notice also that installing RemoteFX Video Adapter is only needed if the vm will be used over Hyper-V Virtual Machine Connection tool; if vm will be used only over RDP it is not needed.
      My System SpecsSystem Spec

  10. #10


    Posts : 12
    Win 8.1 pro


    Kari, that is just .... excellent. It brings me to the next point, the vm doesn't want to shut down, turn off. In the attached screenshot the status shows turning off failed. Shutting down the service and restarting it just brings the vm back to the same state.
    Click image for larger version
      My System SpecsSystem Spec

Page 1 of 3 123 LastLast
Hyper-V new vm doesn't start
Related Threads
Just purchased a laptop for the wife with windows 8.1 & trying to understand it I set up live mail 2012 as her email service & pinned it to the taskbar. But when she clicks the mail tile from the start screen it ask for an account & does not start the correct program. The same is true of IE...
Hi, This is my first post on this forum. I've been searching for a solution for my problem for a couple of days and found nothing, so I hope I can find some answers here. I'm trying to make a certain program (a game, actually) to run as soon as I boot the computer. So, I don't want to click...
I have a Hyper-V VM, and during the setup wizard I chose to install OS later. I added DVD drive to it's hardware, and added the DVD drive to the boot order. I put the retail Windows XP disc in the drive and start the VM, but it doesn't see the disk and eventually I get the error "Boot...
Hi! I have self built PC: Asus P8z77-v, 32 gb ram, I7, processor, C-drive ssd another ssd and one HDD, DVD, Card reader, Radeon graphics card. OS: Win 8.1 x64 PRO with latest updates. Suddenly it did not start. C-drive ssd. Behavior: After post screen is shown win logo is displayed and small...
hello guys.it my first post as i am new to this os.when i start my laptop,the leds are lighting but the screen is blank.if i press the reject button of the cd/dvd driver in the first 10-20 seconds.windows will start properly.if i don't, the blanc screen continues to exist.if i start the laptop with...
Solved App Doesn't Start Upon Login in Software and Apps
I placed an app (RealTemp GT) in the Startup folder, so it will automatically run every time I log in to my desktop, but it does not run. The application is listed as "Enabled" under the Task Manager group Startup. I've attempted running as admin, and not. If I manually run the application, I...
Hey guys! I'm having a problem with windows 8 professional setup: So I have win8 consumer preview installed on my laptop. A couple days ago its licence expired, so I got win8 professional to upgrade. I made an install USB with the win7 USB utility and proceeded to boot from the stick. The...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook