Windows 8 and 8.1 Forums

W8.1 on Linux Hosts - Web cams working - Solved

  1. #1

    Hafnarfjörður IS
    Posts : 4,376
    Linux Centos 7, W8.1, W7, W2K3 Server W10

    W8.1 on Linux Hosts - Web cams working - Solved

    Hi there.

    Sometimes a Windows 8.1 Virtual Machine running on Linux Hosts won't recognize the webcam even though you can connect / attach the webcam to the VM machine (especially INTERNAL USB typeWebcams).

    Often the problem is that the HOST Linux machine hasn't enabled the webcam / started the video service -- this is easy to do in Linux Mint (16), OPENSUSE or other distros with LXDE / KDE desktops (might also work on GNOME too - haven't tried but should work as LXDE uses a lot of GNOME stuff).

    1) Install KOPETE (KDE) or CHEESE (non KDE) on your Host Linux system.

    2) Start KOPETE etc and simply go to the configuration ==>video devices -- click on the webcam image and after a few secs you should see your web cam working. - Note these apps are instant messaging - but you can use them to set up your webcam. Exit KOPETE (you need to QUIT the application - not merely close it otherwise the webcam won't get released for attaching to your VM).

    3) Next, power up your VM and attach the webcam to the VM -- you'll see disconnect from host and it will display a couple of messages about disconnecting from /dev/video or whatever. Now the webcam should work properly in your VM.

    Works also for SKYPE etc - and LYNC (SKYPE works well in Linux anyway !!) but LYNC is a MS messaging application which requires Windows.

    Attached Thumbnails Attached Thumbnails snapshot19.png  
    Last edited by jimbo45; 29 Apr 2014 at 07:46.

      My System SpecsSystem Spec

W8.1 on Linux Hosts - Web cams working - Solved
Related Threads
Hi there Linux Mint (17) QIANA now released I Am trying this in a VM now before testing on a REAL machine. I'm looking for good things with this release --it's a LTS (Long Term support) release which will be supported until 2019. This is the sort of things I've been looking for -- I tend...
Solved try to save the hosts file in General Support
Thanks for sharing these instructions, which I followed to the letter and added the "Take ownership". I use the new menu on the Windows/System32/drivers/etc folder. Notwithstanding, as I try to save the hosts file on Windows/System32/drivers/etc it responds "Denied access" and does not allow to...
Alright, so I've just encountered this problem today and it's inexplicably frustrating. I'm running Windows 8.1 x64 with only Bitdefender Total Security on. A day or so back I could edit and modify my hosts file perfectly. Today, it's just gone. There are 2 hosts.backup file in the...
Hi there I know a load of you run Linux VM's - and you *might* have wondered how to mount GPT partitions. (Works too on Linux HOSTS) The standard Linux fdisk -l command doesn't list the partitions properly for GPT partitions. What you need to do is use the parted command (as root --su /...
I am getting error "Save failed - Please check if this file is opened in another program" when trying to edit the hosts file in Notepad++. This has only started happening after a fresh installation of Windows 8 on a new computer. My previous computer with Windows 8.1 was able to do it correctly...
Linux Professional Institute puts Linux in the classrooms | ZDNet
Changing Hosts File in General Support
I am trying to edit my host file, but the system is telling me that I need to be an administrator, when I am the administrator. I made an attachment in word with screen shot for you to see. Is there a solution for this problem? 25078
Eight Forums Android App Eight Forums IOS App Follow us on Facebook