Windows 8 and 8.1 Forums


Can not install Virtual Switch external in Hyper-V

  1. #21


    Posts : 21
    Windows 8


    I do not understand why but all my Virtual machines are now working and can connect to the world and the rest of my network.
    Out of desperation I changed the network adapter for the machine operation Windows 7 to a legacy one, this then connect to the internet all be it slowly. I then removed that adapter and changed it back to a normal one and every thing works as it should at normal speed.
    The machine operating Windows XP I changed the legacy adapter from a legacy one to a normal one and that now connects to the network at normal speed, faster than it did originally when the host was Windows 8.
    To me none of this makes any sense, but it works, why I have no idea.
    Big thank you to Harry for his input.
    Many thanks,
    Martin

      My System SpecsSystem Spec

  2. #22


    UK
    Posts : 333
    Windows Server 2012 R2 / 8.1


    Quote Originally Posted by Martin7 View Post
    I do not understand why but all my Virtual machines are now working and can connect to the world and the rest of my network.
    Out of desperation I changed the network adapter for the machine operation Windows 7 to a legacy one, this then connect to the internet all be it slowly. I then removed that adapter and changed it back to a normal one and every thing works as it should at normal speed.
    The machine operating Windows XP I changed the legacy adapter from a legacy one to a normal one and that now connects to the network at normal speed, faster than it did originally when the host was Windows 8.
    To me none of this makes any sense, but it works, why I have no idea.
    Big thank you to Harry for his input.
    Many thanks,
    Martin
    Fantastic news Martin

    If you have any other questions please ask it will be a pleasure to help.

    Enjoy your new found internet and have a good rest of the weekend.

    Cheers,
    Harry
      My System SpecsSystem Spec

Page 3 of 3 FirstFirst 123
Can not install Virtual Switch external in Hyper-V
Related Threads
Hyper-V Virtual Switch 101: How to create and use Virtual Switches to connect Virtual Machines to Network I will try to make this tutorial as simple and easy to understand as possible. Therefore some examples used might seem to you fellow geeks too simple. However, I ask you to understand that...
Hello all, I'm learning windows phone 8, and I want to run the windows phone 8 simulator on my PC ( OS windows 8.1 pro ), but the simulator can not run because it can not create the virtual switch in Hyper-V, and I also can not do it manually :mad:. This is the error when I create the new virtual...
Hi, I had Hyper-V and Ubuntu running on Windows 8 no problem. I've since done a fresh install to 8.1, and I can no longer create an External Virtual Switch. The button for "Create Virtual Switch" is grayed out when I select "External". I can create Internal and Private switches, but not...
After i updated to Windows 8.1 Enterprise from Windows 8 Enterprise, Hyper-V does not function correctly. When I add an iso image to a new virtual server or start one of my existing, I can see the iso file is loaded in the bottom thumbnail. But when I connect to the virtual server it just says:...
hyper-v - error in creating external virtual switch I got an error in creating external virtual switch at hyper-v on windows 8 pro x64. I have one xp vm and tried to make an network connection, but I coul not success. Please let me know how to make creating external virtual switch at...
I have a Win8-64 system hosting a Win8-32 VM. A physical Wifi adapter provides Internet sharing, and a virtual switch provides Internet access to the guest VM via "internal network". However, the Win8-64 host seems to be confused as to which adapter provides Internet access. If I delete the...
Hi All, Getting a strange error with Hyper-V on Windows 8 Pro x64. When I try and add a virtual switch I get: Error Applying Virtual Switch Properties Changes Failed while adding virtual Ethernet switch connections. Ethernet port '{a bunch of stuff}' bind failed: The data is invalid....
Eight Forums Android App Eight Forums IOS App Follow us on Facebook