I was using my Win 8.1 machine to develop some WP8 apps with Visual Studio 2013, which works great... until this week. After I installed all the Windows updates, the OS would not boot - it kept getting into "repairing OS..." mode and ending up to give me only to option to shutdown the machine. Since I was using an SSD, I thought the drive might have some issues (it shouldn't since it's only ~1yr), so I ordered a new drive. While waiting for the drive, I tried to install the OS (Win 8.1 Enterprise Edition, MSDN download) onto an old drive, everything was working until I enabled HyperV. The OS went back to "repairing OS..." mode and ended up (again) the only option is to shutdown the machine.

Since I was doing a fresh OS install, this did not make any sense - the OS was working with HyperV. Has anyone seen this before? If so, how to fix it?

I tried to install Windows Server 2012 R2 on the same box, and I was able to enable HyperV and create a VM. So I don't think this is a hardware issue. - in case you are wondering, I can't use WS 2012 to run Phone emulator, so I have to go back to Win 8 to work on the app :-(

Thanks in advance!