Windows 8 and 8.1 Forums


Hyper-V stuck at connecting to virtual server

  1. #1


    Oslo, Norway
    Posts : 3
    Windows 8.1 Enterprise

    Hyper-V stuck at connecting to virtual server


    After i updated to Windows 8.1 Enterprise from Windows 8 Enterprise, Hyper-V does not function correctly.
    When I add an iso image to a new virtual server or start one of my existing, I can see the iso file is loaded in the bottom thumbnail.

    But when I connect to the virtual server it just says: Connecting to virtual server... and it times out after 5minutes.

    All my virtual servers are running locally, they are able to start and are running fine, I just cannot connect to them.
    Also the ability to turn virtual servers off tends to hang and I have to kill the processes and restart the services for it to stop.

    Does anyone know of a workaround for this problem?

      My System SpecsSystem Spec

  2. #2


    Posts : 96
    Win 8.1 Enterprise


    Hi there,

    If you are running VM(s), the Host VM should have plenty of RAM, just trying to confirm.

    Have you tried shutting off some of your VMs, and try to run one for now, then connect to it?
      My System SpecsSystem Spec

  3. #3


    Oslo, Norway
    Posts : 3
    Windows 8.1 Enterprise


    Quote Originally Posted by 2xg View Post
    Hi there,

    If you are running VM(s), the Host VM should have plenty of RAM, just trying to confirm.

    Have you tried shutting off some of your VMs, and try to run one for now, then connect to it?
    Offcourse, I've tried everything.
    I have the same issue at my desktop computer, I did upgrade from 7 to 8 and from 8 to 8.1.
    Also tried uninstall Hyper-V and reinstall, delete all vm's make a new one.

    Same problem.. stops at connecting...

    It worked fine at 8.0, so something must have happened during the update.
    Or some group policy or something is wrong..
      My System SpecsSystem Spec

  4. #4


    Hafnarfjörður IS
    Posts : 4,376
    Linux Centos 7, W8.1, W7, W2K3 Server W10


    Hi there
    How are you connecting to the VM -- does it go via IE 11 (as external console) -- in this case you'll have to disable the Enhanced security settings in IE11. (I run a few VM's via Esxi which needs an "external console connection" from a separate machine - and I had to set IE11 enhanced security to OFF before I could connect to the VM's).

    Otherwise I assume you've tried to PING the VM's and allowed firewall access / security software (if any).

    VMware workstation has no issues with VM's and W8.1 but you can't run that with HYPER-V - you have to switch off one to test the other. -- Try and see if your VM's work with VMware player (free) just as a test. VHD conversion is easy enough.

    Otherwise sometimes the Virtual switch in HYPER-V causes problems -- especially if you are using wi-fi.

    Cheers
    jimbo
      My System SpecsSystem Spec

  5. #5


    Oslo, Norway
    Posts : 3
    Windows 8.1 Enterprise


    I am just using the Hyper-v Manager to connect to instances i make in hyper-v manager located on the same computer.
    I try installing Ubuntu 13.10, wont connect to anything after 8.1 upgrade.

    Also I test only to make an image and boot disk, wont even connect.

    This happened after i upgraded 2 of my computers, so I guess people will experience the same issue with enterprise edition.

    I am not using vm-ware software.
      My System SpecsSystem Spec

Hyper-V stuck at connecting to virtual server
Related Threads
Hyper-V Virtual Switch 101: How to create and use Virtual Switches to connect Virtual Machines to Network I will try to make this tutorial as simple and easy to understand as possible. Therefore some examples used might seem to you fellow geeks too simple. However, I ask you to understand that...
Upgraded my win 7 pro that had virtual XP mode to win 8.1 pro. Everything from Win 7 came with it including my install programs. Noticed the virtual xp file .vmcx is there but can't access it. So I installed Hyper-V and got to the point of connecting to Virtual Hard Disk. Noticed it creats a .vhdx...
Hello all, I'm learning windows phone 8, and I want to run the windows phone 8 simulator on my PC ( OS windows 8.1 pro ), but the simulator can not run because it can not create the virtual switch in Hyper-V, and I also can not do it manually :mad:. This is the error when I create the new virtual...
I am running Windows 8.1 Pro with Hyper-V enabled. When I had Windows 8 I could install a Virtual switch with out any problems, since upgrading I can not install a Virtual Switch with External or Internal settings. Not sure if this is relevant or not but when I look at the Ethernet properties...
Hi, I've Windows 8 Pro, I've enabled the Hyper-V and I've created two VM's. One is a WinXP and the other is a Win7. They seem to be working fine, however I can't connect to the internet with them or view them on my lan. I've tried using Legacy network Adapters, network adapters, googled to find...
I have a Win8-64 system hosting a Win8-32 VM. A physical Wifi adapter provides Internet sharing, and a virtual switch provides Internet access to the guest VM via "internal network". However, the Win8-64 host seems to be confused as to which adapter provides Internet access. If I delete the...
I am preparing to go to Windows 8 but I teach a lot of workshops. Most of the time in the workshops, my students use virtual images that I build. If I build an image on Win8 in hyper-v, will my students be able to run this image on their Win7 boxes? They will be 32bit images. If they can't, I'm...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook