Windows 8 and 8.1 Forums

USB issue with VirtualBox

  1. #11

    Same issue with VMware (different message but same issue). Using VMware is not the solution! I'm really desperated.

      My System SpecsSystem Spec

  2. #12

    Orbiting the Moon
    Posts : 2,975
    Windows 10 x64

    You're welcome.

    Actually VirtualBox 4.2.8 was released. You can give it a try.

    For VMWare, go with Player if you want a free product. USB works fine.

      My System SpecsSystem Spec

  3. #13

    Orbiting the Moon
    Posts : 2,975
    Windows 10 x64

    Quote Originally Posted by ElectroMark View Post
    Same issue with VMware (different message but same issue). Using VMware is not the solution! I'm really desperated.
    What is the message?
    Can you post a screenshot...

      My System SpecsSystem Spec

  4. #14

    What is the message?
    Can you post a screenshot..
    I post the message in the new Thread entitled "USB issue with VMware"
      My System SpecsSystem Spec

  5. #15

    Actually VirtualBox 4.2.8 was released. You can give it a try.
    I've read the change log from 4.2.6 to 4.2.8: there is no fix related to USB issue. As just mentioned, there is no ticket open about this.
      My System SpecsSystem Spec

  6. #16

    Posts : 2

    Let's not throw ElectroMark off the bus quite yet.

    I have a Win8 host with an XP guest. Everything was working two days ago just fine. The guest could see my USB devices, I could map COM1 on my guest to COM4 on my host, and I could print from my guest machine.

    That all changed when I attempted to:

    1. Investigate why the Oracle VM VirtualBox Manager (2) (as shown in the host's Task Manager) was consuming 75% of the CPU at all times;
    2. Troubleshoot why a daily production data upload to a remote appliance via a USB Modem attached to a host USB port was taking 23% longer than it did when the entire process was working on a much slower stand-alone PC running XP (this is an hour long upload...23% is a lot of time); and,
    3. Use the task scheduler on the host to automatically invoke VM VirtualBox and an instance of the XP VM whenever the host machine was rebooted.

    Since fiddling around with the three items above, I can no longer map COM1 to COM4 using the serial configuration setup without getting the following error:

    Failed to open a session for the virtual machine Win XP.
    NamedPipe#0 failed to create named pipe COM4 (VERR_INVALID_NAME).
    Result Code: E_FAIL (0x80004005)
    Component: Console
    Interface: IConsole {db7ab4ca-2a3f-4183-9243-c1208da92392}

    My guest machine cannot see the printer, and it cannot connect to the USB Modem.

    I suspect that all three things may have a common root cause. However, my primary focus is the need to restore connectivity to the USB Modem. The daily upload is critical.

    I have read all the VBox documentation I can get my hands on. I have read forums on the printer issue, the Serial Port issue, and the USB issue until I am beginning to mix them up. I have now invested over 30 hours in testing conflicting theories, statements, configurations, and networking, serial, and USB configurations. I still cannot get back to where things worked two days ago.

    In my attempts to restore the COM port connectivity, I gave up at trying to map COM1 to COM3 at one point and attempted, instead, to try and connect to the modem directly via the virtual USB port. That is when I discovered problems with this method as well. In the original configuration (> two days ago) I only had the "Enable USB Controller" checked. I used no filters. I had not checked whether the USB modem showed up in the hardware device list within Control Panel or not (I had no need, since the COM port mapping was working just fine), so I have no real baseline regarding the USB issue. In my testing to try to restore functionality, I have added a USB device filter and the device list shows the USB modem connected to the host just like ElectroMark said. However, my result is the same as his; once the guest is running, I can't find the modem anywhere from within the guest OS.

    Things that I did that may have had an impact:
    • I attempted to Invoke the Guest XP VM at Host startup via Task Scheduler with the following command:

    "C:\Program Files\Oracle\VirtualBox\VBoxManage.exe" startvm "WIN XP"

    However, I screwed up a couple of times when I didn't remember the correct syntax. Accordingly, I had invoked the commands:

    "C:\Program Files\Oracle\VirtualBox\VBoxManage.exe" vmstart "WIN XP"
    "C:\Program Files\Oracle\VirtualBox\VBoxManage.exe" /vmstart "WIN XP"
    "C:\Program Files\Oracle\VirtualBox\VBoxManage.exe" /startvm "WIN XP"

    and possibly others before I realized my mistakes and gave up altogether for the time being.

    • I turned off McAfee's firewall and antivirus services on the Host; this did not help. I have restored the two functions.

    Things that I have done to troubleshoot (including all of testing discussed above):

    • I have reinstalled the USB modem drivers on both the host OS and the guest OS; this did not help.
    • I have moved the USB modem to a different USB port
    • I have renamed the USB modem port to COM3
    • I have tried every configuration of networking and Serial Port mapping I can think of.
    • I upgraded VM VirtualBox from version 4.2.6 to version 4.2.12 r84980

    Things that happened along the way that may have had an impact:

    • While troubleshooting, the automated Dell update process kicked off, popped a bunch of windows on the screen, then, eventually said successful update. This was after I had problems with the modem connection, however.

    The bottom line is that everything worked just fine two days ago, I am now experiencing the same things as ElectroMark, I am having the same luck in resolving the problem as ElectroMark, and I am sure there is a solution.

    Could it be something in the Host's registry?
    Could it be a firewall issue?
    Could it be something wrong with DHCP? (I'm a bit out of my element here.)

    I would rebuild the entire VM world from scratch except that it takes about 10 hours per day for a week to get everything loaded so the production application runs correctly. I just finished putting it all together about two weeks ago and had not yet backed it all up before this problem. (Now you can rag on me!)

    Any new ideas or direction would help.


    P.S. By the way, the Oracle VM VirutalBox Manager (2) App in the Host's Task Manager now shows as 15% CPU utilization. I have no idea what caused this change. It had been running 75% and higher constantly for weeks.
    Last edited by Tenacious; 19 Apr 2013 at 16:36.
      My System SpecsSystem Spec

  7. #17

    Orbiting the Moon
    Posts : 2,975
    Windows 10 x64

    Hello Tenacious,

    That seems to be a frustrating situation. I'm no expert but I'll try to help.

    Just some ideas I like to share:

    If you upgraded or downgraded the VBox version, make sure you upgrade or downgrade the Additions as well to match the current version.

    Did you tried a system restore if possible? To go back 2 days ago and see it the host settings are back before Scheduled Tasks in VirtualBox took place.

    When the executable uses 75% CPU on the host (I believe you look in Task Manager on the host) If there is a VM running, you should also look in the Task Manager in the guest as well to see precisely what program from the guest is causing this. If it uses CPU with no VM's running than that wouldn't be considered as normal. In this case maybe is this high CPU related with the USB modem problems with VirtualBox.

    I've tried 4.2.12 but it crashed (stopped working) a few times and I went back to my good 'ol 4.2.4 OSE version which is the most superior at the moment regarding Windows 8 (QT interface is fixed among some other stuff stable in 4.2.4). I consider this stable since it never crashed to me. I'm not sure if the crashes on 4.2.12 were due to outdated VM Additions but that was annoying not being able to update those.

    Turning off antivirus is not a good idea but you should exclude the VM's folder from scans since virtual disks are enclosed, hidden from the host system and are usually very large which can slow antivirus scans.

    USB's are tricky in VBox, some devices don't work at all (Sandisk USB 32GB?...) If the modem worked once it should work again, it's a matter of finding the cause on the host or guest so there are many places to look for (system restore should be easier but this time I think is useful to turn off McAfee).

      My System SpecsSystem Spec

  8. #18

    Posts : 2

    Thank you for your reply. I tried some of the items plus removed and reinstalled the USB Modem. At this stage, the CPU usage is still quite acceptable and I am now able to connect to the USB modem. However, I have to manually initiate the connection each time I load the guest machine. I do this by selecting Devices>USB Devices (in the upper left corner of the Guest machine) then left clicking on the USB Modem I want attached to the guest machine. (By clicking Devices>USB Devices I can see each of the USB devices available.)

    This allows me to use the modem but if I reboot the guest machine, the attachment must be manually reestablished. Is there a way to ensure that any USB device that is seen as available can automatically be attached when booting the guest OS? (I tried using filters but that didn't seem to do it.)

    Also, I still cannot make an association between the guest serial port (COM1) and the host serial port (COM4) like I was doing before. That method allowed me to use the modem without having to manually attach things. (I suppose that is because the setup configuration of the guest OS explicitly calls out the association.)

    At this stage, I am able to keep things running in production; however, I am not real comfortable that everything is working as well as it was a few days back.


    P.S. I still cannot see the network printer.
      My System SpecsSystem Spec

Page 2 of 2 FirstFirst 12
USB issue with VirtualBox
Related Threads
My laptop runs Windows 8 Home version (unsure exactly which home version it is if there are more than one), and after reading other posts about VirtualBox crashing on Windows 8 I fear to actually install VirtualBox in the first place. Here are my computer specs just so you can have a look at them...
Windows 8.1 and VirtualBox in Virtualization
After installing the W 8.1 Preview, seems the VirtualBox networking is out. 23691 This is using the latest VBox 4.2.14. Re-installing VirtualBox solves it but duplicate driver entries still remain, one being the old one.
VirtualBox-problem in Virtualization
hi there i want make a virtual machine on virtual box but when i start the machine this error come please help (sorry bad english i come from Germany) Fehlercode: E_FAIL (0x80004005)
Windows 8 Vm VirtualBox in Virtualization
Hello , i installed windows 8 pro to virtual machine.Also activated and save the box for future use. Today i ran the windows but it cant be activated becuase the serial key is already being used on another pc.. (The key is genius.)Well i cant use anymore this key??Also i made a new setup but...
VirtualBox and Hyper-V...... in Virtualization
Just a tip, I couldn't see any other references goes. Please disregard/move/delete if this has been covered. Today, I attempted to install the 64-bit RP in Virtual-Box on Win 8 RTM 64-bit. It failed. So I updated to the latest(?) version I had (4.18). Still no joy. I suspected...
Solved VirtualBox 4.2 on the way in Virtualization
Good news for VirtualBox users! Beta1 of the next major version 4.2 is out: found on the official site: -Better Windows 8 support. -Drag & drop first time on VBox (beginning with linux VM's)
I created a new VM and loaded the Win RP 64-Bit. Blearghhhh. Re-read Virtualbox help section 9.7.2 Yippeee!! Looks ok.
Eight Forums Android App Eight Forums IOS App Follow us on Facebook