Windows 8 and 8.1 Forums


Strange sound with VMWare Workstation

  1. #41


    Orbiting the Moon
    Posts : 2,975
    Windows 10 x64


    Quote Originally Posted by tedych View Post
    Hopachi, see my edit above .
    As to vmw 8, I just haven't updated there, but I have and tried vmware 9.0.1 on a Win2003 host. It behaves the same.
    I'll try it on the Win2008 host now anyway. It is a too-long-lasting issue and I'll give this a shot now, as the last thing I'll try because I lost too much time on this already.
    I'm not interested in 8.0.5, we are on the 9.x branch already . If 9 (last version) hasn't fixed it, no reason to think 8 would have.
    You're right, I see....

    Well, since we're all on version 9, I'll see if I can get the intel HD sound driver on XP x64 (win 2003 core).

    One of these days we'll get 9.0.2 since it's been a long time wait.
    The good thing about 9.0.1 is that it lets me use Win98, ME again on i7 processor (9.0.0 crashed all the times).

    Thanks

      My System SpecsSystem Spec

  2. #42


    Posts : 18
    Windows 7 x64


    The Autohotkey script I just tested and it works (in this case to keep the timer at 2ms).
    Code:
    SetBatchLines -1  ; Ensures maximum effectiveness of this method.
    
    SleepDuration = 1000
    TimePeriod = 3
    
    DllCall("Winmm\timeBeginPeriod", uint, TimePeriod)
    Loop
        DllCall("Sleep", UInt, SleepDuration)
    ;DllCall("Winmm\timeEndPeriod", UInt, TimePeriod)
    I had it run on the host (Win2008), and VMs play fine.
    The script process uses only 2MB RAM, and the super negligible 80,000 cycles delta (1 sec) on my 2.8G cpu.
    It can be compiled to an exe.

    For me, it works when running on the host, but it can be set up to run in the guest (only), so the timer is boosted only when an XP VM is run.
      My System SpecsSystem Spec

  3. #43


    Orbiting the Moon
    Posts : 2,975
    Windows 10 x64


    At least that gives something nice!

    Here I tested the XP 64 but no drivers exist for the HD audio. It's not Intel, it's Realtek but a customized one because the Realtek drivers don't apply.

    Click image for larger version
    This is the hd audio driver needed but missing in Xp 64.

    this is something Win7 uses:
    Code:
    sound.virtualdev = "hdaudio"
    I've added it to XP64 and then I needed to find the driver... but no Xp version was found so I used the Win7 one.

    If you use the drivers from Win7 (because I use the sound card from Win7) it's not gonna work (corrupted driver) although it installs successfully.

    And since I'm on x64 VM I'm not gonna try the soundblaster 16 since it's old.

    These are the 3 choices of sound cards:
    Code:
    sound.virtualdev = "sb16"
    sound.virtualdev = "es1371"
    sound.virtualdev = "hdaudio"
    Only one of those lines needs to be active for one VM.
    For XP is "es1371" but the one in XP 32 didn't stuttered at all only in XP 64 I have this problem.

    If no other drivers are available the we cannot use anything else but the default one.
    AND even if we find HD driver for XP the chance is to work bad too since it's about those bloody timers we talked about earlier.

    But, anyway we have found some stuff out even if no real fix exists... the script (made by tedych in previous post) should be considered as a fix for now.
      My System SpecsSystem Spec

  4. #44


    Posts : 18
    Windows 7 x64


    Well, that's something new - you don't see the problem with XP x86's? I have only 32 bit XP/2003's here.
    I have been testing the other sound cards before, with no luck either.
    I'm already sick of experiments and time spent on this issue . My 7.1.4 serves me well and unless I need 8+ desperately for something, I'll put VMWare tests on hold for now, until 9.0.5/6 comes out (or you folks confirm a build has fixed the issue). I'd rather expect v10 before that. Amazing how many years vmware have not fixed this.
    The AHK code from above is borrowed by an autohotkey's examples site and slightly modified by me. I've tried so many things that I've already forgotten where it was borrowed from. It can just replace the "mighty" WMPlayer in its function to keep the timer high.
    Still, I'm not taking any chances with v9.0.x for now, until this is properly fixed OR I need something from what 9 has to offer desperately (no Win8 please ).
      My System SpecsSystem Spec

  5. #45


    Just for grins, I checked out a few older versions of Windows running on VMWare Workstation v9 under a Windows 8 host:

    Windows 95, 98, and ME all work fine -- sound is clear with no distortion.

    Windows 2000 has the same problem as XP ... scratchy/distorted sound. The "fix" is a bit different than with XP. In XP, if you simply load Windows Media Player the issue goes away. In 2000, just loading media player doesn't fix it; you have to actually play something in Media Player -- THEN it's resolved.

    Vista and Windows 7 VM's work perfectly (as I've noted before).

    Definitely a WEIRD issue -- it'll be very interesting to see if it goes away with the next release from VMWare.
      My System SpecsSystem Spec

  6. #46


    Posts : 18
    Windows 7 x64


    Please compare the OS timer resolutions when testing combinations of host and guests.
    Ultimately check in Win2000 whether the resolution increases when WMP just running, and whether it increases when playing.
    I was just moments away from taking the plunge and update vmw to 9.0.1 on my Win7. Something keeps its timer at 1ms and I had good feelings for it, but I'll wait.

    Please check also your host timers when VM is idle and when playing. It'd be interesting to know.

    Also does vmware know about this issue? I can't htink of a scenario which doesn't include testing with XPs. or maybe they've cut on budget so bad that they don't test at all. I think they screwed up something in the core with 8. Just like Photoshop after CS4 - 4 versions and 5 years they didn't fix the problem I (and many others) experience.
      My System SpecsSystem Spec

  7. #47


    VMWare v9 works just fine on a Windows 7 host -- it's on my main machine. The problem is only with a Windows 8 host. [To be precise, it's Windows 8 Pro x32 in my case.] When I get a chance I'll repeat the tests again and see what the timer values are.

    ... I don't know if VMWare is aware of this or not; but there are enough posts about it on various forums (this one; a Windows 8 forum; and several other help sites) that I'd certainly think they've noticed it !!

    By the way, just to confirm this wasn't just a VMWare Tools issue, I removed VMWare Tools from the XP machine, and tried several older versions of VMWare tools (from v6 and v7) ... but the issue's still there when running on VMWare 9.
      My System SpecsSystem Spec

  8. #48


    Posts : 18
    Windows 7 x64


    So, maybe I'm rignt to believe that if I update on my Win7 host to v9, it would work without issues. Still, I'll wait a bit.
    If this is not a problem for you, could you check the host timer of your Win7, both when idle and when a sound is playing in XP VM, also the timer of your Win8. It really would be helpful to know if the timer resolutions are showing consistent relation to the the issue at hatnd across OSes.

    I have the issue with v9 both on Win2003x86/2008x64 hosts. The difference being that on Win2003 v9 causes all kinds of stability issues too.
      My System SpecsSystem Spec

  9. #49


    If you're concerned about whether or not v9 will cause any side effects, I'd suggest you do what I ALWAYS do before installing any significant updates/upgrades: (a) Image the OS partition; (b) make whatever changes I'm considering and test them out; and then, if for any reason I don't like the results, just (c) restore the image.
      My System SpecsSystem Spec

  10. #50


    Posts : 18
    Windows 7 x64


    Of course. I use an old 2009 version of Acronis trueImage Ent. Server from another OS to always image the sys partition before such changes. Still, I've never had an occasion to rely on restoring an image, hopefully . Also restoring an image is not always 100% safe operation - restoring/copying/transferring some 120GB (2x60 - read/write) is always dangerous - a small problem in RAM or hdd, could case some bits to get wrong, etc. so I avoid such things if not urgently necessary.
    7.1.4 serves me well for now. I need strong proofs newer versions are ok before I take any chances. vmware is one of a software of its kind - all other softwares (almost) are just tested inside it without harming the host .
      My System SpecsSystem Spec

Page 5 of 6 FirstFirst ... 3456 LastLast
Strange sound with VMWare Workstation
Related Threads
If you are using VMWare Workstation with Windows 8.1 you will have to reinstall it. I attempted a repair first but that didn't work so I removed and reinstalled, and now all is working just fine. VMWare player worked without having to do a reinstall. . . good luck.
Hello Guys, Hope you all are fine. I want to install some of the programs and OS that I want to test before installing them on my actual computer. But, here I am confused between the two Virtualization Products:- 1) Oracle VM VirtualBox 4.2.16 2) VMware Workstation 9.0.2 Both of these...
Hi there people using VMware workstation release 9.02 (free update from 9) is now available -- and has quite a few updates for Windows 8 as well as a load of other improvements such as updates for vmare tools for a load og Guests. Cheers jimbo
Good news about VMs again. The latest VMware Workstation 9 brings a new UI and it's designed for Windows 8. Read about it here: VMware Announces VMware Workstation™ 9 Also VMware Player 5 is available for download....
Hi Gentlement, VMWare WorkStation 8.0.4 build 744019 does not support Window 8, Am I correct ? Thanks.
Hi there If you have workstation 8.0 or 8.01 it doesn't (as of todays date 31 jan 2012) detect that an update is available. You can download it manually from the vmware site. (Also posted same topic on W7 Forum) Cheers jimbo
Hi all To install W8 developer edition (current version) as a VM with vmware workstation you have to download / upgrade to version 8. Version 7.1X and earlier won't work. Vmware player (current version) gives same problem as vmware workstation 7.1x. When you install choose W7 as the OS...
Eight Forums Android App Eight Forums IOS App Follow us on Facebook