Windows 8 and 8.1 Forums


Unable to connect microsoft account to domain account

  1. #1


    Posts : 18
    8.1 enterprise

    Unable to connect microsoft account to domain account


    I am a system administrator in a large enterprise environment and we are doing a rollout of Windows 8.1. In our image capture we somehow captured a setting that is disabling users from setting up a connected account with their domain account. I am relatively sure that it is in my unattend and I can fix it for machines going forward but I really don't want to have to reimage the machines I've already deployed.

    When I go to connect an account, the "connect to a Microsoft account" option is grayed out and the "some settings are managed by your administrator" message is displayed at the top. This is NOT a group policy object that is applying. The machines are in a test OU and there is absolutely no policy applied. I have searched all through local policy and even did a search through the registry for "account" (that took forever) but have been unable to find any registry key or local policy that would be causing this issue.

    Does anyone have any idea what setting might be causing this?
    Any help is greatly appreciated as I have 30+ machines already out in the environment and the user experience is going to be terrible if I have to reimage them all.

      My System SpecsSystem Spec

  2. #2


    Posts : 467
    Windows 8 Pro


    This is a copy from a technet forums...I haven't seen this issue myself...but it may point you in the right direction.

    There is a policy for this:
    It's Administrative Templates\Windows Components\App Runtime > Allow Microsoft Accounts to be optional
    In 2012, 2012 R2 there is an option in CompConfig\Windows Settings\Security Settings\Local Policies\Security Options that reads "Accounts: Block Microsoft accounts"
    If you don't have 2012 or 2012R2 then you can RSAT from a Windows 8 box and change the settings that way


      My System SpecsSystem Spec

  3. #3


    Posts : 18
    8.1 enterprise


    Sadly, I have seen this exact page in my research this afternoon. In both Computer and User local policies I have this set as not configured. Just for grins I set it to disabled and enabled with no luck.
      My System SpecsSystem Spec

  4. #4


    Posts : 467
    Windows 8 Pro


    in gpedit....here is mine...just a guess though....set to disabled?

    Click image for larger version
      My System SpecsSystem Spec

  5. #5


    Posts : 18
    8.1 enterprise


    You have just saved me literally a weeks worth of work. I had seen that in group policy but it was set to not defined so i bypassed it. Giving it another look, i searched for its referencing registry key and found the value to be 3. If gpedit was showing it to be "not defined" the key shouldn't have even existed in the registry. this is what must have been stuck in our capture. I changed it to 0 and it immediately started functioning. Local Policy now shows the value as "this policy is disabled"
    Just for kicks I deleted the key entirely and it is now back to not defined but the microsoft accounts are still available.

    For anyone else looking for this key it is HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System
    The dword is "NoConnectedUser". Value should be 0

    THANKS!
      My System SpecsSystem Spec

Unable to connect microsoft account to domain account
Related Threads
Can't connect to my Microsoft Account in User Accounts and Family Safety
So as the title said, I can't connect to my Microsoft Account, it said that i don't have a network connected yet I am writing this message using the same laptop, therefore i am stuck with my local account. Any advices on what i should do?
Merge Domain User Account with Local User Account in User Accounts and Family Safety
I have a user with a machine that was setup with Win 8.1 Home. The machine has been upgraded to 8.1 Pro and joined to a domain (WinSrv 2003). I need to get the conten/configuration from their old local machine user profile to their new domain user profile. I tried to copy the contents of their...
Hi, I have a Desktop with Windows 8.1 Enterprise 32-bit. I use internet with 3G Dongle/Data Card. Internet Speed is find. Even I can play and download music and video. I updated Windows 8.1 using Automatic Update. It was successful. AVG Internet Security in installed. Even I updated 3G...
unable to remove microsoft account alias in User Accounts and Family Safety
hi all, I am new to windows 8 and having trouble with my account alias, I recently purchased a new laptop, when I created my alias email address I used a pop 3 email (ntlworld.com) unaware that that these email addresses cannot be used, I am trying to add a Hotmail.co.uk address but it is saying, ...
Microsoft Account over Local Domain in User Accounts and Family Safety
Hello, my Microsoft account is taking over the computer. I have two administrator accounts, both set with equal priorities, but on two different domains, one is a Microsoft Account and the other is the AD (local)domain. The problem is that when I am logged in under my AD account, whenever I do...
Here goes. Since I have installed windows 8 I have been unable to access calendar,people apps and all the other panes. I changed my password a number of times to no avail. So I thought I would just remove my whole Microsoft account and start anew. I removed the account and tried to start another...
10967 When i tried to follow the steps I could not find Accounts and Preferences. So is this a bug or am i doing something wrong?:cry:
Eight Forums Android App Eight Forums IOS App Follow us on Facebook