Windows 8 and 8.1 Forums

Going insane with Access Denied - please please help.

  1. #1

    Going insane with Access Denied - please please help.

    Now that I did my perfect fresh install of Windows 8 to a new SSD, on two machines, and got everything activated and working , I am "this" close to throwing in the towel, buying two more licenes , and upgrade to windows 7. In general I can load apps, and I have restored all my documents (to their own drive) - all good EXCEPT:

    I cannot for the life of me fix these two problems, which are show-stoppers. Would be grateful for any help. I know its dead simple, but I cannot not solve it on my own.

    1) ISSUE ONE - I cannot save a PDF file off the web and save it to my hard drive. When I try to save it to my own area on my data drive, it give me the error below , suggesting I cannot do that, and suggested another folder.
    -I have already set Enable Protected mode OFF.
    -I am signed in as Administrator,
    -I turned UAC off ( or at least on the lowest setting).
    -I turned Avast anti-virus off
    -I turned Windows Defender off
    -I turned Windows Firewall off
    -I even changed the Permissions to give every possible user type full control.
    -I have a licenced activated version of window's 8.

    ..but why cant I save a file in directory of my choosing, on my own data drive!! ? It should not have to be this hard, but I have no idea what else I can possibly do !! I have 4 other Windows 7 machines - none have this issue.

    2) ISSUE TWO - I cannot save a text file in a Program Files subdirectory. I need to edit a script file.
    -I can create file in that subdirectory
    -I can rename files in that subdirectory,
    -I can open files in that subdirectory.
    ..but I get Access denied when I try to save it. Why am I getting Access denied?

    Same settings as in (1). Again it should not have to be this much work to save a text file!

    Click image for larger version
    Click image for larger version

      My System SpecsSystem Spec

  2. #2

    I even tried Take Ownership tips
    -here : I'm an Administrator on windows 8 but still get Access Denied. How - Microsoft Community and
    -here: "Access Denied" or other errors when accessing or working with files and folders in Windows

    I am having the issues to two different machines - both Win 8.1, ; one 8.1 PRO, on fresh installs for each with brand new SSD drives. And on each machine, I have at least two user profiles, and these two issues still exiist on both profiles.

    On Issue 1- the problem is still there.
    On issue 2, even if I take ownership of all directories on all drives, I still have to continuously manually take ownership of any new files I create.

    This is all so very tiring and seemingly hopeless. Surely others have had this problem and have a solution .. or is there indeed no solution?
    Last edited by Mediaman09; 07 Feb 2014 at 05:16.
      My System SpecsSystem Spec

  3. #3

    Posts : 333
    Windows Server 2012 R2 / 8.1

    Issue two:

    Press - Windows key + X
    click "Computer Management"
    locate and click "local Users and groups"
    click "Users"
    Right Click "Administrator"
    Click "set password.."
    Click "Proceed"
    Type in a suitable password and click "Ok"
    Open the "Administrator"
    in the general tab - Untick "Account Disabled"
    Click "Ok"

    Sign out of user and login in as the Administrator account you have just enabled.

    Then navigate to the file you want to change ie your txt file.

    Right Click > Properties > select the Security tab > click Advanced (at the bottom) > under owner click "Change" > Enter "Administrator" in the input box > click ok
    Then under permissison entries, click "add" > click "Select Principal" Enter "Administrator" in the input box > click ok > Under "basic permissions", click Full control > click ok

    Then try changing the txt file again.
      My System SpecsSystem Spec

  4. #4

    Quote Originally Posted by Harrylowt View Post
    ... Then navigate to the file you want to change ie your txt file..
    Thank you, but any solution that requires I repeat the process for every file I might want to edit in future, is not really workable. Besides I could not find any section called local Users and groups' under Computer Management.
      My System SpecsSystem Spec

  5. #5

    Posts : 1,883

    By any chance, did you disable Application Experience service?

    Anyway, you'd have to uninstall your antivirus to test. Disabling alone does not help test at all in things like this.
      My System SpecsSystem Spec

  6. #6

    Newport, South Wales, UK
    Posts : 576
    Windows 10 Pro x64 x2 Windows 10 Enterprise x64, Ubuntu

    The take ownership solution to this type of problem is actually step one of a two stage process, I often come across this type of issue when dealing with shared data drives subsequent to an OS upgrade, this is due mainly to the fact that although we see and use "User Names" the system sees users as their SID reference, this is regenerated by each OS at initialisation. So although the user name may be the same the SID is different and thus prevents access.

    Enough of the reasons now to the practice

    Go to the root of the folder tree you have issues with and follow the normal steps to take ownership

    Now you need to go into the root of the tree again and give your, (Current), Username explicit permissions to access the files, in the case of data folders this would normally be full access.

    As a last step, in the advanced security tab, use the change permissions option to cascade the set permissions at the top level down to the lower levels, ( there is a checkbox to apply the current settings to all lower levels)

    There may be errors as the instruction cascades down and it may be necessary to manually navigate to these sub-trees and reapply the last two steps above, although I have seen quite large drive structures complete without any errors

    This procedure may work for system drives but due to the virtualisation used in modern OS structures, (Vista and later), it may be only partially successful, and should only be used as a last resort.

    Hope this helps
      My System SpecsSystem Spec

  7. #7

    Quote Originally Posted by Barman58 View Post
    Hope this helps
    Bingo Mr. Barman!

    Adding the explicit account names in the Security tab, at the root folder, and letting it propagate, seems to have done it the trick.

    I am assuming that :
    - I will need to repeat the two-step process for any directory or drive that exhibits the issue (not a big deal if its a one-time task)
    - the reason I did not see this on other machines is that those machines were new builds with as brand new drives. This machine was new boot drive but with my current and main data drive ( created prior to Win 8).

    Anyway, great progress on this issue, and thank you again. The insanity has subsided for now!
      My System SpecsSystem Spec

  8. #8

    Newport, South Wales, UK
    Posts : 576
    Windows 10 Pro x64 x2 Windows 10 Enterprise x64, Ubuntu

    As the doctor would say, "Take as prescribed, Always read the label, and repeat as necessary"
      My System SpecsSystem Spec

Going insane with Access Denied - please please help.
Related Threads
Solved Access denied in General Support
HELLO FRIENDS, I just installed win 8. I have two partitions for my hard drive, C and D, of which I can't access to D Drive. It shows " access denied". When I go to the disk management D Drive shows healthy. I've put a screen shot for reference. Please help. ...
Since installing Windows 8, I have been having sporadic problems with access denied. Examples follow: PIMEX is a Personal Information Manager that I have been using through several generations of Windows. When I first converted to Windows 8, this program worked with no problems. Now, however,...
Access Denied - No Read Access in General Support
Access Denied in General Support
Hi everyone! Before I begin, let me state that I did do a search but nothing returned (possibly because my internet is rubbish, lol). I'm having a problem with my Windows 8 installation; I have a file called "saves.txt" located on my C (so C:\saves.txt). I have been editing this file all...
Access Denied in Installation & Setup
Hello I am trying to upgrade from Windows 7 Pro to Windows 8. I have bought the program and I am using the Windows 8 Upgrade Assistant to load the program. However, once it downloads and get to 100% all I get is Access Denied and then download fail. I have looked on the net for an...
Solved Access Denied in General Support
I am getting access denied when attempting to get into a folder. Just recently installed Windows8. I had the same issue with win7, but I managed to resolve it. What do I need to do to get around this? I don't remember ever having had a problem with simply getting into one of my own folders.
Solved Access denied in General Support
heres an odd one, i have an external with music and movies on it, from the library i can access the music folder and play any file i want and in the movies folder i am denied access ,i have to take ownership apparently but im not sure about that as i didnt for the music folder 1921
Eight Forums Android App Eight Forums IOS App Follow us on Facebook