Windows 8 and 8.1 Forums

Store - Re-register in Windows 8 and 8.1

  1. #1
    Store - Re-register in Windows 8 and 8.1

    Store - Re-register in Windows 8 and 8.1
    How to Re-register the Store in Windows 8 and 8.1
    Published by Brink is online now
    09 Nov 2013
    Default Store - Re-register in Windows 8 and 8.1

    Published by

    Brink's Avatar

    Join Date: Jul 2009
    Posts: 22,577

    How to Re-register the Store in Windows 8 and 8.1

    information   Information
    This tutorial will show you how to re-register the Store app to fix the Windows Store when it has the following issues below in your account in Windows 8, Windows RT, Windows 8.1, and Windows RT 8.1.

    After upgrading to Windows 8.1, the Store may not start at all.

    PC settings doesn't open. For example, when you click/tap on Change PC settings in the Settings charm.

    When you try to open the Store, it shows a progress ring, but never finishes loading.

    Click image for larger version

    The Store tile on your Start screen still shows the number of available app updates when there's actually not any available.

    Name:  Store_Tile_Number.png
Views: 60139
Size:  5.2 KB

    Here's How:

    1. Open a command prompt.

    2. In the command prompt, copy and paste the command below, and press Enter. (see screenshots below)

    powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\WinStore\AppxManifest.XML
    Click image for larger version

    Click image for larger version

    3. When finished, you can close the command prompt, and try opening the Store again.

    Note   Note
    If you get the 0x8007064A error in quotes below, then it means that the Packages registry key below does not have System set as it's owner. For how, see step 3 in Option Three here: How to "Take Ownership" of a File, Folder, Drive, or Registry Key in Windows 8 and 8.1. Afterwards, try again.

    (registry key)
    HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\Repository\Packages

    error 0x8007064A: Cannot register the request because the following error was encountered while initializing the windows.repositoryExtension extension: The
    configuration data for this product is corrupt. Contact your support personnel.

    That's it,

  2. #1

    Hi Shawn
    Wonder if you can help? I have the problem where the store won't open but just sits there showing off ts 'progress' ring. My machine was purchased 18 months ago with Win 8 pre-installed. I upgraded to win 8.1 via the store as soon as it was released. There are 3 users on the machine and the other two work perfectly. My account worked fine up until about a month ago when I discovered the problem with the store (I only use the store infrequenyly so the problem may have existed longer). All the apps I had previously installed still work just fine. If I create a new user they can access the store just fine. it's just me it hates! I have tried too many things to list here and just tried your suggestion of re-registering the store - to no avail. Have you got any other ideas? (I suspect my account might be corrupt but haven't a clue how to fix it).

      My System SpecsSystem Spec

  3. #2

    Posts : 22,577
    64-bit Windows 10

    Hello Bob, and welcome to Eight Forums.

    You might see if going through the listed troubleshooting steps in the tutorial below may be able to help for now.

    Apps and Tiles Not Working or Responding: Fix in Windows 8
      My System SpecsSystem Spec

  4. #3

    Hi Brink
    thanks for the response. I have already tried just about everything in the tutorial you recommend. Quite a lot of them do not apply in my case. I do not get any error messages, my apps (with the exception of the store) ALL work correctly. There are two other users on the machine and they can both access the store without problems, if I create a new user they can access the store correctly. Under the guidance of somebody called Rajesh from the "Microsoft Community" (who now seems to have gone into hiding!) I have also tried something very convoluted which I will try to explain.

    Assume my own, existing account to be 'Account A'. I created a new, local, 'Account B'. I then converted my 'Account A' to a local account by disconnecting it from my Microsoft Account. Next I copied all the files in
    C:/users/'Account A' with the exception of Ntuser.dat, Ntuser.dat.log1, Ntuser.dat.log2 and Ntuser.ini to
    C:/users/'Account B'. (there was a problem here as it 'hung' when 92% complete with loads of files that it said it couldn't copy for various reasons - I proceeded with the rest of the procedure anyway). Then I checked that I could log in to 'Account B' (I could). Finally I connected 'Account B' to my Microsoft Account, rebooted the machine and logged into 'Account B' - the reslt was that 'Account B' had full access to the store and all my apps. The big problem being that lots of things on the desktop were not working correctly. This has all but convinced me that one or more of the files that I did not copy is causing the problem but I have no idea how to replace the suspect files. (I rather imagine that this is really a matter for Microsoft to solve but I'm not holding my breath). I hope you followed the logic of all the above and perhaps coe up with some new idea?

    Either way I hope you will respond even if only to say "sorry, can't help" rather than just walk away as Rajesh seems to have done.
      My System SpecsSystem Spec

  5. #4

    Posts : 22,577
    64-bit Windows 10

    Using a new account was going to be my next suggestion as well.

    To fix what you have now, delete Account B. Create a new Account B as a Microsoft account, and sign in to it. This time only copy files you want from the user profile folders (ex: "C:\Users\Account A"\Documents") in "Account A" to the corresponding folders in "Account B".

    When everything checks out ok, you can delete "Account A" when ready.
      My System SpecsSystem Spec

  6. #5

    Wow! That was a REALLY fast response - thanks. I'll try that shortly but here's another thing to consider - some of my desktop programs ('Pixfiler' comes to mind) don't work in 'Account B' because their data is indexed in C:/users/'Account A'/Skydrive etc, which, of course is now c:/user/'Account B'/Skydrive - a quite different location as far as Pixfiler is concerned. Also, which came as a huge surprise to me, when you 'remove' an account such as 'Account B' it leaves behind an empty C:/users/'Account B' folder which seems to be locked by the system and cannot be deleted. If you then recreate 'Account B' it does not use that empty folder but actually creates yet another new one with a slightly different name - odd or what? I'll let you know how I get on doing it your way a bit later.
      My System SpecsSystem Spec

  7. #6

    oh dear! I think perhaps you have to copy files from one user folder to another with them both as local accounts. I have just tried it your way and now I am completely stymied. First off - the new account woudn't let me do anything much at all. I guessed that was because the original account was still connected so I disconnected it. The new account allowed nme to connect to the store but I couldn't set the mail app account. I decided to forget it and reconnect my original account. Trouble is it told me I needed to verify the account by doing what it told me in an email to a secondary email account. that email gave me a code but no instructions as to what to do with it. Now I'm stuck with NO account that will work on the start screen.
      My System SpecsSystem Spec

  8. #7

    Posts : 22,577
    64-bit Windows 10

    It doesn't matter what type of accounts they are to just copy the files from the old to the new. You won't be copying the entire folders, just the specific files (ex: documents, pictures, etc...) that you want to keep.

    At this point, I think it would be best to back up anything you want to keep to another location, then reset Windows.
      My System SpecsSystem Spec

  9. #8

    Brink - I have everything backed up luckily. All the same I have been avoiding resetting windows like the plague - remember this is a machine that has been in constant use by three people for 18 months. I believe that if I reset windows all that will be left is the data? All the programs/utilities/apps etc that have been installed in that time wll be lost. That will require hours of downloading and even then I doubt we could recover all the various keys and licences etc required to get everything working. I it keeps telling me I need to verify my microsoft account (which is an outlook account that I can access ok via a browser) -to do that I have to follow the non-existent directions in their email. I'm sure the last two times I did this there was a box that I just popped their verificatio code in but there's no sign of it now.
      My System SpecsSystem Spec

  10. #9

    Posts : 22,577
    64-bit Windows 10

    Did you use the method below to verify your Microsoft account in Windows?

    Microsoft Account - Verify in Windows 8.1
      My System SpecsSystem Spec

Page 1 of 4 123 ... LastLast
Store - Re-register in Windows 8 and 8.1
Related Threads
Hi, I have only been using Win 8.1 for about a month and I notice that every day or so I get the following 1008 Event viewer error: The Open Procedure for service ".NETFramework" in DLL "C:\windows\system32\mscoree.dll" failed. Performance data for this service will not be available. The...
Hello! I use a really really old music production mastering software called t-racks 24 which I'm dependant on and I don't want to buy a new version because of this. I really like the old version and see no reason to stop using it. Considering it being so old I wouldn't expect any support from...
Solved Register Link? in Site Stuff
Hi. I just signed up! But, When I signup, I can't find any "Register" link in the site. By the way, as webmaster I know what is the register link of vbulletin. But, a newbie in forums may difficult to find the register link! I think, this is very important and to be noticed by the admin. ...
Re-register Music app? in Software and Apps
Is there a way this can be done to the Music app? I can't get it to work after all of my metro apps disappeared and I tried to re-install them. I got all of them working by using the option to repair them in the store.
Solved cannot register MSCOMCTL.OCX in Drivers & Hardware
Hi there. Have been trying to install a network printer, Konica-Minolta MC5430DL under Windows 8, 64bit. The setup starts, but asks for a file MSCOMCTL.OCX. After looking up this problem online, I find conflicting reports about it having to be in SYSWOW64. Others say in System32. Either way, the...
windows 8 wont register in Installation & Setup
I bought 3 upgrade copys of 8 when the offer first came out I also took advantage of the free media centre on my pc and laptop I was doing updates on my laptop today and noticed it says its not registed when I try to put the product key I have for the copy for my laptop it says its valid but when...
More... This promo is for upgrading newly purchased Windows 7 PCs to Windows 8 Pro.
Eight Forums Android App Eight Forums IOS App Follow us on Facebook