What's new

Windows Store Error - 0x80244022 - Unable to purchase apps

ssbtech

Member
Member
Having a little trouble here with downloading apps from the store.

I'm getting an error: "Something happened and your purchase can't be completed. Error code: 0x80244022". This is for a free app.

I've Googled and very little comes up. I've performed the Windows Store Reset as well as the Windows Update Repair (despite Windows update working properly) to no avail.

One site suggested converting the user account to a local account from a Microsoft Account, but that didn't work either.

Any tips would be appreciated.

Thanks!
 

My Computer

System One

  • OS
    Windows 7
    System Manufacturer/Model
    Built by me
    CPU
    AMD Quad Core something
    Motherboard
    Asus
    Memory
    5GB
    Graphics Card(s)
    nVidia something hacked with Quadro drivers
    Sound Card
    Asus Xonar
    Monitor(s) Displays
    2x LCD
    Hard Drives
    A few of them
    PSU
    Corsair HX750
    Case
    Antec Sonata Elite
    Cooling
    Couple of fans
    Keyboard
    Logitech backlit wireless
    Mouse
    Logitech rechargable Laser Mouse
    Internet Speed
    25Mbps
    Country Flag
    Canada

veggymight

New Member
I am having the EXACT problem you describe. It seems to have started within the last few days. The weird thing is that it started not only on my laptop but also on my desktop computer at approximately the same time. Both are running Windows 8.1. That would suggest it is Windows Update-related or perhaps account-related.

Please do reply if you find a fix and I will do the same.

Pete
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    Laptop
    System Manufacturer/Model
    Yoga 2 Pro
    CPU
    Intel i7
    Country Flag
    USA
    State/Region Flag
    us washington

ssbtech

Member
Member
Good to know I'm not alone :p

I'm guessing a recent update caused an issue. I haven't downloaded any apps from the Windows Store for a while, so I can't say when it started.
 

My Computer

System One

  • OS
    Windows 7
    System Manufacturer/Model
    Built by me
    CPU
    AMD Quad Core something
    Motherboard
    Asus
    Memory
    5GB
    Graphics Card(s)
    nVidia something hacked with Quadro drivers
    Sound Card
    Asus Xonar
    Monitor(s) Displays
    2x LCD
    Hard Drives
    A few of them
    PSU
    Corsair HX750
    Case
    Antec Sonata Elite
    Cooling
    Couple of fans
    Keyboard
    Logitech backlit wireless
    Mouse
    Logitech rechargable Laser Mouse
    Internet Speed
    25Mbps
    Country Flag
    Canada

popeye

New Member
VIP Member
Guru

My Computer

System One

  • OS
    Windows 8.1 Pro 64-bit
    Name
    Steve
    Computer type
    Laptop
    System Manufacturer/Model
    Acer V3 771G-6443
    CPU
    i5-3230m
    Motherboard
    Acer VA70_HC (U3E1)
    Memory
    8GB DDR3 PC3-12800 (800 MHz)
    Graphics Card(s)
    HD4000 + GeForce GT 730M
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    17" Generic PnP Display on Intel HD Graphics 4000
    Screen Resolution
    1600x900 pixels
    Hard Drives
    Samsung SSD 850 EVO 250 GB
    ADATA SSD SP900 128GB
    PSU
    90 watt brick
    Occupation
    Old Geek
    Mouse
    Bluetooth
    Antivirus
    Comodo
    Other Info
    Asus RT-AC56R dual-band WRT router (Merlin firmware). Intel 7260.HMWWB.R dual-band ac wireless adapter.
    Country Flag
    USA
    State/Region Flag
    us arkansas

NovaNed

New Member
I'm also being affected by this problem, exactly like ssbtech. Like you guys, it only seems to have happened since I allowed my last batch of updates to install a few days ago. Can't find much yet on this except for generic suggestions such as running MS's 'AppsDiagnostic.diagcab' tool, resetting the Store cache etc. I'll feedback any leads I find on a solution but hopefully one will surface here soon.
 

My Computer

System One

  • OS
    Windows 8.1
    State/Region Flag
    ca novia scotia

bigboy12

New Member
I have this exact same problem. In fact, I have many problems. Tell me, can you access the list of apps you own in the Windows Store?

I have also tried everything you said in the main post in vain.

EDIT:

Well, what do you know? I just spammed try again on an App and now everything works.
 

My Computer

System One

  • OS
    Windows 8.1 x64

Dcorwin

New Member
I am very new to Windows 8.1, I just bought this new ACER All in one yesterday. Did the normal set-up procedures and downloaded a ton of windows updates. I cannot use the store for most games but can use it for apps such as Netflix or Facebook.

Error Code: 0x80244022
 

My Computer

System One

  • OS
    Windows 8.1 x64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    ACER Aspire Z3-615
    CPU
    Intel(R) Core(TM) i3-4130T CPU @ 2.90GHz
    Memory
    8GB
    Graphics Card(s)
    Intel(R) HD Graphics 4400
    Monitor(s) Displays
    23" ISP LED Full Touch with 10 Point Support
    Screen Resolution
    1920 x 1080
    Hard Drives
    1 TB HDD (7200 rpm)
    Keyboard
    Logitech mk520 Wireless
    Mouse
    Logitech mk520 Wireless
    Internet Speed
    30Mbps
    Antivirus
    Mcafee / Webroot
    Country Flag
    USA
    State/Region Flag
    us texas

bigboy12

New Member
I am very new to Windows 8.1, I just bought this new ACER All in one yesterday. Did the normal set-up procedures and downloaded a ton of windows updates. I cannot use the store for most games but can use it for apps such as Netflix or Facebook.

Error Code: 0x80244022

Well, things started working here for no reason, but I get the feeling that I got lucky. I'm waiting for a logical solution as well.

EDIT: There you go. Same error here. I can not access the list of my apps again.
 

My Computer

System One

  • OS
    Windows 8.1 x64

scatman12

New Member
I have a new Surface Pro 3 that I picked up on Thursday. I could download apps from the store yesterday, but today I'm getting the same error message. Maybe Microsoft is having some server issues today.
 

My Computer

System One

  • OS
    windows 8.1
    Computer type
    Tablet

ejtannen

New Member
I have this exact same problem. In fact, I have many problems. Tell me, can you access the list of apps you own in the Windows Store?

I have also tried everything you said in the main post in vain.

EDIT:

Well, what do you know? I just spammed try again on an App and now everything works.

"Spammed" as in hitting Try Again, over and over?

I got my Dell pad back from Dell and they upgraded everything including the OS and, like all the others, am in the same leaky boat.

Having been around a while, should I just wait until there is an update to fix the update?

Thanks,
 

My Computer

System One

  • OS
    Windows 8.1

Dcorwin

New Member
Same here, Yesterday I was able to download applications like Netflix and Facebook. For the sake of trial and error I removed Facebook and tried to re-install. Ended up getting the same error code. Looks like we will be waiting until Microsoft realizes there is an issue....Or one of us here decides to call in and report the error. Either way Seems like I will just have to wait for now.
 

My Computer

System One

  • OS
    Windows 8.1 x64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    ACER Aspire Z3-615
    CPU
    Intel(R) Core(TM) i3-4130T CPU @ 2.90GHz
    Memory
    8GB
    Graphics Card(s)
    Intel(R) HD Graphics 4400
    Monitor(s) Displays
    23" ISP LED Full Touch with 10 Point Support
    Screen Resolution
    1920 x 1080
    Hard Drives
    1 TB HDD (7200 rpm)
    Keyboard
    Logitech mk520 Wireless
    Mouse
    Logitech mk520 Wireless
    Internet Speed
    30Mbps
    Antivirus
    Mcafee / Webroot
    Country Flag
    USA
    State/Region Flag
    us texas

teflonn

New Member
I just purchased a new laptop today and am using Windows 8 (and the app store) for the first time. I'm glad to know that what I thought was a glitch isn't unique to me!
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    Laptop
    System Manufacturer/Model
    HP Envy 15
    Browser
    Firefox
    Antivirus
    Norton
    Country Flag
    USA

My Computer

System One

  • OS
    Windows 8.1.1 Pro with Media Center
    Name
    David A. Bailey
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Gateway
    CPU
    AMD K140 Cores 2 Threads 2 Name AMD K140 Package Socket FT1 BGA Technology 40nm
    Motherboard
    Manufacturer Gateway Model SX2110G (P0)
    Memory
    Type DDR3 Size 8192 MBytes DRAM Frequency 532.3 MHz
    Graphics Card(s)
    ATI AMD Radeon HD 7310 Graphics
    Sound Card
    AMD High Definition Audio Device Realtek High Definition Audio USB Audio Device
    Monitor(s) Displays
    Name 1950W on AMD Radeon HD 7310 Graphics Current Resolution 1366x768 pixels Work Resolution 1366x76
    Screen Resolution
    Current Resolution 1366x768 pixels Work Resolution 1366x768 pixels
    Hard Drives
    AMD K140
    Cores 2
    Threads 2
    Name AMD K140
    Package Socket FT1 BGA
    Technology 40nm
    Specification AMD E1-1200 APU with Radeon HD Graphics
    Family F
    Extended Family 14
    Model 2
    Extended Model 2
    Stepping 0
    Revision ON-C0
    Instruction
    Occupation
    Trying to live a good life before I die.
    Browser
    Opera 24.0
    Antivirus
    Avast Internet Security
    Country Flag
    USA
    State/Region Flag
    us virginia

vmariet7

New Member
Very new to windows 8.1.. switched from apple , very different! Got encore tablet yesterday and everything worked fine until this afternoon. Went to download apps and the same problem... everything works that is downloaded..so confused. Hoping issue works itself out soon..if anyone figures anything out please comment!! Thank you!
 

My Computer

System One

  • OS
    windows 8.1 with bing
    Computer type
    Tablet
I get this---

screenshot_180.jpg

&

screenshot_180.jpg

Bad Store & "Apps". :(
 

My Computer

System One

  • OS
    Windows 8.1.1 Pro with Media Center
    Name
    David A. Bailey
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Gateway
    CPU
    AMD K140 Cores 2 Threads 2 Name AMD K140 Package Socket FT1 BGA Technology 40nm
    Motherboard
    Manufacturer Gateway Model SX2110G (P0)
    Memory
    Type DDR3 Size 8192 MBytes DRAM Frequency 532.3 MHz
    Graphics Card(s)
    ATI AMD Radeon HD 7310 Graphics
    Sound Card
    AMD High Definition Audio Device Realtek High Definition Audio USB Audio Device
    Monitor(s) Displays
    Name 1950W on AMD Radeon HD 7310 Graphics Current Resolution 1366x768 pixels Work Resolution 1366x76
    Screen Resolution
    Current Resolution 1366x768 pixels Work Resolution 1366x768 pixels
    Hard Drives
    AMD K140
    Cores 2
    Threads 2
    Name AMD K140
    Package Socket FT1 BGA
    Technology 40nm
    Specification AMD E1-1200 APU with Radeon HD Graphics
    Family F
    Extended Family 14
    Model 2
    Extended Model 2
    Stepping 0
    Revision ON-C0
    Instruction
    Occupation
    Trying to live a good life before I die.
    Browser
    Opera 24.0
    Antivirus
    Avast Internet Security
    Country Flag
    USA
    State/Region Flag
    us virginia

labrat

New Member
I am experiencing the exact same thing. New Surface Pro 3 out of the box yesterday, could install from the Store. Today, can't do it with error code 0x80244022. Did run Updates, but can't recall whether I installed from Store before or after Windows Update. Since it was new and I wasn't going to really lose anything but a day of screwing around with it, I did a factory reset on it. After factory reset - with no run of Windows Update - same error still occurs.
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    Tablet
    System Manufacturer/Model
    Surface Pro 3
    Memory
    4 GB

gettingaround

New Member
::AMAZING::I have had quite the experience since the 2nd of Nov. I am on my 3rd Surface Pro 3; all from Best Buy. The first worked amazing and I was so happy; however, on the 3rd day I went to turn it on and it would not turn on. It took about 25 minutes of every few minutes, trying different hold times. Googled it a and found a reset with power and volume keys. Same thing happened the day after, so I took the SP3 back and they exchanged it, no problem. Second one, I get home, turn it on, first thing is to update.... won't do a windows update, froze for about an hour, turned off. I let it chill for over 5 mintues, then I tried to turn it on, no response, seriously? Got it going about 5 minutes later and I went to do the update, it did the update, but in a much different way than the first SP3 I had. I felt as if the 1st was one big update with with one update after the initial restart, however the second SP3 needed 4 individual updates with restarts. Worked well for 2 days, then twice it took over 10 minutes to start, no response to the start button. I was thinking, Best Buy is going to think I'm nuts.

Took
it back, Best Buy was very cool, no hassle, exchanged it out. #3!!! Updates went well, but I can't download apps from the Microsoft App Store. I've been on the internet for the last 4 hours, trying to find a solution & I just found this forum and felt the need to share this story. I guess I will wait to see if they release a firmware update in the next couple days, if not, I'll have to get a different device, this is crazy. I'm supposed to go to Germany in Dec and I have to have a reliable device, too bad, I love this thing! It's SO practical! FK!

thanks, for reading, open to suggestions.

RK
 

My Computer

System One

  • OS
    Surface Pro 3 8.1

Dcorwin

New Member
I guess I will wait to see if they release a firmware update in the next couple days, if not, I'll have to get a different device, this is crazy. I'm supposed to go to Germany in Dec and I have to have a reliable device, too bad, I love this thing! It's SO practical! FK!

thanks, for reading, open to suggestions.

RK

I think they will, I also think your device is fine. This is not limited to a certain device but to the store itself. I vote for giving it a couple days and seeing what comes of it.
 

My Computer

System One

  • OS
    Windows 8.1 x64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    ACER Aspire Z3-615
    CPU
    Intel(R) Core(TM) i3-4130T CPU @ 2.90GHz
    Memory
    8GB
    Graphics Card(s)
    Intel(R) HD Graphics 4400
    Monitor(s) Displays
    23" ISP LED Full Touch with 10 Point Support
    Screen Resolution
    1920 x 1080
    Hard Drives
    1 TB HDD (7200 rpm)
    Keyboard
    Logitech mk520 Wireless
    Mouse
    Logitech mk520 Wireless
    Internet Speed
    30Mbps
    Antivirus
    Mcafee / Webroot
    Country Flag
    USA
    State/Region Flag
    us texas

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top