• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Windows Search - access denied to start service


rogertad

New Member
Posts
9
#1
hi there!

My Windows Search is not working.

I try to start it from services management but the error 5 (access denied) rises (with user SYSTEM) :huh:

I tried create another user with admin privilegies, but it is not working as well, error 1297 rises :cry:


I think I added some folder to indexing and COULD this folder is not with SYSTEM privilegies...BUT I cannot see the folder indexed because the service IS NOT WORKING :mad:

any clue ?
 

My Computer

System One

  • OS
    Windows 8

Vadikan

(*.*)
Power User
Posts
480
#3
Hello,

In addition to the post above:

1. Run sfc /scannow in the elevated command prompt.
If it can't repair files, follow http://www.eightforums.com/tutorials/26512-dism-fixing-component-store-corruption-windows-8-a.html, then repeat SFC.

2. Restore Windows Search service settings using the REG-file. http://www.eightforums.com/tutorials/9413-services-restore-default-services-windows-8-a.html

3. Open the registry editor and make sure that SYSTEM has Full Control and Read on
Code:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\WSearch
4. Open the classic Control Panel (control.exe) and search for search. Use the troubleshooter you find in there. Ignore a message about incorrect permissions, if you see one.

Report the results of each step in the next post.
 

My Computer

System One

  • OS
    Windows 8 Pro x64
    Computer type
    Laptop
    System Manufacturer/Model Number
    HP Pavilion dv7t (17.3'', i7-2630QM, HD 6770M 1Gb, 8Gb RAM, 2 [email protected] + 1 [email protected])

rogertad

New Member
Posts
9
#4
Hi guys...I appreciate all the proposals...but I had made some procedures, one of I change the permissions in regedit set LOCAL SYSTEM with full control. and after that, my private user lost completely the admin permissions... I couldnt access admin processes, as taskmgr, regedit, services msg etc...

I would like to thank you all to the ideias, but I did have to resign and formated my windows to the frabric configs.. :/


BTW: the ideias had been done. I post the print screen in brazilian site: Windows Search - acesso negado para iniciar serviço - FórumGdH

Thanks all!!!
 

My Computer

System One

  • OS
    Windows 8
Posts
7
#5
Everyone:

I was troubleshooting a very similar error for a couple hours, and I tried a couple things, of course. When I started or stopped the Windows Search service, I had an 'Error 2.' My IE pages were talking to the windows search code, because it would send an error every minute to the event viewer. I could not start the Windows Search service, and it was counting the number of times that it failed in my event log, and it was a couple thousand times.

Steps that I did:
1) virus scans/maleware scans
2) sfc /scannow
3) running the "DISM /Cleanup-Image" tool for both from a command prompt and also from a powershell.
4) ran another sfc /scannow
5) rebuild the indexer from the control panel from the advanced tab
6) tried the computers Troubleshooting Tool for the Indexing
7) checked the services

Alot of 'yuck, yuck, yuck, yuck!!!!' Nothing worked. I was lucky to Google and find this link.

[FIX] "Windows Search'' Service Failed To Start In Windows 8.1 - Kapil Sparks?
[FIX] "Windows Search'' Service Failed To Start In Windows 8.1 - Kapil Sparks?

8)a)launched regedit
b) Went to this key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search\FileChangeClientConfigs
c) On the right pane, I changed VALUE DATA from 0 to 1
d) clicked OK
e) rebooted computer

I would check the event viewer and the errors were still launching, so I had to continue with the link and went to the regedit again.

9) Went to this folder: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search\FileChangeClientConfigs
10) Renamed the folder FileChangeClientConfigs to FileChangeClientConfigsBK
11) rebooted the computer again
12) I now have 2 versions of the FileChangeClient Configs, and I could still start/stop the Windows Search service, and NOW the error messages are no longer timestamped in the eventvwr.

Of course, I had a backup of my registry already on my HDD when troubleshooting earlier, so this my logic why I did not mention about saving a backup of my registry. I also cleaned-out all of my logs in the eventvwr, because having all of those entries takes up space too.
 
Last edited:

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    System Manufacturer/Model Number
    p7-1257c
    CPU
    A8-3820 APU
    Motherboard
    AMD
    Memory
    8 GB RAM
    Graphics Card(s)
    AMD Radeon HD 6550D
    Sound Card
    IDT High Definition Audio CODEC
    Monitor(s) Displays
    HP 2511A
    Screen Resolution
    1371x771
    Keyboard
    Logitech K350
    Mouse
    Logitech M350
    Internet Speed
    ping=41ms, download speed=2.23ms, upload speed=1.10mps
    Browser
    IE 10, Google Chrome
    Antivirus
    Avast