What's new

Solved Windows explorer Search doesn't work for Google drive fold

rodion15

Member
Member
When I open Windows Explorer (Windows 8.1) the search box on upper-right corner doesn't work in the Google drive folder. It works on all other folders. That is: when I enter the name of a file inside this folder, the search returns "0 items".
Capture.PNG
 

My Computer

System One

  • OS
    WINDOWS 8

rodion15

Member
Member
SOLVED (for Windows 10, I guess for 8.1 it should work as well)!.
I got this answer in google drive forum:


Hello Antonio,

Thank you for contacting us. Try this:


Go to the actual folder in its C:\Users\<your name>\Google Drive\ (NOT the Google Drive folder listed under 'FAVOURITES' which is a shortcut).
Right click 'Google Drive' > Security tab > Advanced > Click your username (mine showed <not inherited>) > Click 'Change Permissions' > Check the 'Include inheritable permissions...' box > Click ok.
Search indexing of Google Drive should then begin in the background.


On Windows 10, the steps might be slightly different: After selecting your username on the Advanced page, click 'Enable inheritance' on the bottom left corner. After pressing 'ok' go back to indexing options and add the Google Drive folder (again, not the shortcut, but from the Users folder)


Let me know if that helps. Best of luck to you!


Just to add: A user pointed out that you may need to set permissions.


First check the permissions of the "Google Drive" folder. If you do not see an entry for "SYSTEM" with full permissions then follow these steps to set it up:


1. Navigate to the location of the "Google Drive" folder. It will be something like "C:\Users\[USERNAME]"
2. Right click on your "Google Drive" folder and select "Properties".
3. Select the "Security" tab.
4. Click "Edit"
5. Click "Add"
6. Type "system" (case is NOT sensitive) and Click "OK"
7. Check the top box for "Full control" (this should select all the boxes able to be modified)
8. Click "OK" and wait while it applies the permissions. (the time this will take depends on the speed of your computer and the number of files in your "Google Drive" folder)



Hope that helps. Best of luck to you!


-Tyler M

It worked!: I had to remove and then add the
google drive folder in indexing though, then it instantly indexed and search worked.Many many thanks, I've been chasing this problem since Windows 7 and Windows 8 then 8.1 (I think I tried something like this in 7/8.1, though, advised in another forum answer, strange). I didn't need to permissions for system, just the inherit stuff for my administrator user.





 

My Computer

System One

  • OS
    WINDOWS 8
Top