• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Windows Defender don't start-up immediately


ritahubert

Member
Member
Posts
37
#1
Hello,

I am using Windows Defender in W8.

I see that the Defender becomes only active after a few minutes.

If the Defender is activated before than everthing is in red , and unable to start it.

The fault code is than 0x80070426.

But as explained already after a few minutes everthing is oké.

Question:
*does this mean that during that time one is not protected?
*maybe is it technically as such
*if no is there a solution for it?

Regards
RitaHubert
 

My Computer

System One

  • OS
    windows 8
    Computer type
    Laptop

my2cents

Veni, Vidi, Vici
VIP Member
Guru
Posts
2,191
#2
Seems like Windows Defender is failing to update and the reason could be due to a licensing issue. So, is you Windows 8 installation activated? If so, is the Software Licensing Service running? To check, run servcies.msc:

Screenshot (50).png
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    CPU
    Intel G2020
    Motherboard
    ASRock B75M-DGS R2.0
    Memory
    8GBs @ 1333 MHz
    Hard Drives
    Samsung 840 EVO
    PSU
    400w
    Internet Speed
    57/11

ritahubert

Member
Member
Posts
37
#3
Hello,
Thanks for your technical advice.

The indicationon services is the same as you presented.

I don't understand : is your W8 activated?

I tried to make a trigger into the taskplanner for the Windows defender but no result.

I am getting the impression that the delay is normal?
Our am i missing something?

PS: the notification tool for Windows Defender is very good (again thanks).

Regards
RitaHubert
 

My Computer

System One

  • OS
    windows 8
    Computer type
    Laptop

topgundcp

Well-Known Member
VIP Member
Guru
San Jose - California

Posts
2,847
#4
Services set to Automatic will start during the boot process while services set to Automatic ( Delayed start) will start shortly after boot.

By default, Windows Denfender was set to Automatic(Delayed Start) so that the boot up process will be a little faster and in addition, Windows Defender also depends on the RPC (Remote Procedure Call) service to start before in order for it to start You can change it from "Automatic(Delayed start)" to "Automatic".

  1. Win+X->Computer Management->Services and Application->Services
  2. Double click on Windows Defender service and change it to "Automatic"
 

My Computer

System One

  • OS
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home Brewed
    CPU
    I7 4970K OC'ed @4.7 GHz
    Motherboard
    MSI-Z97
    Memory
    16 GB G-Skill Trident X @2400MHZ
    Graphics Card(s)
    NVIDIA GeForce GTS 450
    Sound Card
    X-Fi Titanium Fatal1ty Professional Series
    Monitor(s) Displays
    Dual HP-W2408
    Screen Resolution
    1920X1200
    Hard Drives
    256 GB M2 sm951, (2) 500GB 850EVO, 5TB, 2 TB Seagate
    PSU
    Antec 850W
    Case
    Antec 1200
    Cooling
    Danger Den H20
    Keyboard
    Logitech
    Mouse
    Logitech Performance Mouse MX
    Internet Speed
    35/12mbps
    Browser
    Firefox

ritahubert

Member
Member
Posts
37
#5
Hello,
Thanks for the information.

The point is that RPC is set to auotmatic but the Windows Defender is indeed set as delayed but ik can change it (grey)

Regards
RitaHubert
 

My Computer

System One

  • OS
    windows 8
    Computer type
    Laptop

my2cents

Veni, Vidi, Vici
VIP Member
Guru
Posts
2,191
#6

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    CPU
    Intel G2020
    Motherboard
    ASRock B75M-DGS R2.0
    Memory
    8GBs @ 1333 MHz
    Hard Drives
    Samsung 840 EVO
    PSU
    400w
    Internet Speed
    57/11

my2cents

Veni, Vidi, Vici
VIP Member
Guru
Posts
2,191
#7

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    CPU
    Intel G2020
    Motherboard
    ASRock B75M-DGS R2.0
    Memory
    8GBs @ 1333 MHz
    Hard Drives
    Samsung 840 EVO
    PSU
    400w
    Internet Speed
    57/11

ritahubert

Member
Member
Posts
37
#8
Hello,

Thanks for the information

Yes, my W8 is activated ...a product key is shown
I am not in favor to use restore points ...who nows how far i have to go back ...
For carrying out the proposed action i will need some time to read everthing an execute it afterwards.

I will keep you informed.

Regards
RitaHubert
 

My Computer

System One

  • OS
    windows 8
    Computer type
    Laptop

topgundcp

Well-Known Member
VIP Member
Guru
San Jose - California

Posts
2,847
#9
You need to stop the Windows Defender service first then you can change it to "Automatic".
 

My Computer

System One

  • OS
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home Brewed
    CPU
    I7 4970K OC'ed @4.7 GHz
    Motherboard
    MSI-Z97
    Memory
    16 GB G-Skill Trident X @2400MHZ
    Graphics Card(s)
    NVIDIA GeForce GTS 450
    Sound Card
    X-Fi Titanium Fatal1ty Professional Series
    Monitor(s) Displays
    Dual HP-W2408
    Screen Resolution
    1920X1200
    Hard Drives
    256 GB M2 sm951, (2) 500GB 850EVO, 5TB, 2 TB Seagate
    PSU
    Antec 850W
    Case
    Antec 1200
    Cooling
    Danger Den H20
    Keyboard
    Logitech
    Mouse
    Logitech Performance Mouse MX
    Internet Speed
    35/12mbps
    Browser
    Firefox

topgundcp

Well-Known Member
VIP Member
Guru
San Jose - California

Posts
2,847
#10
Please ignore the above message. Here's what I found:
Microsoft must have updated and disabled the option to allow user to change the Start Up type to Automatic. I have done this in the past and now the option is greyed out.

To satisfy myself, I reloaded the original saved image and indeed I was able to change the Start Up type to Automatic as shown in the screen shot below:


It makes sense since the RPC service needs to start first so that Windows Defender (MsMpeng.exe) will not fail.

In addition, to avoid any conflict if you have any third party Anti Virus software installed, Windows will disable Windows Defender.
 

Attachments

My Computer

System One

  • OS
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home Brewed
    CPU
    I7 4970K OC'ed @4.7 GHz
    Motherboard
    MSI-Z97
    Memory
    16 GB G-Skill Trident X @2400MHZ
    Graphics Card(s)
    NVIDIA GeForce GTS 450
    Sound Card
    X-Fi Titanium Fatal1ty Professional Series
    Monitor(s) Displays
    Dual HP-W2408
    Screen Resolution
    1920X1200
    Hard Drives
    256 GB M2 sm951, (2) 500GB 850EVO, 5TB, 2 TB Seagate
    PSU
    Antec 850W
    Case
    Antec 1200
    Cooling
    Danger Den H20
    Keyboard
    Logitech
    Mouse
    Logitech Performance Mouse MX
    Internet Speed
    35/12mbps
    Browser
    Firefox

ritahubert

Member
Member
Posts
37
#11
Hello;
Reply to topgundcp : no change after disabling it

Repyl to my2cents
after dispart /list volume i receive
vol 0 C Acer boot
1 Recovery hidden
2 ESP system
3 push button hidden
to be honnest i am a little afraid as i am not sure what i have to type in next although i did make first a restore point.


Regards
RitaHubert
 

My Computer

System One

  • OS
    windows 8
    Computer type
    Laptop

my2cents

Veni, Vidi, Vici
VIP Member
Guru
Posts
2,191
#12
Hello;
Reply to topgundcp : no change after disabling it

Repyl to my2cents
after dispart /list volume i receive
vol 0 C Acer boot
1 Recovery hidden
2 ESP system
3 push button hidden
to be honnest i am a little afraid as i am not sure what i have to type in next although i did make first a restore point.


Regards
RitaHubert
Hello Rita,

Let me make it easy for you by following these simple steps:

open an elevated command prompt and type/enter sfc /scannow

Note: This will take some time to finish; however, once done, if errors are reported, do the following:

open (or same) elevated command prompt and type/enter Dism /Online /Cleanup-Image /RestoreHealth

Once done, reboot and see what happens.
 

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    CPU
    Intel G2020
    Motherboard
    ASRock B75M-DGS R2.0
    Memory
    8GBs @ 1333 MHz
    Hard Drives
    Samsung 840 EVO
    PSU
    400w
    Internet Speed
    57/11

topgundcp

Well-Known Member
VIP Member
Guru
San Jose - California

Posts
2,847
#13
Have you read my last post from the previous page ?
 

My Computer

System One

  • OS
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home Brewed
    CPU
    I7 4970K OC'ed @4.7 GHz
    Motherboard
    MSI-Z97
    Memory
    16 GB G-Skill Trident X @2400MHZ
    Graphics Card(s)
    NVIDIA GeForce GTS 450
    Sound Card
    X-Fi Titanium Fatal1ty Professional Series
    Monitor(s) Displays
    Dual HP-W2408
    Screen Resolution
    1920X1200
    Hard Drives
    256 GB M2 sm951, (2) 500GB 850EVO, 5TB, 2 TB Seagate
    PSU
    Antec 850W
    Case
    Antec 1200
    Cooling
    Danger Den H20
    Keyboard
    Logitech
    Mouse
    Logitech Performance Mouse MX
    Internet Speed
    35/12mbps
    Browser
    Firefox

ritahubert

Member
Member
Posts
37
#14
Hello, topgundcp & my2cent

-i executed the scan and it stopped at 58% with a fault which couldn't be solved
-afterwards the dism... and it wat corrected succesfully
-then i did run the scan again ....succesfully with some correction
-restarted the PC but unfortunally the same

Previously i had already stopped the Defender but neither i could make any change (topgundcp , i mentioned it in a previous combined answer but maybe you missed it)
I did it now again after the clean-up but no effect.

Additional information:
I saw that a few systemcomponents mentioned as "delayed start, triggerstart" have the same problem (al others are working).
Both are depended on the RPC but it is set as automatic (can neither be changed).

PS: i stated now that the startu-up time is by now much longer ...maybe due to more testing??

Regards
RitaHubert
 
Last edited:

My Computer

System One

  • OS
    windows 8
    Computer type
    Laptop

my2cents

Veni, Vidi, Vici
VIP Member
Guru
Posts
2,191
#15
Hello, topgundcp & my2cent

-i executed the scan and it stopped at 58% with a fault which couldn't be solved
-afterwards the dism... and it wat corrected succesfully
-then i did run the scan again ....succesfully with some correction
-restarted the PC but unfortunally the same

Previously i had already stopped the Defender but neither i could make any change (topgundcp , i mentioned it in a previous combined answer but maybe you missed it)
I did it now again after the clean-up but no effect.

Additional information:
I saw that a few systemcomponents mentioned as "delayed start, triggerstart" have the same problem (al others are working).
Both are depended on the RPC but it is set as automatic (can neither be changed).

PS: i stated now that the startu-up time is by now much longer ...maybe due to more testing??

Regards
RitaHubert
Just a side note, somewhat related to your latest "slow startup" issue. I was using Windows Defender and I had fast boot enabled on one of my 8.1 laptops and I noticed that my fast startup wasn't quite as fast as I expected. So, when Avast 8 finally announced a new release that was fully compatible with 8.0 and 8.1, I jumped at the chance to replace Defender. Now, I can safely say that my boot time has greatly improved and my fast boot is actually making a distinct difference. Please understand that I am not trying to encourage you to make the switch; however, if you cannot get your issue resolved by continuing to work with topguncp, you might be able to "kill two birds with one stone" by switching to Avast.
 
Last edited:

My Computer

System One

  • OS
    Windows 8.1
    Computer type
    PC/Desktop
    CPU
    Intel G2020
    Motherboard
    ASRock B75M-DGS R2.0
    Memory
    8GBs @ 1333 MHz
    Hard Drives
    Samsung 840 EVO
    PSU
    400w
    Internet Speed
    57/11

ritahubert

Member
Member
Posts
37
#16
Hello,

Thanks all for the technical information.
Some clean-up took place on the services but unfortunally the Defender problem wasn't solved , neither by stopping the function.

Also thanks for your advice but the little longer start-up (15 sec.) will be probably due to some corrupted services which are now being solved.

For your information only: without changing anything and after several restarts ...the laptob is again booting very fast.

Regards
RitaHubert
 

My Computer

System One

  • OS
    windows 8
    Computer type
    Laptop

topgundcp

Well-Known Member
VIP Member
Guru
San Jose - California

Posts
2,847
#17
What My2Cents advised you to do (run SFC & DISM) were to repair any corrupted files and indeed will help starting up Windows faster. Your original question is about Windows Defender not starting right away and due to recent Windows Updates, MS disabled the option to allow you to change the Startup Type from "Automatic delayed" to "Automatic".
 

My Computer

System One

  • OS
    8.1x64PWMC Ubuntu14.04x64 MintMate17x64
    Computer type
    PC/Desktop
    System Manufacturer/Model
    Home Brewed
    CPU
    I7 4970K OC'ed @4.7 GHz
    Motherboard
    MSI-Z97
    Memory
    16 GB G-Skill Trident X @2400MHZ
    Graphics Card(s)
    NVIDIA GeForce GTS 450
    Sound Card
    X-Fi Titanium Fatal1ty Professional Series
    Monitor(s) Displays
    Dual HP-W2408
    Screen Resolution
    1920X1200
    Hard Drives
    256 GB M2 sm951, (2) 500GB 850EVO, 5TB, 2 TB Seagate
    PSU
    Antec 850W
    Case
    Antec 1200
    Cooling
    Danger Den H20
    Keyboard
    Logitech
    Mouse
    Logitech Performance Mouse MX
    Internet Speed
    35/12mbps
    Browser
    Firefox

ritahubert

Member
Member
Posts
37
#18
Hello,
Thanks for your attention but i think i am not following quite well.
Indeed the initial question was and is still why can't i change the setting to automatic of the Defender.

I executed the sfc & Dim with success whereby some corrupted files were solved (again thanks), your proposal first to stop the defender but that didn't worked neither.

I mentioned afwards a short delay (which looked for me obvious) but now the start-up is again very fast (why the positive change i don't know).

If i understood you well than due to recent MS updates the function is disabled but than it is the case for everybody?

If i am totaly confused than sorry for it but nevertheless thanks again.

regards
RitaHubert
regards
 

My Computer

System One

  • OS
    windows 8
    Computer type
    Laptop

Hopachi

Polyhedric Stellation
VIP Member
Pro User
Orbiting the Moon

Posts
2,975
#19
But as explained already after a few minutes everthing is oké.
Hallo Rita,

I hope da's oké. :)


Normally Defender should be turned on and working without issues (I got that here too).

What most forget to point out is that other Antivirus programs need to be completely uninstalled in order for Defender to work. You need to uninstall any left overs of Norton, Mcaffee and others if this is the case (mostly with new PC's where the manufacturer installed extra programs).

If this isn't the case of extra AV programs installed, try to follow some of the posts above mine.

Good luck.
 

My Computer

System One

  • OS
    Windows 10 x64
    Computer type
    Laptop
    System Manufacturer/Model
    HP Envy DV6 7250
    CPU
    Intel i7-3630QM
    Motherboard
    HP, Intel HM77 Express Chipset
    Memory
    16GB
    Graphics Card(s)
    Intel HD4000 + Nvidia Geforce 630M
    Sound Card
    IDT HD Audio
    Monitor(s) Displays
    15.6' built-in + Samsung S22D300 + 17.3' LG Phillips
    Screen Resolution
    multiple resolutions
    Hard Drives
    Samsung SSD 250GB + Hitachi HDD 750GB
    PSU
    120W adapter
    Case
    small
    Cooling
    laptop cooling pad
    Keyboard
    Backlit built-in + big one in USB
    Mouse
    SteelSeries Sensei
    Internet Speed
    slow and steady
    Browser
    Chromium, Pale Moon, Firefox Developer Edition
    Antivirus
    Windows Defender
    Other Info
    That's basically it.

ritahubert

Member
Member
Posts
37
#20
Hello to all,

Sorry, I missed the comment of topgundcp that MS has changed recently via updates the possibility to change the setting to automatically.

That was indeed my understanding that everbody should have the greyed layout, although it seems that by hopachi it is oké..

I was thinking that maybe there is a difference between 8 en 8.1 (may some of you are using it), in Europe is is planned for october

Regards and again all thanks, i see herewith the thread as closed.
RitaHubert
 

My Computer

System One

  • OS
    windows 8
    Computer type
    Laptop

Users Who Are Viewing This Thread (Users: 0, Guests: 1)